1. Wyncher 13.05.19 13:04 Сейчас в теме

Выборка

Смотрю курс Иллеонтьева в ютубе. https://www.youtube.com/watch?v=64804e4NRXE&list=PL6Nx1KDcurkBdxssD1k56SDnwuTuX2bBr&index=­43 -остановился на этом видео. У него в коде всё работает. У меня же при выполнении кода -ошибка поле не обнаружено(сотрудник). Я по отладке посмотрел: записывается всё в переменную ВыборкаДетальныеЗаписи корректно,но не может вывести на экран поле сотрудник(в переменной есть поле сотрудник)
Прикрепленные файлы:
Ответы
Избранное Подписка Сортировка: Древо
2. alex-l19041 9 13.05.19 13:59 Сейчас в теме
4. user5300 34 13.05.19 14:07 Сейчас в теме
(1)попробуй так
... |ПриемНаРаботу.Проведен,
                | ПриемНаРаботу.Сотрудник КАК Сотрудник, 
...
...
Сообщить(ВыборкаДетальныеЗаписи.Сотрудник);
...
6. spacecraft 13.05.19 20:55 Сейчас в теме
(1) проверьте, что в слове Сотрудник все символы соответствуют русской раскладки в обоих местах. Может там английская буква C затесалась.
9. Wyncher 14.05.19 17:34 Сейчас в теме
3. ErshKUS 13.05.19 14:06 Сейчас в теме
Странно, поле вроде есть, попробуй добавить КАК Сотрудник , чтоб стало так
…
ПриёмНаРаботу.Сотрудник КАК Сотрудник,
...


и сделай скрин с ошибкой подробную
5. Wyncher 13.05.19 20:09 Сейчас в теме
(3)
о, поле вроде есть, попробуй добавить КАК Сотрудник , чтоб стало так
Прикрепленные файлы:
7. catena 99 14.05.19 05:42 Сейчас в теме
(5)Посимвольно сравнили? Копируйте сюда, будем сравнивать)
8. Wyncher 14.05.19 17:33 Сейчас в теме
(7)
Процедура КнопкаВыполнитьНажатие(Кнопка)
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ПриёмНаРаботу.Ссылка,
| ПриёмНаРаботу.ВерсияДанных,
| ПриёмНаРаботу.ПометкаУдаления,
| ПриёмНаРаботу.Номер,
| ПриёмНаРаботу.Дата,
| ПриёмНаРаботу.Проведен,
| ПриёмНаРаботу.Сотрудник как сотрудник,
| ПриёмНаРаботу.Должность,
| ПриёмНаРаботу.Подразделение,
| ПриёмНаРаботу.Оклад
|ИЗ
| Документ.ПриёмНаРаботу КАК ПриёмНаРаботу";

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Сообщить(ВыборкаДетальныеЗаписи.Cотрудник);
КонецЦикла;

Выгрузка = РезультатЗапроса.Выгрузить();
Для каждого Строка из Выгрузка цикл
Сообщить(Строка.Сотрудник);
КонецЦикла;

КонецПроцедуры
10. catena 99 14.05.19 17:42 Сейчас в теме
(8)ну, теперь нажми кнтрл+F, введи Сотрудник и убедись, что в этой строке явно что-то другое написано:
Сообщить(ВыборкаДетальныеЗаписи.Cотрудник)
11. Wyncher 14.05.19 20:47 Сейчас в теме
(10) Оу. Блин. Реально. Никак не моуг привыкнуть к странностям 1с(и сейчас даже не про другую раскладку)
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Ведущий программист 1С
Москва
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Программист 1С
Самара
зарплата от 50 000 руб. до 100 000 руб.
По совместительству


Ведущий программист 1С
Сочи
зарплата от 82 500 руб. до 99 000 руб.
Полный день