1. Asya.Ozerova 20.04.19 18:51 Сейчас в теме

СКД, как исключить из отбора Элементы и оставить только Группы справочника?

Добрый день!
Подскажите, как в СКД, в форму отбора попадали только Группы из Справочника? (т.е. исключить Элементы)
Заранее благодарна.
Прикрепленные файлы:
Ответы
Избранное Подписка Сортировка: Древо
2. independ 391 20.04.19 19:02 Сейчас в теме
(1) Вид сравнения: В Группе
3. Asya.Ozerova 20.04.19 19:05 Сейчас в теме
(2) Он и так стоит "В Группе", а при выборе дает выбирать все элементы и группы!
А надо только Группы
4. Asya.Ozerova 20.04.19 19:10 Сейчас в теме
(2) Точнее, надо чтоб Пользователь мог выбрать только Группу из справочника, а не элемент
5. independ 391 20.04.19 19:12 Сейчас в теме
(4) скорее всего нельзя, т.к. по умолчанию используется форма выбора элементов и групп
6. Asya.Ozerova 20.04.19 19:16 Сейчас в теме
(5)Уже второй день голову ломаю:( Думала, может что-то упускаю
7. independ 391 20.04.19 19:18 Сейчас в теме
(6) как вариант на форме отчета разместить выбор групп, и программно формировать отбор или использовать группу как необязательный параметр
8. Asya.Ozerova 20.04.19 19:23 Сейчас в теме
(7)Видимо так и придется делать, раз других вариантов нет :(
Спасибо!
9. Asya.Ozerova 20.04.19 21:44 Сейчас в теме
(7)Вот что-то нашла, но все равно открывает все элементы
Хм...
Прикрепленные файлы:
10. independ 391 20.04.19 21:46 Сейчас в теме
(9) так это для параметров, а у вас отбор
11. Asya.Ozerova 20.04.19 21:49 Сейчас в теме
(10)Он и в параметрах тоже все элементы открывает, думала так сделать
12. independ 391 20.04.19 21:50 Сейчас в теме
(11) значит так надо, или ошибка
13. Asya.Ozerova 20.04.19 21:54 Сейчас в теме
(12)Кому надо!? Мне не надо!
Я понимаю, что ошибка, но не понимаю где!
Прикрепленные файлы:
14. Asya.Ozerova 20.04.19 22:01 Сейчас в теме
Я уже все отборы удалила, остались только Параметры.
15. independ 391 21.04.19 07:08 Сейчас в теме
Можно отработать событие Выбор у элемента формы - отбор, примерно так

Процедура ТЗОтборВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
	Если ВыбраннаяСтрока.ЛевоеЗначение=Новый ПолеКомпоновкиДанных("Номенклатура") 
		И Колонка.Имя="ПравоеЗначениеДляКраткогоОтображенияЭлемента" Тогда
		СтандартнаяОбработка=Ложь;
		Форма=Справочники.Номенклатура.ПолучитьФормуВыбораГруппы();
		ПравоеЗначение=Форма.ОткрытьМодально();
		Если ЗначениеЗаполнено(ПравоеЗначение) Тогда
			ВыбраннаяСтрока.ПравоеЗначение=ПравоеЗначение;
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры
Показать
18. Asya.Ozerova 24.04.19 23:30 Сейчас в теме
(15)Спасибо!
Не совсем то, что я хотела!
Хотелось использовать только ресурсы СКД! Буду искать дальше...
independ большое спасибо!
20. Asya.Ozerova 25.04.19 01:14 Сейчас в теме
16. user750322 21.04.19 15:47 Сейчас в теме
Сделать форму выбора с динамическим списком, в его произвольном запросе установить отбор: это группа = истина
17. meriferi 21.04.19 18:20 Сейчас в теме
СКД настраивается в конфигураторе. Конфигуратор знает максимум предопределённые элементы, о заведённых пользователями элементах - он ничего не знает. Соответственно, в явном веде указать ссылки на элемент - нельзя
19. Asya.Ozerova 24.04.19 23:31 Сейчас в теме
(17)Не совсем Вас поняла, точнее "Я Вас не поняла совсем!"
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата до 120 000 руб.
Полный день

Работа от Инфостарт
Санкт-Петербург
Временный (на проект)

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Ведущий программист 1С
Москва
зарплата от 120 000 руб. до 150 000 руб.
Полный день