1. zayden 16 19.04.19 10:55 Сейчас в теме

Ошибка перед обновлением "Справочники.ДоговорыКонтрагентов.ЗаполнитьСпособЗаполненияСтавкиНДС"

БП 3.0
Перед обновлением зашел в Резульататы обновления и что увидел:
Обнавлять пока не стал - что с этим делать?
Процедура "Справочники.ДоговорыКонтрагентов.ЗаполнитьСпособЗаполненияСтавкиНДС" обработки данных завершилась с ошибкой:

{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(5171)}: Превышено допустимое количество запусков процедуры обновления.
Выполнение прервано для предотвращения зацикливания механизма обработки данных.
ВызватьИсключение ТекстОшибки;
Ответы
Избранное Подписка Сортировка: Древо
2. darkmessiahan 34 19.04.19 11:09 Сейчас в теме
Закомментировать код, обновить, изменить ставку через групповое изменение справочник и реквизитов
3. darkmessiahan 34 19.04.19 11:25 Сейчас в теме
В процедурах обновления у вас сейчас что?
4. zayden 16 19.04.19 11:31 Сейчас в теме
5. zayden 16 19.04.19 11:32 Сейчас в теме
5171 строка говорит ток о зацикливании а как вообще проверку эту исключить?
6. darkmessiahan 34 19.04.19 11:39 Сейчас в теме
Сделайте резервную копию,
попробуйте ТИИ (Тестирование и исправление из конфигуратора)
если не поможет, закомментируйте текст процедуры

Процедура ЗаполнитьСпособЗаполненияСтавкиНДС(Параметры) Экспорт

	Параметры.ОбработкаЗавершена = Ложь;

	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ДоговорыКонтрагентов.Ссылка КАК Договор,
	|	ДоговорыКонтрагентов.Владелец КАК Контрагент
	|ИЗ
	|	Справочник.ДоговорыКонтрагентов КАК ДоговорыКонтрагентов
	|ГДЕ
	|	ДоговорыКонтрагентов.ПометкаУдаления = ЛОЖЬ
	|	И ДоговорыКонтрагентов.ЭтоГруппа = ЛОЖЬ
	|	И ДоговорыКонтрагентов.ВидДоговора В(&СписокВидовДоговоров)
	|	И ДоговорыКонтрагентов.СпособЗаполненияСтавкиНДС = ЗНАЧЕНИЕ(Перечисление.СпособыЗаполненияСтавкиНДС.ПустаяСсылка)";

	СписокВидовДоговоров = Новый Массив;
	СписокВидовДоговоров.Добавить(Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком);
	СписокВидовДоговоров.Добавить(Перечисления.ВидыДоговоровКонтрагентов.СФакторинговойКомпанией);
	СписокВидовДоговоров.Добавить(Перечисления.ВидыДоговоровКонтрагентов.СКомитентом);
	СписокВидовДоговоров.Добавить(Перечисления.ВидыДоговоровКонтрагентов.СКомиссионеромНаЗакупку);
	СписокВидовДоговоров.Добавить(Перечисления.ВидыДоговоровКонтрагентов.СКомиссионером);
	
	Запрос.УстановитьПараметр("СписокВидовДоговоров", СписокВидовДоговоров);
	ТаблицаДоговоров = Запрос.Выполнить().Выгрузить();

	Если ТаблицаДоговоров.Количество() = 0 Тогда
		Параметры.ОбработкаЗавершена = Истина;
		Возврат;
	КонецЕсли;
	
	Для каждого ВыборкаДоговоров Из ТаблицаДоговоров Цикл
	
		СправочникОбъект = ВыборкаДоговоров.Договор.ПолучитьОбъект();
		Если СправочникОбъект.УдалитьПредъявляетНДС 
			ИЛИ СправочникОбъект.УчетАгентскогоНДС Тогда
			СправочникОбъект.СпособЗаполненияСтавкиНДС = Перечисления.СпособыЗаполненияСтавкиНДС.Автоматически;
		Иначе
			СправочникОбъект.СпособЗаполненияСтавкиНДС = Перечисления.СпособыЗаполненияСтавкиНДС.БезНДС;
		КонецЕсли;
		
		Попытка
			ОбновлениеИнформационнойБазы.ЗаписатьОбъект(СправочникОбъект);
		Исключение
			ТекстСообщения = НСтр("ru = 'Не удалось установить ""Заполнение ставки НДС в документах"" для договора %1 контрагента %2, рекомендуется самостоятельно установить необходимое значение'");
			ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ТекстСообщения, ВыборкаДоговоров.Договор, ВыборкаДоговоров.Контрагент);
			ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);
		КонецПопытки;

	КонецЦикла

КонецПроцедуры
Показать
7. zayden 16 19.04.19 11:42 Сейчас в теме
(6) а где эта процедура? Лежит в каком модуле?
8. darkmessiahan 34 19.04.19 11:55 Сейчас в теме
(7) так ж написано же Справочники.ДоговорыКонтрагентов
Модуль менеджера
И вам комментировать только внутренности)
Процедура ЗаполнитьСпособЗаполненияСтавкиНДС(Параметры) Экспорт

	//Параметры.ОбработкаЗавершена = Ложь;

	//Запрос = Новый Запрос;
	//Запрос.Текст = 
	//"ВЫБРАТЬ
	//|    ДоговорыКонтрагентов.Ссылка КАК Договор,
	//|    ДоговорыКонтрагентов.Владелец КАК Контрагент
	//|ИЗ
	//|    Справочник.ДоговорыКонтрагентов КАК ДоговорыКонтрагентов
	//|ГДЕ
	//|    ДоговорыКонтрагентов.ПометкаУдаления = ЛОЖЬ
	//|    И ДоговорыКонтрагентов.ЭтоГруппа = ЛОЖЬ
	//|    И ДоговорыКонтрагентов.ВидДоговора В(&СписокВидовДоговоров)
	//|    И ДоговорыКонтрагентов.СпособЗаполненияСтавкиНДС = ЗНАЧЕНИЕ(Перечисление.СпособыЗаполненияСтавкиНДС.ПустаяСсылка)";

	//СписокВидовДоговоров = Новый Массив;
	//СписокВидовДоговоров.Добавить(Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком);
	//СписокВидовДоговоров.Добавить(Перечисления.ВидыДоговоровКонтрагентов.СФакторинговойКомпанией);
	//СписокВидовДоговоров.Добавить(Перечисления.ВидыДоговоровКонтрагентов.СКомитентом);
	//СписокВидовДоговоров.Добавить(Перечисления.ВидыДоговоровКонтрагентов.СКомиссионеромНаЗакупку);
	//СписокВидовДоговоров.Добавить(Перечисления.ВидыДоговоровКонтрагентов.СКомиссионером);
	//
	//Запрос.УстановитьПараметр("СписокВидовДоговоров", СписокВидовДоговоров);
	//ТаблицаДоговоров = Запрос.Выполнить().Выгрузить();

	//Если ТаблицаДоговоров.Количество() = 0 Тогда
	//    Параметры.ОбработкаЗавершена = Истина;
	//    Возврат;
	//КонецЕсли;
	//
	//Для каждого ВыборкаДоговоров Из ТаблицаДоговоров Цикл
	//
	//    СправочникОбъект = ВыборкаДоговоров.Договор.ПолучитьОбъект();
	//    Если СправочникОбъект.УдалитьПредъявляетНДС 
	//        ИЛИ СправочникОбъект.УчетАгентскогоНДС Тогда
	//        СправочникОбъект.СпособЗаполненияСтавкиНДС = Перечисления.СпособыЗаполненияСтавкиНДС.Автоматически;
	//    Иначе
	//        СправочникОбъект.СпособЗаполненияСтавкиНДС = Перечисления.СпособыЗаполненияСтавкиНДС.БезНДС;
	//    КонецЕсли;
	//    
	//    Попытка
	//        ОбновлениеИнформационнойБазы.ЗаписатьОбъект(СправочникОбъект);
	//    Исключение
	//        ТекстСообщения = НСтр("ru = 'Не удалось установить ""Заполнение ставки НДС в документах"" для договора %1 контрагента %2, рекомендуется самостоятельно установить необходимое значение'");
	//        ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ТекстСообщения, ВыборкаДоговоров.Договор, ВыборкаДоговоров.Контрагент);
	//        ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);
	//    КонецПопытки;

	//КонецЦикла

КонецПроцедуры
Показать
9. darkmessiahan 34 19.04.19 11:56 Сейчас в теме
(7) Вы тестирование и исправление то попробовали?
10. zayden 16 19.04.19 11:59 Сейчас в теме
12. zayden 16 19.04.19 12:42 Сейчас в теме
13. WWWWW 19.04.19 23:09 Сейчас в теме
У меня способ заполнения ставки тоже ни где не указан, если зайти в договор и попытаться пересохранить, указывает на это и пока не заполнишь не сохраняет((
14. meriferi 21.04.19 18:33 Сейчас в теме
тоже такая ошибка после обновления БП
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата до 120 000 руб.
Полный день

Работа от Инфостарт
Санкт-Петербург
Временный (на проект)

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Ведущий программист 1С
Сочи
зарплата от 82 500 руб. до 99 000 руб.
Полный день