1. ArBot 19.04.19 10:07 Сейчас в теме

Как изменить доступность строки табличной части?

Здравствуйте, вопрос в следующем.
Есть у меня в тч 3 строки:
\
Вид                       Данные
Адрес                     какойтоадрес
Телефон                   какойтотелефон
Информация               


и в строке информация необходимо колонке данные ставить доступность = ложь, если колонка данные в строке телефон не заполнен?
Ответы
Избранное Подписка Сортировка: Древо
3. noprogrammer 123 19.04.19 10:21 Сейчас в теме
(1) Либо попробовать реализовать через "Условное оформление" либо просто "ПередНачаломИзменения" проверять и устанавливать "Отказ=Истина"
5. MaxxiMiliSan 86 19.04.19 10:40 Сейчас в теме
(3) через условное оформление
4. ArBot 19.04.19 10:38 Сейчас в теме
6. ksen 19.04.19 10:55 Сейчас в теме
(4)как то так
Процедура ТабличноеПоле1ПередНачаломИзменения(Элемент, Отказ)
    Если Элемент.ТекущаяКолонка.Имя = "название колонки" Тогда
        ТекСтрока = Элемент.ТекущиеДанные;
        Если Не ТекСтрока.название колонки для провери <> Неопределено Тогда
            Отказ = Истина;
        КонецЕсли; 
    КонецЕсли; 
КонецПроцедуры
7. ArBot 19.04.19 11:03 Сейчас в теме
(6)В тч строки заносятся программно, их не добавляют, при создании на сервере они уже есть.
надо проверять строку 2 на заполненность, и давать доступность строке 3.
8. ksen 19.04.19 11:06 Сейчас в теме
9. ArBot 19.04.19 11:16 Сейчас в теме
(8)Поле объекта не обнаружено текущаяколонка
В этом коде проверка идет в одной строке, если текущая колонка тогда тек строка, мне не нужна тек строка
мне надо:
Если В строке 2 колонка Данные не заполнена, Тогда
в строке 3 колонка данные не доступна.
10. ksen 19.04.19 11:28 Сейчас в теме
(9)невнимательно прочитал, скиньте скриншот
11. ArBot 19.04.19 11:34 Сейчас в теме
12. ksen 19.04.19 11:38 Сейчас в теме
(11)создать 2 проверки
1) при открытии документа, если заполнено то дать доступность
2) при изменении поля если изменили на не пустое давать доступность, если изменили на пустое очищать и забирать доступность в чем возникает сложность?
13. ArBot 19.04.19 11:40 Сейчас в теме
(12)в том что я не знаю как дать доступность определенной строке исходя из другой?
ведь эти строки не добавляются, они программно там уже созданы.
14. ksen 19.04.19 11:46 Сейчас в теме
(13)
1)документ либо уже создан в базе и заполнен, тогда можно заглянуть в нужное поле в процедуре приоткрытии и изменить доступность
2)документ только создан и по умолчанию в этой же процедуре блокировать доступность поля
15. ArBot 19.04.19 11:57 Сейчас в теме
(14)
	СтрокаКИ = Объект.КонтактнаяИнформация.Добавить();
			СтрокаКИ.Тип = Перечисления.ТипыКонтактнойИнформации.Адрес;
			СтрокаКИ.Вид = Справочники.ВидыКонтактнойИнформации.АдресДляИнформированияКонтактныеЛица;
			СтрокаКИ.ВидОтправителяПолучателя = Перечисления.ВидОправленияПолучения.Получатель;
			СтрокаКИ.Страна = ПредопределенноеЗначение("Справочник.КлассификаторСтранМира.РОССИЯ");
			
			СтрокаКИ = Объект.КонтактнаяИнформация.Добавить();
			СтрокаКИ.Тип = Перечисления.ТипыКонтактнойИнформации.Телефон;
			СтрокаКИ.Вид = Справочники.ВидыКонтактнойИнформации.ТелефонМобильныйКонтактныеЛица;
			СтрокаКИ.ВидОтправителяПолучателя = Перечисления.ВидОправленияПолучения.Получатель;
			СтрокаКИ.Страна = ПредопределенноеЗначение("Справочник.КлассификаторСтранМира.РОССИЯ");	
			
			СтрокаКИ = Объект.КонтактнаяИнформация.Добавить();
			СтрокаКИ.Тип = Перечисления.ТипыКонтактнойИнформации.Информация;
			СтрокаКИ.Вид = Справочники.ВидыКонтактнойИнформации.ДругаяИнформацияКонтактныеЛица;
			СтрокаКИ.ВидОтправителяПолучателя = Перечисления.ВидОправленияПолучения.Получатель;
			СтрокаКИ.Страна = ПредопределенноеЗначение("Справочник.КлассификаторСтранМира.РОССИЯ");
			
			
			СтрокаКИ = Объект.КонтактнаяИнформация.Добавить();
			СтрокаКИ.Тип = Перечисления.ТипыКонтактнойИнформации.Адрес;
			СтрокаКИ.Вид = Справочники.ВидыКонтактнойИнформации.АдресДляИнформированияКонтактныеЛица;
			СтрокаКИ.ВидОтправителяПолучателя = Перечисления.ВидОправленияПолучения.Отправитель;
			СтрокаКИ.Страна = ПредопределенноеЗначение("Справочник.КлассификаторСтранМира.РОССИЯ");
			
			СтрокаКИ = Объект.КонтактнаяИнформация.Добавить();
			СтрокаКИ.Тип = Перечисления.ТипыКонтактнойИнформации.Телефон;
			СтрокаКИ.Вид = Справочники.ВидыКонтактнойИнформации.ТелефонМобильныйКонтактныеЛица;
			СтрокаКИ.ВидОтправителяПолучателя = Перечисления.ВидОправленияПолучения.Отправитель;
			СтрокаКИ.Страна = ПредопределенноеЗначение("Справочник.КлассификаторСтранМира.РОССИЯ");
			
			СтрокаКИ = Объект.КонтактнаяИнформация.Добавить();
			СтрокаКИ.Тип = Перечисления.ТипыКонтактнойИнформации.Информация;
			СтрокаКИ.Вид = Справочники.ВидыКонтактнойИнформации.ДругаяИнформацияКонтактныеЛица;
			СтрокаКИ.ВидОтправителяПолучателя = Перечисления.ВидОправленияПолучения.Отправитель;
			СтрокаКИ.Страна = ПредопределенноеЗначение("Справочник.КлассификаторСтранМира.РОССИЯ");
Показать

и как тут это можно сделать?
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата до 120 000 руб.
Полный день

Работа от Инфостарт
Санкт-Петербург
Временный (на проект)

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Ведущий программист 1С
Москва
зарплата от 120 000 руб. до 150 000 руб.
Полный день