1. Mister_1C 18.04.19 17:56 Сейчас в теме

Дата

Здравствуйте, вопрос возник. Как запретить ввод прошлой даты?
Ответы
Избранное Подписка Сортировка: Древо
5. PhoenixAOD 57 19.04.19 07:25 Сейчас в теме
(1)Я бы предложил обратить внимание на механизм Дата запрета редактирования для начала, а потом уже костыли вклинивать.
12. ishelper 19.04.19 10:45 Сейчас в теме
(1)
Здравствуйте, вопрос возник. Как запретить ввод прошлой даты?
Приказом по предприятию. И штрафовать за его нарушение.

P.S. Какой вопрос - такой ответ.
2. platonov.e 3 18.04.19 18:05 Сейчас в теме
А что для вас прошлая дата?
3. Sander80 68 18.04.19 18:11 Сейчас в теме
4. nikita0832 173 18.04.19 18:39 Сейчас в теме
&НаКлиенте
Процедура ДатаПриИзменении(Элемент)
Если Дата<ТекущаяДата() Тогда
Дата = ТекущаяДата();
КонецЕсли;
КонецПроцедуры
SedovSU@mail.ru; +1 Ответить
7. QuickMix 19.04.19 09:19 Сейчас в теме
(4)можно просто системную дату сдвинуть назад на клиентской машине, и условие работать не будет.
8. login1020 28 19.04.19 09:27 Сейчас в теме
(7) Возвращать ТекущуюДату с сервера

&НаСервереБезКонтекста
Функция АктуальнаяДатаСервера()
Возврат ТекущаяДата();
КонецФункции


а вообще вот О времени и 1С
9. nikita0832 173 19.04.19 09:28 Сейчас в теме
(7)в этом случае в модуле объекта перед записью, но по идее чем раньше сказали об ошибке, тем лучше. вообще правильней не давать пользователям права менять системную дату, это вопрос к админу.
11. QuickMix 19.04.19 10:36 Сейчас в теме
(9)веб-клиентам тоже будете права ограничивать, чтобы они не могли дату менять на компьютере?
10. uk09 19.04.19 10:03 Сейчас в теме
(7)
В домене, с правильной политикой - не прокатит, юзеру сдвинуть дату. Рабочие группы с файл-сервером, не рассматриваем
6. uk09 19.04.19 08:37 Сейчас в теме
Добрый день!

Запрет ввода прошлой даты или документа с прошлой датой ?
Запрещать ввод прошлой даты имеет ли смысл ?
Всегда есть события прошедшего периода, которые требуют отражения ( например документы от поставщика)
Для УТ в справочнике "Пользователи " можно разграничить полномочия по группам с разной датой запрета.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата до 120 000 руб.
Полный день

Работа от Инфостарт
Санкт-Петербург
Временный (на проект)

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 115 000 руб. до 160 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день