1. newbigrator 18.04.19 11:22 Сейчас в теме

Добавление колонки в Динамический список (ОсновнаяТаблица)

Добрый день,

Пытаюсь решить казалось бы простую задачу.
Берем любую конфу на 8.3.
Требуется добавить колонку в форму списка и заполнять ее произвольным текстом.

Деталь состоит в том, что для Динамического списка задана ОсновнаяТаблица.
И вот в таком случае у меня проблема, не понимаю как обойти ограничение, колонка не добавляется, не появляется.

Задача легко решается для случая Произвольного запроса, но я не хочу изменять это свойство.
Неужели никак не обойти это ограничение?
Ответы
Избранное Подписка Сортировка: Древо
2. dhurricane 18.04.19 11:36 Сейчас в теме
(1) Так что за колонка? Если это не поле основной таблицы, не реквизит какого-либо поля, а также не значение характеристики, то действительно, добавить не меняя запрос не получится.

Можно разве что попробовать подменить одно значение другим. Вытянуть на форму любую возможную колонку, а в обработчике события "ПриПолученииДанныхНаСервере" динамического списка получить нужные значения и подставить их в новую колонку.
3. newbigrator 18.04.19 11:49 Сейчас в теме
(2) Воооот. Все так, я пытался таким способом делать.
Но в событии СписокПриПолученииДанныхНаСервере не могу добраться до колонки.

пытаюсь добраться кодом

КлючиРегистра = Строки.ПолучитьКлючи();
	
Для Каждого Ключ Из КлючиРегистра Цикл
		
	СтрокаСписка = Строки[Ключ];
		
КонецЦикла;
5. dhurricane 18.04.19 12:17 Сейчас в теме
(3) Что из себя представляет эта колонка? Она отображается на форме? Что за основная таблица?
4. tusv 148 18.04.19 11:56 Сейчас в теме
(1) В догонку к (2) . Теоретически. в настройки списка добавить какой нибудь Параметр со списком значений, Значение -Ссылка, представление - Введенное значение, а в ПриПолученииДанныхНаСервере проверять и дополнять. Пример работы ПриПолученииДанныхНаСервере в Зазеркалье. Только это же на один сеанс открытия формы
6. newbigrator 18.04.19 12:27 Сейчас в теме
(4) (5) Колонка со статичным текстом. Суть моего вопроса - можно ли сделать такое, не используя Произвольный запрос.
Говоря ОсновнаяТаблица имею ввиду что для свойства Динамического списка задана ОсновнаяТаблица Документ.ИмяДокумента.
7. dhurricane 18.04.19 12:44 Сейчас в теме
(6) Не понимаю, где именно возникла сложность с использованием обработчика события "ПриПолученииДанныхНаСервере". Приведу свой пример.

Основная таблица: регистр сведений "УчетнаяПолитика". Единственное измерение - организация. Требуется вывести ее префикс с использованием вышеобозначенного события.

Итак, при создании формы добавляем элемент для вывода своего значения. В качестве примера я взял колонку ссылочного типа (что только усложнило задачу):
Элемент = Элементы.Добавить("СписокМоеЗначение", Тип("ПолеФормы"), Элементы.Список);
Элемент.ПутьКДанным = "Список.ОсновнойСчетУчетаЗатрат";
Элемент.Заголовок = "Мое значение";

Реализация обработчика получения данных динамического списка:
Процедура СписокПриПолученииДанныхНаСервере(ИмяЭлемента, Настройки, Строки)
	
	МассивСсылок = ОбщегоНазначения.ВыгрузитьКолонку(Строки.ПолучитьКлючи(), "Организация");
	
	РеквизитыСсылок = ОбщегоНазначения.ЗначенияРеквизитовОбъектов(МассивСсылок, "Префикс");
	
	Для каждого Элемент Из Строки Цикл
		
		Ссылка = Элемент.Значение.Данные["Организация"];
		
		ОформлениеЯчейки = Элемент.Значение.Оформление["ОсновнойСчетУчетаЗатрат"];
		ОформлениеЯчейки.УстановитьЗначениеПараметра("Текст", РеквизитыСсылок[Ссылка].Префикс);
		
	КонецЦикла; 
	
КонецПроцедуры
Показать

Все работает, в колонке "Мое значение" вижу префиксы вместо счетов бух. учета.
8. newbigrator 18.04.19 13:46 Сейчас в теме
(7) Не прокатывает..
В коллекции Элемент.Значение.Оформление нет добавленного поля, пробоавал и программно и вручную. Добавляю колонку, связываю ее с имеющимся реквизитом и хочу подменить, но в коллекции ее нет!
9. newbigrator 18.04.19 13:51 Сейчас в теме
(7) (8)

Я понял.. подменяемая колонка, должна содержать значение еще не выведенного реквизита.
К примеру если в форме списка уже Номер выведен, то через него сделать колонку, а потом подменить не получится. Нужно чтобы был какой то другой еще не выведенный, но сидящей в основной таблице реквизит.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата до 120 000 руб.
Полный день

Работа от Инфостарт
Санкт-Петербург
Временный (на проект)

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Ведущий программист 1С
Сочи
зарплата от 82 500 руб. до 99 000 руб.
Полный день