1. user1200515 18.04.19 09:31 Сейчас в теме

Загрузить результат запроса в таблицу значений на форме

В документе есть таблица значений, необходимо в нее загрузить значения справочника, делаю через запрос, выдает ошибку
&НаКлиенте
Процедура ИсторияИзмененияПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа, Параметр)
ТабЗнач();

КонецПроцедуры

&НаСервере
Функция   ТабЗнач()
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               |    ФизическиеЛица.Наименование
               |ИЗ
               |    Справочник.ФизическиеЛица КАК ФизическиеЛица";
Результат=Запрос.Выполнить().Выгрузить();
//ИсторияИзменения.Загрузить(Запрос.Выполнить().Выгрузить());
//Результат.Колонки.Добавить("Дата");
//Результат.ЗаполнитьЗначения(ТекущаяДата(),"Дата");
//ИсторияИзменения.Загрузить ("Результат");
ЗначениеВРеквизитФормы(Результат,"ИсторияИзменения")
КонецФункции
Показать

ИсторияИзменения-Таблица значений на форме
Ошибка-ЗначениеВРеквизитФормы(Результат,"ИсторияИзменения")
по причине:
Недопустимое значение параметра (параметр номер '2')
Ответы
Избранное Подписка Сортировка: Древо
2. user1200515 18.04.19 09:36 Сейчас в теме
Делаю так, добавляются пустые строки
ИсторияИзменения.Загрузить(Запрос.Выполнить().Выгрузить());
8. Oldsad 18.04.19 09:56 Сейчас в теме
(2)

Пустые строки добавляются потому что не совпадают имена полей и/или типы полей

Как минимум должны совпадать имена полей
Типы желательно тоже, т.к. например результатом преобразования строки (наименование) в ссылку физлица будет пустая ссылка
3. user614822 25 18.04.19 09:36 Сейчас в теме
Вот Это было првильной идеей -= зачем переделали???
//ИсторияИзменения.Загрузить(Запрос.Выполнить().Выгрузить());
SedovSU@mail.ru; +1 Ответить
5. user1200515 18.04.19 09:39 Сейчас в теме
(3)Делаю так, добавляются пустые строки
В таблице значений 2 колонки
Ответственный-тип ссылка на справочник физ лиц
и Дата -тип дата
Может из-за этого пустые строки?
7. SedovSU@mail.ru 292 18.04.19 09:42 Сейчас в теме
(5) вот так попробуйте у вас должно все работать

&НаСервере
Функция ТабЗнач()
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| ФизическиеЛица.Ссылка КАК Наименование
|ИЗ
| Справочник.ФизическиеЛица КАК ФизическиеЛица";
Результат=Запрос.Выполнить().Выгрузить();

ИсторияИзменения.Загрузить(Результат);
ИсторияИзменений.Колонки.Добавить("Дата");
ИсторияИзменений.ЗаполнитьЗначения(ТекущаяДата(),"Дата");

КонецФункции
user614822; +1 Ответить
4. user614822 25 18.04.19 09:38 Сейчас в теме
Только ИсторияИзменения - должна быть Табличной частью вашего Объекта и путем к данным на форме
6. SedovSU@mail.ru 292 18.04.19 09:39 Сейчас в теме
У вас написан верный код уже ИсторияИзменения.Загрузить(Запрос.Выполнить().Выгрузить());
9. uk09 18.04.19 11:20 Сейчас в теме
Добрый день!

В своем отчете делаю так:

	Запрос.Текст = "ВЫБРАТЬ
                ........";
	Запрос.Параметры.Вставить("НачалоПериода",НачалоГода(ТекущаяДата());
	Запрос.Параметры.Вставить("КонецПериода",ТекущаяДата());
	ТаблицаЗвезд = РеквизитФормыВЗначение("Звезды");
	ТаблицаЗвезд = Запрос.Выполнить().Выгрузить();
	ЗначениеВРеквизитФормы(ТаблицаЗвезд, "Звезды");
Показать

т.е. до преобразования значения, предварительно, преобразую реквизит формы в объект
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата до 120 000 руб.
Полный день

Работа от Инфостарт
Санкт-Петербург
Временный (на проект)

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Ведущий программист 1С
Сочи
зарплата от 82 500 руб. до 99 000 руб.
Полный день