1. furman2000 12 18.04.19 08:10 Сейчас в теме

Индикатор прогресса на управляемых формах

Доброго времени суток всем.
Встал вопрос как на управляемых формах нарисовать индикатор выполнения.
В гугле был, тут тоже скачал пару обработок. Но что то не получается.

И так
&НаКлиенте
Процедура ПровестиРеализации(Команда)

	ПровестиРеализацииНаСервере();
	
КонецПроцедуры

&НаСервере
Процедура ПровестиРеализацииНаСервере()
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	РеализацияТоваровУслуг.Ссылка КАК Ссылка
		|ИЗ
		|	Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
		|ГДЕ
		|	РеализацияТоваровУслуг.Проведен = ИСТИНА
		|	И РеализацияТоваровУслуг.Дата >= &ДатаНач
		|	И РеализацияТоваровУслуг.Дата <= &ДатаКон";
	
	Запрос.УстановитьПараметр("ДатаНач", НачалоДня(Объект.НачалоПериода));
	Запрос.УстановитьПараметр("ДатаКон", КонецДня(Объект.КонецПериода));
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

		//???? тут надо отправить данные в индикатор?????

		ИзменитьСчет(ВыборкаДетальныеЗаписи.Ссылка);

	КонецЦикла;

КонецПроцедуры



Показать


Подскажите как???
Или ссылкой киньте в меня.
Найденные решения
10. Oldsad 18.04.19 09:17 Сейчас в теме
существенное ограничение, работает только на локальном сервере через файл-открыть
что бы заработало на другом сервере, надо добавлять во внешние обработки
Прикрепленные файлы:
ШаблонОбработки_КакФоновоеЗадание_ДляДлительныхОпераций_ПрогрессБар.epf
rabota.v8.1c; furman2000; serg7777; +3 Ответить
Остальные ответы
Избранное Подписка Сортировка: Древо
5. DNN13 8 18.04.19 08:57 Сейчас в теме
(1) Свою форму с индикатором, на клиенте изменяйте индикатор, на сервере порциями выполняйте действия
6. furman2000 12 18.04.19 09:01 Сейчас в теме
11. Xershi 559 18.04.19 09:19 Сейчас в теме
(1) ключевой фишкой прогресса является реквизиты на форме. Как сделано в обработке по удалению помеченных объектов.
Иначе только кружок о выполнении.
Если на клиенте делать, то состояние подойдет, но обычно все операции на сервере.
2. signum2009 664 18.04.19 08:36 Сейчас в теме
3. furman2000 12 18.04.19 08:42 Сейчас в теме
Читал про это. Но все дело в том, что я не могу создать фоновое задание.
Это все во внешней обработке находится.
4. noprogrammer 123 18.04.19 08:52 Сейчас в теме
а просто через Состояние(...) ?
7. furman2000 12 18.04.19 09:03 Сейчас в теме
(4) Оно (СОСТОЯНИЕ) должно быть на клиенте. как его вызвать на сервере???
8. Oldsad 18.04.19 09:07 Сейчас в теме
общий модуль ДлительныеОперации

работает в том числе и с внешними обработками

но если раньше не работал с фоновыми заданиями на управляемых формах, то разобраться будет непросто

проще взять готовый пример с прогресс баром, и допилить его под себя
9. furman2000 12 18.04.19 09:09 Сейчас в теме
(8)Ссылку на готовый можете дать?
10. Oldsad 18.04.19 09:17 Сейчас в теме
существенное ограничение, работает только на локальном сервере через файл-открыть
что бы заработало на другом сервере, надо добавлять во внешние обработки
Прикрепленные файлы:
ШаблонОбработки_КакФоновоеЗадание_ДляДлительныхОпераций_ПрогрессБар.epf
rabota.v8.1c; furman2000; serg7777; +3 Ответить
12. furman2000 12 18.04.19 10:28 Сейчас в теме
(10)Пошел изучать вашу обработку. Спасибо.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата до 120 000 руб.
Полный день

Работа от Инфостарт
Санкт-Петербург
Временный (на проект)

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Ведущий программист 1С
Москва
зарплата от 120 000 руб. до 150 000 руб.
Полный день