1. Mister_1C 15.04.19 16:12 Сейчас в теме

Документы

Здравствуйте, возник вопрос. Как сделать так что бы документ нельзя было провести задним числом?
Найденные решения
3. darkmessiahan 32 15.04.19 16:29 Сейчас в теме
В новых конфигурациях есть дата запрета - вчерашний день

В старых, в настройках ролей убрать Оперативной проведение
или код для ленивых
Процедура ОбработкаПроведения(Отказ, РежимПроведения)

Если  НЕ РольДоступна("ПолныеПрава") И Дата < НачалоДня(ТекущаяДата()) тогда
	Отказ = Истина;
		Сообщить("Только избранные могут проводить Реализации прошлого периода.");
	КонецЕсли;
//остальной код процедуры
КонецПроцедуры // ОбработкаПроведения()
Показать
YanTsys; acanta; +2 Ответить
Остальные ответы
Избранное Подписка Сортировка: Древо
2. GeraltSnow 77 15.04.19 16:14 Сейчас в теме
Запретить пользователю неоперативное проведение
3. darkmessiahan 32 15.04.19 16:29 Сейчас в теме
В новых конфигурациях есть дата запрета - вчерашний день

В старых, в настройках ролей убрать Оперативной проведение
или код для ленивых
Процедура ОбработкаПроведения(Отказ, РежимПроведения)

Если  НЕ РольДоступна("ПолныеПрава") И Дата < НачалоДня(ТекущаяДата()) тогда
	Отказ = Истина;
		Сообщить("Только избранные могут проводить Реализации прошлого периода.");
	КонецЕсли;
//остальной код процедуры
КонецПроцедуры // ОбработкаПроведения()
Показать
YanTsys; acanta; +2 Ответить
4. user-z99999 18 15.04.19 16:34 Сейчас в теме
(3)
Если Дата < НачалоДня(ТекущаяДата()) тогда

Может в этом моменте нужно заморочится?
ТекущаяДата - это дата у пользователя на компьютере. Она может быть любая т.е. не очень точная.

Может быть посмотреть статью
https://infostart.ru/public/1017637/
5. darkmessiahan 32 15.04.19 16:36 Сейчас в теме
(4) такие мы имеем дело с необычным случаем, userом умеющим менять дату на компьютере?
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 135 000 руб. до 135 000 руб.
Полный день

Программист 1С
Норильск
зарплата от 50 000 руб. до 80 000 руб.
Полный день

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Ведущий программист 1С
Москва
зарплата от 120 000 руб. до 150 000 руб.
Полный день