1. Shecurok 15.04.19 14:22 Сейчас в теме

Как в ПФ вывести значения Кт и Дт

Дали задание сделать внешнюю ПФ, сделал 95 процентов. Остался последний штрих: добавить номера счетов Дт и Кт. Я так понимаю надо как то сделать ссылку на Хозрасчётный.Ссылка, но как это прописать не пойму и что оттуда брать. В программирование вообще не силен ни разу.

Сегодня уже к Вам обращался, помогли. Но остался последний вопрос.

P.S. Вывел Кт простым Копировать-Вставить из кода документа, только другая ПФ. Посмотрел по макету, нашел в коде как выводится. Там был такой код (всего две строчки): Счет КАК Счет и Параметры.Вставить (...). По идее то счёт Кт был под наименованием Счет и должно быть такое же наименование для Дт. Так ведь?
Ответы
Избранное Подписка Сортировка: Древо
2. darkmessiahan 32 15.04.19 14:28 Сейчас в теме
Имеете ввиду это продолжение этой темы?
https://forum.infostart.ru/forum9/topic215428/
3. Shecurok 15.04.19 14:30 Сейчас в теме
4. darkmessiahan 32 15.04.19 14:36 Сейчас в теме
(3) ну я смогу помочь если напишите код, я не развил свои экстрасенсорные способности. Мб кто другой поможет)
5. Shecurok 15.04.19 14:45 Сейчас в теме
(4) Слушай, я бы с радостью, но код большой и мне кажется для тебя буде ну очень не понятный, ибо он сделан через Копировать-Вставить и лишнего там ну ооочень много.
6. darkmessiahan 32 15.04.19 16:25 Сейчас в теме
7. Shecurok 15.04.19 17:27 Сейчас в теме
(6) Ну мой код выглядит так для вывода Дт.

ТекстЗапроса =
"ВЫБРАТЬ
(...)
| ТребованиеНакладная.СчетЗатрат.Код КАК СчетЗатратКод,
(...)
Конец функции.
(...)
Параметры.Вставить("КоррСчет", Строка.СчетЗатратКод);
Конец функции.

Поясню откуда я взял этот код: по аналогии с Кт взял его из кода другой ПФ. Никаких ошибок не вылезает, но и занчение не выводится. При этом в выводится в другом месте. Если тупо все копирую то в шапке вставляется (ну параметр соответсвтенно тоже прописываю на макете). Доп код для шапки:

Если Не Шапка.СчетаУчетаЗатратВТаблице Тогда
Параметры.Вставить("ПредставлениеПодразделения", ПредставлениеПодразделенияЗатрат(Шапка));
Параметры.Вставить("КоррСчет",Шапка.СчетЗатратКод);
Иначе

Получатели = Новый Соответствие;
СчетаУчетаЗатрат = Новый Соответствие;
Для Каждого СтрокаТабличнойЧасти Из Материалы Цикл
Получатели.Вставить(СтрокаТабличнойЧасти.ПодразделениеЗатрат, ПредставлениеПодразделенияЗатрат(СтрокаТабличнойЧасти));
СчетаУчетаЗатрат.Вставить(СтрокаТабличнойЧасти.СчетЗатратКод);
КонецЦикла;

Если Получатели.Количество() = 1 Тогда
Для Каждого КлючИЗначение Из Получатели Цикл
Параметры.Вставить("ПредставлениеПодразделения", КлючИЗначение.Значение);
КонецЦикла;
КонецЕсли;

Если СчетаУчетаЗатрат.Количество() = 1 Тогда
Для Каждого КлючИЗначение Из СчетаУчетаЗатрат Цикл
Параметры.Вставить("КоррСчет",КлючИЗначение.Ключ);
КонецЦикла;
КонецЕсли;

КонецЕсли;

Я работаю с областью строка, шапку меняю на строку выводится сообщение что поле обекта СчетаУчетаЗатратВТаблице не найдено
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 135 000 руб. до 135 000 руб.
Полный день

Программист 1С
Норильск
зарплата от 50 000 руб. до 80 000 руб.
Полный день

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Ведущий программист 1С
Москва
зарплата от 120 000 руб. до 150 000 руб.
Полный день