1. Aspiring_specialist 1 15.03.19 23:34 Сейчас в теме

обработка ftp

Подскажите пожалуйста, как можно сделать(нужно), чтобы внешняя обработка забирала файл с ftp с периодичностью времени?
Ответы
Избранное Подписка Сортировка: Древо
3. independ 291 16.03.19 09:02 Сейчас в теме
(1) проще батник и в планировщик
4. alxarz 29 16.03.19 12:11 Сейчас в теме
5. Aspiring_specialist 1 16.03.19 13:49 Сейчас в теме
(3)там смысл чтобы xml забрать с ftp и передать параметр в обработку универсальный обмен данными xml/но тут тоже вопрос как передать и как запускать ее автоматически
2. user834357 12 16.03.19 08:40 Сейчас в теме
Регламентное задание создать в конфигурации
ну или ПодключитьОбработчикОжидания в самой обработке
6. maks_20 18 18.03.19 09:36 Сейчас в теме
Внешняя обработка с типом "ВызовСерверногоМетода". В самой обработке в модуле создается метод ВыполнитьКоманду(ИдентификаторКоманды), в нем прописываете подключение к фтп и передачу файла в универсальный обмен. например так:

ftp = ПодключитьсяКФтп();
Если ftp<>Неопределено Тогда
МассивФайлов = ftp.НайтиФайлы("/ВашКаталог","*.xml");
МассивФайлов = НайтиФайлы(Каталог,"*.xml"); 
Для Каждого Файл Из МассивФайлов Цикл
	Если Файл.ЭтоФайл() Тогда
		пИмяФайла = Файл.Имя;
		ВременныйФайл = ПолучитьИмяВременногоФайла("xml");
		СкопироватьСФтп(ftp, пИмяФайла, ВременныйФайл);	
		ЗагрузитьФайлОбменаВБазу(Файл.ПолноеИмя);
		УдалитьФайлы(Файл.ПолноеИмя);
       КонецЕсли;
КонецЦикла;
КонецЕсли;
Показать



Так выглядит процедура ЗагрузитьФайлОбменаВБазу()

Процедура ЗагрузитьФайлОбменаВБазу(ФайлОбмена)
	ОбработкаЗагрузки  = Обработки.УниверсальныйОбменДаннымиXML.Создать();
	ОбработкаЗагрузки.ИмяФайлаОбмена = ФайлОбмена;
	ОбработкаЗагрузки.РежимОбмена	 = "Загрузка";
	ОбработкаЗагрузки.ОптимизированнаяЗаписьОбъектов = Истина;
	ОбработкаЗагрузки.ЗаписыватьРегистрыНаборамиЗаписей = Истина;
	ОбработкаЗагрузки.ЗаписыватьВИнформационнуюБазуТолькоИзмененныеОбъекты = Истина;
	ОбработкаЗагрузки.ЗагружатьДанныеВРежимеОбмена = Истина;
	ОбработкаЗагрузки.ВыполнитьЗагрузку();	
КонецПроцедуры
Показать


Остальное приводить не буду.
После чего обработку заливаете в дополнительные и настраиваете расписание.
Aspiring_specialist; +1 Ответить
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Ведущий инженер - программист 1С
Москва
зарплата от 200 000 руб.
Полный день

Ведущий программист 1С
Нижний Новгород
зарплата от 100 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 110 000 руб. до 120 000 руб.
Полный день

Аналитик 1С
Санкт-Петербург
зарплата от 80 000 руб.
Полный день

Программист 1С
Волгоград
зарплата от 45 000 руб. до 90 000 руб.
Полный день