1. b-dm 169 15.03.19 11:24 Сейчас в теме

Подскажите, как возможно исправить данную ошибку "Преобразование к типу Булево не может быть выполнено" ?

Есть такая ошибка в модуле формы обработки Печать этикеток.

{Обработка.ПечатьЭтикеток.Форма.Форма.Форма(112)}: Преобразование значения к типу Булево не может быть выполнено
ЭтикеткаОбласть.Параметры.Артикул = СтрокаИзСписка.Номенклатура.Артикул + ?(Демо, "-DEMO", "");


Само значение Демо, это булевский реквизит на форме Приходного ордера на товары....

Как её возможно исправить ?
Ответы
Избранное Подписка Сортировка: Древо
3. spacecraft 15.03.19 11:29 Сейчас в теме
(1) как вариант:
?(Демо = Истина, "-DEMO", "")
10. SedovSU@mail.ru 292 15.03.19 12:33 Сейчас в теме
Ошибка явная - Демо не булевский тип. следовательно при работе в какой то момент времени у вас Переменная Демо становиться не типом Булево. Поставьте отладку и посмотрите. А обойти ошибку можно как в (1) предложили
11. Fox-trot 95 15.03.19 13:22 Сейчас в теме
2. user834357 14 15.03.19 11:27 Сейчас в теме
Как вариант, в отладке посмотреть почему булевский тип не может быть преобразован в булевский
4. VmvLer 15.03.19 11:33 Сейчас в теме
код ниже может быть и избыточен, но обходит рогатки типов

ПрефиксАртикула = "";
Если ЗначениеЗаполнено(СтрокаИзСписка.Номенклатура.Артикул) Тогда
   ПрефиксАртикула = Строка(СтрокаИзСписка.Номенклатура.Артикул);
КонецЕсли;

СуффиксАртикула = "";
Если ТипЗнч(Демо) = Тип("Булево") Тогда
   Если Демо Тогда
        СуффиксАртикула =  "-DEMO";
   КонецЕсли;
КонецЕсли;
ЭтикеткаОбласть.Параметры.Артикул  = ПрефиксАртикула + СуффиксАртикула;
Показать
5. herfis 276 15.03.19 11:35 Сейчас в теме
ЭтикеткаОбласть.Параметры.Артикул = СтрокаИзСписка.Номенклатура.Артикул;
6. b-dm 169 15.03.19 11:36 Сейчас в теме
(5) - Демо тоже надо выводить..
7. majoram 7 15.03.19 11:48 Сейчас в теме
(6) Сообщить(ТипЗнч(Демо));
mrcamomile; +1 Ответить
8. mrcamomile 2 15.03.19 11:57 Сейчас в теме
(7) Просто сделайте чтобы значение Демо было ожидаемого типа - может у Вас еще локальная переменная Демо есть другого типа
9. VictorRGB2 9 15.03.19 12:06 Сейчас в теме
(6) вообще надо залезть в отладчик и посмотреть, что же вообще есть в указанной строке - значения, типы
1С указывает на строку с ошибкой, зачастую ошибочно показывая что именно не смогла привести к типу Булево или Число, может случиться так, что Демо как раз Булево, а ошибку вызывает Артикул... и вовсе не из-за того, что к булево приводится, а из-за того, что там не строка, а вы к ней строчное "Демо" присоединяете
12. b-dm 169 15.03.19 15:29 Сейчас в теме
Всем спасибо, варианты 3 и 4 вполне подошли :)

а также вариант

Если Демо = Неопределено Тогда 
    Демо = Ложь 
КонецЕсли;
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Нижний Новгород
зарплата до 120 000 руб.
Полный день

Программист 1С
Волгоград
зарплата от 45 000 руб. до 90 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Консультант-аналитик 1С
Москва
зарплата от 70 000 руб. до 100 000 руб.
Полный день

Программист 1С
Москва
зарплата от 80 000 руб. до 120 000 руб.
Временный (на проект)