1. ArBot 15.03.19 11:16 Сейчас в теме

Как при нажатии кнопки печать, спрашивать у пользователя по какой организации печатать документы?

Здравствуйте, на форме списка есть кнопка печать, при нажатии на нее пользователь должен вводить организацию, далее передаю эту организацию в параметры запроса, и печатаю по ней информацию?
Вопрос: как при нажатии кнопки вывести поле для ввода организации?
Найденные решения
7. SedovSU@mail.ru 292 15.03.19 12:50 Сейчас в теме
(3) Смотрите можно так.

Процедура ВашаПечать();

// тут какой то код что то делает, далее делаем выбор организации

Форма = Справочники.Организации.ПолучитьФормуВыбора();
ВыбранноеЗначение = Форма.ОткрытьМодально();
Если ЗначениеЗаполнено(ВыбранноеЗначение) Тогда
Организация = ВыбранноеЗначение
Иначе
Организация = Справочник.Организация.ПустаяСсылка()
Конецесли


КонецПроцедуры
Показать
12. SedovSU@mail.ru 292 15.03.19 13:08 Сейчас в теме
(9)

&НаКлиенте
Процедура ОткрытьФормы(Команда)
    Форма = ПолучитьФорму("Справочник.Номенклатура.ФормаВыбора");
   Форма.Открытьмодально();
	   
КонецПроцедуры
Остальные ответы
Избранное Подписка Сортировка: Древо
2. majoram 7 15.03.19 11:20 Сейчас в теме
почему бы этот выбор не разместить сразу на форме-владельце кнопки Сформировать?
alex-l19041; +1 Ответить
3. ArBot 15.03.19 11:28 Сейчас в теме
(2)На форму списка добавить сразу поле организация?
5. majoram 7 15.03.19 11:37 Сейчас в теме
(3) ну я не знаю что там за форма. если на ней можно сделать реквизит формы с произвольным типом, привязать к нему элемент управления "Поле ввода" с выбором из списка и заполнить список организациями примерно вот так: Элементы.Организация.СписокВыбора.Добавить(Выборка.Организация); (получив организации запросом например).
6. ArBot 15.03.19 11:49 Сейчас в теме
(5)а можно ли на форме списка получить текущие данные по колонке? а не всю текущую строку целиклм
7. SedovSU@mail.ru 292 15.03.19 12:50 Сейчас в теме
(3) Смотрите можно так.

Процедура ВашаПечать();

// тут какой то код что то делает, далее делаем выбор организации

Форма = Справочники.Организации.ПолучитьФормуВыбора();
ВыбранноеЗначение = Форма.ОткрытьМодально();
Если ЗначениеЗаполнено(ВыбранноеЗначение) Тогда
Организация = ВыбранноеЗначение
Иначе
Организация = Справочник.Организация.ПустаяСсылка()
Конецесли


КонецПроцедуры
Показать
8. ArBot 15.03.19 13:00 Сейчас в теме
(7) У меня Это все происходит на сервере, там пишет интерактивные операции не доступны.
Сделать на клиенет и через пароаметр функции передать организацию в функцию?
10. SedovSU@mail.ru 292 15.03.19 13:04 Сейчас в теме
(8) Да конечно же, а почему бы и нет. Переда началом все обработке на сервере, где то наклиенте предложить выбор и передать его уже на сервер
9. ArBot 15.03.19 13:04 Сейчас в теме
(7)а на клиенте не работает Справочники.Организации.
11. SedovSU@mail.ru 292 15.03.19 13:07 Сейчас в теме
(9) вызовите ПолучитьФорму("Справочник.Организации.ФормаВыбора") - это должно быть доступно
12. SedovSU@mail.ru 292 15.03.19 13:08 Сейчас в теме
(9)

&НаКлиенте
Процедура ОткрытьФормы(Команда)
    Форма = ПолучитьФорму("Справочник.Номенклатура.ФормаВыбора");
   Форма.Открытьмодально();
	   
КонецПроцедуры
13. ArBot 15.03.19 13:23 Сейчас в теме
4. Timur.V 44 15.03.19 11:36 Сейчас в теме
Можно посмотреть обработку
https://infostart.ru/public/917017/
и сделать аналогично.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Нижний Новгород
зарплата до 120 000 руб.
Полный день

Программист 1С
Волгоград
зарплата от 45 000 руб. до 90 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Консультант-аналитик 1С
Москва
зарплата от 70 000 руб. до 100 000 руб.
Полный день

Программист 1С
Москва
зарплата от 80 000 руб. до 120 000 руб.
Временный (на проект)