Добавление галочки "Ручная корректировка" в документе "Отражение зарплаты в бухучете"

0. 370 13.03.19 18:10 Сейчас в теме
Добавление галочки "Ручная корректировка" для документа "Отражение зарплаты в бухучете" посредством добавления в базу расширения конфигурации.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. front12 29.04.19 16:25 Сейчас в теме
После корректировки движения документа "Отражение зарплаты в бух.учете" с помощью вашей обработки, изменения проводок не слетит после проведения документа Закрытие месяца?
2. 2ncom 24 30.04.19 11:33 Сейчас в теме
3. 2ncom 24 29.05.19 22:04 Сейчас в теме
(2) Собственно говоря, проводки не слетают, а добавляются при каждом проведении документа с установленной галкой
"Ручная корректировка".

Чтобы такого не случалось в это расширение в модуль объекта можно добавить, например, такой код.

&Перед("ОбработкаПроведения")
Процедура Расш1_ОбработкаПроведения(Отказ, РежимПроведения)
	Если ЭтотОбъект.РучнаяКорректировка Тогда
		Отказ = Истина;
	КонецЕсли;
КонецПроцедуры
lexxmaster; DimaP; +2 Ответить
4. lexxmaster 24.10.19 11:39 Сейчас в теме
(3) Только лучше не отказ, а возврат, по аналогии с типовым функционалом.
5. lexxmaster 24.10.19 18:19 Сейчас в теме
(4)Ошибочка, возврат не отрабатывает с инструкцией &Перед, Отказ = истина смущает пользователей, когда не могут провести, корректно будет так:
&Вместо("ОбработкаПроведения")
Процедура Расш_ОбработкаПроведения(Отказ, РежимПроведения)
	Если РучнаяКорректировка Тогда
		Возврат;
	Иначе
		ПродолжитьВызов(Отказ, РежимПроведения);
	КонецЕсли;	
КонецПроцедуры
Показать
6. rounder 173 25.10.19 11:32 Сейчас в теме
(5) а при закрытие месяца будет вылезать ошибка
движения документа отредактированы вручную и не могут быть автоматически актуализированы
7. lexxmaster 25.10.19 14:39 Сейчас в теме
(6)Вот буквально вчера успешно закрыли месяц. Жалоб от бухгалтеров не было.
9. devlog 02.12.19 15:49 Сейчас в теме
(7) Здравствуйте. Пожалуйста уточните, правильно ли понял, что данный код надо добавить в модуль объекта документа ОтражениеЗП в расширении? Сейчас этот модуль пустой
10. lexxmaster 02.12.19 19:16 Сейчас в теме
8. rallyboy 13.11.19 14:46 Сейчас в теме
Так все-таки слетают ли изменения после закрытия месяца?
11. user1107343 23.01.20 12:33 Сейчас в теме
Здравствуйте, на текущую версию 3.0.75.58 не ставиться это расширение.
12. Валенсия 39 28.07.20 20:42 Сейчас в теме
Как изменить Режим совместимости в обработке. Она не корректируется. Иначе не устанавливается.
13. Cobranet123 370 04.08.20 13:08 Сейчас в теме
(12)
Здравствуйте, у вас какая версия конфигурации ?
14. user949023 28.08.20 19:15 Сейчас в теме
Здравствуйте! Не удалось установить расширение. Выдает сообщение:"Не удалось добавить расширение "РучнаяКорректировка" из файла … по причине: Ошибка применения конфигурации: свойства РежимСовместимости у объекта на совпадает с расширяемой конфигурацией"
Бухгалтерия предприятия, редакция 3.0 (3.0.81.30) - текущая конфигурация.
15. user949023 28.08.20 19:21 Сейчас в теме
Режим совместимости Версия 8.3.14
Платформа 8.3.17
16. user1633981 21.07.21 18:02 Сейчас в теме
Здравствуйте!

Не устанавливает, выдает:

ошибка применения расширения конфигурации: Для работы с базовой версией расширение должно быить подписано тем же ключом, что и конфигурация

У меня платформа 8.3.19.1229
конфа 3.0.97.26
17. aleksandr_leiman 69 23.08.21 10:42 Сейчас в теме
(16)В базовой версии нельзя подключать расширения сторонних разработчиков, только публикуемые самой фирмой 1С
18. kotenok2710 15.10.21 10:23 Сейчас в теме
Добрый день! Помогите, пожалуйста, установить расширение." значение контролируемого свойства режим совместимости у объекта не совпадает со значением...." 8.3.18.1289 , 3.0.95.24
19. Sveta 17.11.21 11:17 Сейчас в теме
Добрый день! Помогите, пожалуйста, установить расширение "значение контролируемого свойства режим совместимости у объекта не совпадает со значением...." Платформа 8.3.18.1289 и 8.3.19.1229. И можно ли как-то самостоятельно менять режим совместимости. А то разработчики 1С часто заставляют менять платформы.
20. 31337 38 28.06.22 11:53 Сейчас в теме
в расширении просто реквизит что-ли добавлен "ручнаякорректировка" и всё? )
Оставьте свое сообщение
Вакансии
Архитектор 1С
Москва
зарплата от 260 000 руб.
Полный день

Начальник отдела архитектуры
Москва
зарплата от 300 000 руб.
Полный день

Эксперт по технологическим вопросам
Москва
зарплата от 250 000 руб.
Полный день

Ведущий разработчик 1С
Ростов-на-Дону
зарплата от 200 000 руб.
Полный день

Бизнес-аналитик 1С
Ростов-на-Дону
зарплата от 150 000 руб.
Полный день