1. ranis888 5 13.03.19 08:51 Сейчас в теме

Как отправить файл в POSt запросе

Как можно сделать отправку CSV файла в post запросе?
Ответы
Избранное Подписка Сортировка: Древо
5. DNN13 13.03.19 09:16 Сейчас в теме
6. ranis888 5 13.03.19 09:17 Сейчас в теме
7. DNN13 13.03.19 09:22 Сейчас в теме
(6) HTTPЗапрос, УстановитьИмяФайлаТела. А потом через http соединение
2. Aitbay 13.03.19 09:11 Сейчас в теме
ТекстФайла = "";

Для каждого стр Из мСписокСформированныхФайлов Цикл

ТекстФайла = ТекстФайла + "BeginFile:"+Стр.ИмяФайла + Символы.ПС;

Текст = Новый ТекстовыйДокумент;
Текст.Прочитать(Стр.Каталог + Стр.ИмяФайла);

Для НомерСтроки = 1 По Текст.КоличествоСтрок() Цикл

ТекСтрока = Текст.ПолучитьСтроку(НомерСтроки);
ТекстФайла = ТекстФайла + ТекСтрока + Символы.ПС;

КонецЦикла;

ТекстФайла = ТекстФайла + "EndFile" + Символы.ПС;

КонецЦикла;

DocParam.Вставить("СписокФайлов", ТекстФайла);
3. Aitbay 13.03.19 09:11 Сейчас в теме
DocParam.Вставить("СписокФайлов", ТекстФайла); это параметр отправляемой структуры
4. ranis888 5 13.03.19 09:13 Сейчас в теме
(3)Получается CSV файл будет как строка?
8. Aitbay 13.03.19 11:56 Сейчас в теме
да а на стороне приема обратная операция

ТекстСписокФайлов = Параметры.СписокФайлов;
Каталог = КаталогВременныхФайлов() + Параметры.ИИНПользователя + "\";

КаталогНаДиске = Новый Файл(Каталог);
Если НЕ КаталогНаДиске.Существует() Тогда
СоздатьКаталог(Каталог);
КонецЕсли;

Текст = Новый ТекстовыйДокумент;
Текст.УстановитьТекст(ТекстСписокФайлов);

ИмяФайла = "";
СписокФайлов = Новый Массив;

Для НомерСтроки = 1 По Текст.КоличествоСтрок() Цикл

ТекСтрока = Текст.ПолучитьСтроку(НомерСтроки);

Если Сред(ТекСтрока, 1, 9) = "BeginFile" Тогда

ТекСтрока = СтрЗаменить(ТекСтрока,"BeginFile:","");
ИмяФайла = ТекСтрока;
ТекстФайла = "";
Иначе

Если ТекСтрока = "EndFile" Тогда

Путь = Каталог + ИмяФайла;
НовыйТекст = Новый ЗаписьТекста(Путь, КодировкаТекста.UTF8);
НовыйТекст.ЗаписатьСтроку(ТекстФайла);
НовыйТекст.Закрыть();

СписокФайлов.Добавить(Каталог + ИмяФайла);
Иначе
ТекстФайла = ТекстФайла + ТекСтрока + Символы.ПС;
КонецЕсли;
КонецЕсли;
КонецЦикла;
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Нижний Новгород
зарплата до 120 000 руб.
Полный день

Программист 1С
Волгоград
зарплата от 45 000 руб. до 90 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Консультант-аналитик 1С
Москва
зарплата от 70 000 руб. до 100 000 руб.
Полный день

Программист 1С
Москва
зарплата от 80 000 руб. до 120 000 руб.
Временный (на проект)