0. ids79 4438 07.03.19 10:30 Сейчас в теме

Добавление отчетов в типовые конфигурации 1С

Описание различных способов добавления общих и контекстных отчетов в конфигурации 1С, построенные на базе БСП. Основные моменты и нюансы.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. nomadon 382 08.03.19 10:13 Сейчас в теме
Может есть пример-шаблончик?
2. ids79 4438 08.03.19 10:44 Сейчас в теме
(1)Какой именно шаблон Вам нужен?
3. ded20ded 08.03.19 18:43 Сейчас в теме
Шаблон для внешних печатных форм, для внешних отчетов.
4. ids79 4438 09.03.19 07:42 Сейчас в теме
(3)По ссылке в статье можно скачать такие шаблоны.
Правда, там не для всех случаев, да и статья уже давно написана.
Выложу статью с актуальными шаблонами доп. отчетов и обработок
в ближайшее время.
6. Sherzod1984 11.03.19 17:20 Сейчас в теме
(4) Добрый день! Дмитрий Иванов, как можно с вами связаться?
19. ids79 4438 24.04.19 19:51 Сейчас в теме
7. chuff 12.03.19 07:28 Сейчас в теме
Узнал кое-что интересное. Только вот "в панелЕ", "на панелЕ" жутко режет глаза
9. ids79 4438 12.03.19 10:02 Сейчас в теме
(7)Самое интересное, я сперва так и написал.
Перед самой модерацией, мне показалось, что правильно именно так.
Еще раз посмотрел, все-таки Вы правы, исправил.
С грамотностью у меня беда, к сожалению.
Спасибо.
10. @Sonya 26 21.03.19 10:31 Сейчас в теме
Может кто сталкивался, при добавлении внешнего отчета, закладка Варианты не появляется. В свойствах отчета выбрано ХранилищеВариантовОтчетов. Что-то еще надо сделать?
11. @Sonya 26 21.03.19 10:56 Сейчас в теме
(10) Отвечаю сама. При регистрации отчета было написано
РегистрационныеДанные.Вставить("Вид", "Отчет");
а не
РегистрационныеДанные.Вставить("Вид", "ДополнительныйОтчет");
12. user599492_oskomleva 27.03.19 13:18 Сейчас в теме
Добрый день, а можно шаблон для отчета через расширение общего? Как присоединить и с какого релиза БСП для регистрации в справочнике достаточно просто Настройки.НастроитьВариантыОтчета = Истина;
Делаю следующие действия (отчет на СКД):
1. Создаю отчет в расширении
2. В свойствах добавляю ХранилищеВариантовОтчетов
3. В модуле Менеджера:

Процедура ПриОпределенииНастроек(Настройки) Экспорт
	
	Настройки.НастроитьВариантыОтчета = Истина;
	
КонецПроцедуры

Процедура НастроитьВариантыОтчета(Настройки, НастройкиОтчета) Экспорт
	
	НастройкиВарианта = ВариантыОтчетов.ОписаниеВарианта(Настройки, НастройкиОтчета, "ТестСотрудники");
	НастройкиВарианта.Описание = НСтр("ru = 'Тест сотрудники'");
	
КонецПроцедуры
Показать

после запуска 1С в справочнике отчетов не появляется предопределенного элемента
что делаю не так?
13. user599492_oskomleva 27.03.19 16:43 Сейчас в теме
Закрываю, вопрос. Все заработало.
14. ids79 4438 27.03.19 17:27 Сейчас в теме
(12)Даже если ничего не написать в модуле менеджера, отчет должен появиться в панели отчетов автоматически (если конечно указана подсистема).
15. user599492_oskomleva 27.03.19 18:00 Сейчас в теме
мне нужна не панель отчетов, а в справочнике Отчеты, как предопределенный элемент, иначе на отчет нельзя настроить рассылку.
16. Indifference 28.03.19 08:26 Сейчас в теме
(15)
Добрый день! Подскажите, пожалуйста, что вы все таки сделали чтобы отчет появился в предопределенных? В модуль менеджера вообще не заходит ни в одну процедуру.
18. yefalex 24.04.19 14:25 Сейчас в теме
(16) По вышеприведенному описанию для отчетов в расширении тоже не заработало, т.к. описано не совсем точно.
Сделал согласно документации БСП

Кроме того, команды отчетов можно задавать в самих отчетах конфигурации (и в отчетах расширений конфигурации). Для этого отчет нужно включить в состав подсистемы ПодключаемыеОтчетыИОбработки и в его модуле менеджера в области ПрограммныйИнтерфейс определить процедуры ПриОпределенииНастроек и ДобавитьКомандыЗаполнения. Подробнее см. пукнт Подключение отчетов и обработок к механизмам конфигурации документации подсистемы Подключаемые команды. Пример:

#Область ПрограммныйИнтерфейс
// Определяет состав программного интерфейса для интеграции с конфигурацией.
//
// Параметры:
//   Настройки - Структура - Настройки интеграции этого объекта.
//       См. возвращаемое значение функции ПодключаемыеКоманды.НастройкиПодключаемыхОтчетовИОбработок().
//
Процедура ПриОпределенииНастроек(Настройки) Экспорт
    Настройки.Размещение.Добавить(Метаданные.Документы.ИмяДокумента);
    Настройки.ДобавитьКомандыОтчетов = Истина;
КонецПроцедуры
// Определяет список команд отчетов.
//
// Параметры:
//   КомандыОтчетов - ТаблицаЗначений - Таблица с командами отчетов. Для изменения.
//       См. описание 1 параметра процедуры ВариантыОтчетовПереопределяемый.ПередДобавлениемКомандОтчетов().
//   Параметры - Структура - Вспомогательные параметры. Для чтения.
//       См. описание 2 параметра процедуры ВариантыОтчетовПереопределяемый.ПередДобавлениемКомандОтчетов().
//
Процедура ДобавитьКомандыОтчетов(КомандыОтчетов, Параметры) Экспорт
КонецПроцедуры
#КонецОбласти
Показать
24. AgnepuS 3 20.06.19 22:11 Сейчас в теме
(18) Добрый день. Не помог и "ваш" вариант, для того чтобы в пользовательском режиме у отчета из расширения отобразить варианты отчета. Всё также доступен только один вариант. Может быть у вас припасено ещё пара тузов в рукаве?
25. AgnepuS 3 20.06.19 23:04 Сейчас в теме
Разобрался, расширение подключено в безопасном режиме. От этого и не удается перехватить НастроитьВариантыОтчетов.
Спасибо за статью.
28. ids79 4438 20.06.19 23:11 Сейчас в теме
(25)Ну да, по этому и не заходит в модуль менеджера.
26. ids79 4438 20.06.19 23:06 Сейчас в теме
(18) Да, Вы правы. Добавление в подсистему "ПодключаемыеОтчетыИОбработки" - обязательно.
17. user599492_oskomleva 28.03.19 10:22 Сейчас в теме
https://help1c.by/podklyuchenie-novogo-otcheta-k-podsisteme-variantov-otcheta/
пункт 5 , нашла в конфигураторе подобную процедуру дополнила обращением в модуль менеджера своего отчета в расширении с директивой & После
а так все как описано выше, единственное отчет появляется в предопределенных с именем, которое в настройках СКД в графе представление.
Вариант для расширения вместо Описания использовать свойство "Пояснение" почему-то не сработало...
Прикрепленные файлы:
27. ids79 4438 20.06.19 23:10 Сейчас в теме
(17)Похоже, что Вы подключаете отчет не в расширении, а в основной конфигурации. В описании, которое Вы приводите, отчет в конфигурацию добавляется.

"Вариант для расширения вместо Описания использовать свойство "Пояснение" - это только для расширений работает.
20. Alex1053669 18.06.19 23:55 Сейчас в теме
Статья очень пригодилась.
AlexandrSmith; +1 Ответить
22. ids79 4438 20.06.19 11:26 Сейчас в теме
(20) Спасибо, значит не зря писал
23. ids79 4438 20.06.19 11:26 Сейчас в теме
29. nla_a 26.06.19 17:56 Сейчас в теме
Подскажите, пожалуйста, как убрать отчет из основного окна раздела «Отчеты», после того как он добавлен на специальную панель отчетов.
30. ids79 4438 26.06.19 18:34 Сейчас в теме
(29)Можно исключить отчет из подсистемы, в разделе которой он выводится.
31. nla_a 26.06.19 18:40 Сейчас в теме
(30) Да, в командном интерфейсе надо было снять галку. Спасибо.
32. Wefast 11.07.19 08:26 Сейчас в теме
Где это окно Вспомогательные данные, чтобы выбрать обновление вариантов отчетов?
33. ids79 4438 11.07.19 16:07 Сейчас в теме
(32)Обработка "Обновление вспомогательных данных" из состава БСП
34. user641797_salute-91 16.08.19 09:37 Сейчас в теме
На общей форме ФормаОтчета автоматически создаются элементы из быстрого доступа (параметры, отборы).
Есть ли способ навесить свой обработчик на какое-нибудь из таких полей?
Допустим нам надо после установки параметра каким-нибудь образом его обработать. Например пользователь ввёл дату, а мы дописали время 08:00.
В модуле ОтчетыКлиентПереопределяемый обработчиков совсем мало. Хотелось бы обойтись без копирования и изменения общей формы.
35. ids79 4438 17.08.19 08:31 Сейчас в теме
(34)Да, только добавлять свою форму в отчет и ее модифицировать. Там как раз вывод быстрых пользовательских настроек программно делается.
36. Denic01 06.11.19 12:24 Сейчас в теме
Есть такая функция
Функция ВариантыОтчетов.НастройкиФормыОтчета(ОтчетСсылка, КлючВарианта, ОтчетОбъект) Экспорт

в ней код

НастройкиОтчета = ОтчетыКлиентСервер.ПолучитьНастройкиОтчетаПоУмолчанию();
ОтчетыСНастройками = ВариантыОтчетовПовтИсп.Параметры().ОтчетыСНастройками

ОтчетыСНастройками - содержит список типовых отчетов, "свои" отчеты никак не добавляются в него, соответственно там выход из процедуры дальше и функционал ФормыОтчета наполовину не используется, может кто сталкивался ?

всё из статьи уже перепробовал, понял что этот список хранится в виде хранилища значения в настройках, а вот где и когда он перезаполняется ...
37. ids79 4438 06.11.19 16:12 Сейчас в теме
(36)Для начала попробуйте запустить обработку "Обновление вспомогательных данных" из состава БСП
38. Denic01 06.11.19 16:19 Сейчас в теме
(37)
да запускал я, конечно, и эту обработку и конфигуратор с параметром ЗапуститьОбновлениеИнформационнойБазы
Убеждался в отладчике, что в процедуру отчета
Процедура НастроитьВариантыОтчета(Настройки, НастройкиОтчета) Экспорт

программа заходит
однако озвученный массив так и не изменился, еще забыл озвучить, что в справочнике ВыриантыОтчетов все прописалось, появилось с интерфейса открывается.
40. user1310976 15.11.19 11:02 Сейчас в теме
(36)
Работаю с ERP, ситуация похожая. Есть ФормаОтчета(типовая), процедура ПриСозданииНаСервере. При выполнении условия:
Если ВариантыОтчетовПовтИсп.Параметры().ОтчетыСНастройками.Найти(НастройкиОтчета.ОтчетСсылка) <> Неопределено управление передается в процедуру ПриСозданииНаСервере модуля объекта моего отчета. Но он не передается, потому что в массиве ОтчетыСНастройками находятся только типовые отчеты.
Идей тоже пока нет, если вами будет найдено решение - пожалуйста отпишитесь, выручите сильно.
39. Denic01 15.11.19 10:51 Сейчас в теме
Вообщем появилось время разобрался отвечу сам на свой вопрос:
я написал

Процедура НастроитьВариантыОтчета(Настройки, НастройкиОтчета) Экспорт
	
        НастройкиВарианта = ВариантыОтчетов.ОписаниеВарианта(Настройки, НастройкиОтчета, "Основная");
	НастройкиВарианта.Описание = НСтр("ru = 'Состояние товарного кредита покупателя'");
	НастройкиВарианта.ОпределитьНастройкиФормы = Истина;

КонецПроцедуры


так делать нельзя - тут создается переменная НастройкиВарианта, не особо понятно зачем она вообще нужна т.к. если смотреть в отладчике значения приравненные таким образом не оказывают влияние на параметры процедуры
нужно писать так: (в типовых тоже так написано)

Процедура НастроитьВариантыОтчета(Настройки, НастройкиОтчета) Экспорт
	
	НастройкиОтчета.ОпределитьНастройкиФормы = Истина;
	НастройкиВарианта = ВариантыОтчетов.ОписаниеВарианта(Настройки, НастройкиОтчета, "Основная");
	НастройкиВарианта.Описание = НСтр("ru = 'Состояние товарного кредита покупателя'");

КонецПроцедуры


тогда всё ок, смотрел изначально совсем в другую сторону поэтому в первый вопрос не добавил этот код )
41. imbalance 05.12.19 15:33 Сейчас в теме
42. ids79 4438 07.12.19 11:04 Сейчас в теме
(41)А у Вас сама подсистема и отчет в ней отображаются? Отчет не отображается только в панели отчетов?
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Ведущий программист 1С (team leader)
Санкт-Петербург
зарплата от 110 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 80 000 руб. до 120 000 руб.
Полный день

Программист 1С
Иркутск
зарплата от 80 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата от 80 000 руб. до 130 000 руб.
Полный день