1. Slypower 11.02.19 10:57 Сейчас в теме

Условие по субконто.

Добрый день. Не очень разбираюсь с Бух итогами. Ищу помощи.
Нужно выполнить запрос с условием по субконто. Т.е. Счет 10.3 в дебете, а условие Субконто (все субсчета).

Вот код:
	БИ = СоздатьОбъект("БухгалтерскиеИтоги");
	
	БИ.ИспользоватьСубконто(ВидыСубконто.Материалы);
	БИ.ИспользоватьСубконто(ВидыСубконто.Подразделения2009);
	БИ.ИспользоватьСубконто(ВидыСубконто.Сотрудники);
	БИ.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства);

	БИ.ИспользоватьКорСубконто(ВидыСубконто.ЭлементЗатрат,СписокЭлЗатрат,2);
	
	БИ.Опции(1,1);
	БИ.ВключатьСубсчета(1,1);
	Если БИ.ВыполнитьЗапрос(НачМесяца(ДатаДок),КонМесяца(ДатаДок),СчетПоКоду("10.3",ПланыСчетов.Новый),,,) = 0 Тогда
		Возврат;
	КонецЕсли;
	/////
	БИ.ВыбратьКорСчета();
	Пока БИ.ПолучитьКорСчет()=1 Цикл
		Сообщить(БИ.КорСчет);
		БИ.ВыбратьКорСубконто();
		Пока БИ.ПолучитьКорСубконто() = 1 Цикл
			Сообщить(БИ.КорСубконто());
		КонецЦикла;
	КонецЦикла;
Показать


Список заполненный. Но в цикл не заходит.
		БИ.ВыбратьСубконто(1);
		Пока БИ.ПолучитьСубконто(1) = 1 Цикл
			БИ.ВыбратьСубконто(2);
			Пока БИ.ПолучитьСубконто(2) = 1 Цикл
				БИ.ВыбратьСубконто(3);
				Пока БИ.ПолучитьСубконто(3) = 1 Цикл
					БИ.ВыбратьСубконто(4);
					Пока БИ.ПолучитьСубконто(4) = 1 Цикл
						КоличествоОборот = БИ.ДО(3);
						Если КоличествоОборот = 0 Тогда
							Продолжить;
						КонецЕсли;
						Сообщить(БИ.ПредставлениеКорСубконто(ВидыСубконто.ЭлементЗатрат));
						НоваяСтрока();
						Материал = БИ.Субконто(1);
						Подразделения = БИ.Субконто(2);
						Сотрудники = БИ.Субконто(3);
						ОсновныеСредства = БИ.Субконто(4);
						Сумма = БИ.ДО(1);
						Количество = КоличествоОборот;
					КонецЦикла;
				КонецЦикла;
			КонецЦикла;
		КонецЦикла;
Показать


В этом цикле он не видит субконто.

Соответственно, запрос сформирован по всем корсубсчетам без выборки. Как сделать с условием по корсубконто?

Надеюсь смог объяснить верно
Ответы
Избранное Подписка Сортировка: Древо
2. kumi2012 4 11.02.19 11:55 Сейчас в теме
Попробуйте перед запросом:

БИ.ИспользоватьПланСчетов(ПланыСчетов.Новый);
3. Slypower 11.02.19 12:05 Сейчас в теме
(2)
БИ.ИспользоватьПланСчетов(ПланыСчетов.Новый)

Не помогает, тем более, что я определяю ссылочность счета 10.3, а не строку задаю. Поэтому он видит какой использовать.
4. Slypower 11.02.19 12:06 Сейчас в теме
Задал Корсчета, но ничего не изменилось(

Если БИ.ВыполнитьЗапрос(НачМесяца(ДатаДок),КонМесяца(ДатаДок),СчетПоКоду("10.3",ПланыСчетов.Новый),СписокКорСчетов,,,) = 0 Тогда
5. Slypower 11.02.19 12:08 Сейчас в теме
Результат:
Представление кор субконто: <...>
6. Slypower 12.02.19 16:26 Сейчас в теме
Тему можно закрывать. Я ошибался, отрабатывает при таком коде.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Специалист техподдержки 1С
Иркутск
зарплата от 28 000 руб. до 34 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 48 000 руб. до 96 000 руб.
По совместительству

Программист 1С
Ставрополь
зарплата от 40 000 руб. до 60 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Преподаватель 1С
Самара
зарплата от 50 000 руб. до 100 000 руб.
По совместительству