1. sSpy 10.02.19 15:46 Сейчас в теме

Не производится расчёт в табличной части документа

Здравствуйте! Не давно начал изучать 1С и на данный момент столкнулся с одной проблемой.

В общем, есть справочник "Номенклатура", в нём реквизиты "Наименование" и "Цена". Есть документ "Продажа", в документе есть табличная часть "ПодборТоваров", в табличной части три поля: "Наименование", "Количество" и "Стоимость". Поле "Наименование" является ссылкой на справочник "Номенклатура". В форме документа я из реквизитов поля "Наименование" достал реквизит "Цена".
В 1С:Предприятие проверил, при выборе товара, в поле с ценой подтягивается и его цена, закрыл это дело.
Теперь мне нужно сделать так, что бы в поле "Стоимость" автоматически рассчитывалась стоимость указанного количества товара в поле "Количество". Для этого я в здешнем модуле написал процедуру:
&НаКлиенте
Процедура ПодборТоваровКоличествоПриИзменении(Элемент)
	
	СтрокаТабличнойЧасти = Элементы.ПодборТоваров.ТекущиеДанные;
	СтрокаТабличнойЧасти.Стоимость = СтрокаТабличнойЧасти.Количество * СтрокаТабличнойЧасти.Наименование.Цена;

КонецПроцедуры
Показать

Но почему-то поле "Наименование.Цена" программа не видит. Пробовал указывать как с точкой (как сейчас), так и без точки, и просто "Цена", без "Наименование", но ни к чему так и не пришёл. Что я делаю не так и как мне сделать правильно?

Прилагаю файл конфигурации.

P.S. Понимаю, что решение кроется где-то рядом, сам уже второй день пытаюсь разобраться, но не получается, решил спросить совета у знающих людей.
Прикрепленные файлы:
1Cv8.cf
Найденные решения
4. antz 10.02.19 16:20 Сейчас в теме
На клиенте реквизиты объектов ссылочного типа (те, к которым идет обращение через точку) недоступны. Их надо получать на сервере.

&НаКлиенте
Процедура ПодборТоваровКоличествоПриИзменении(Элемент)
    
    СтрокаТабличнойЧасти = Элементы.ПодборТоваров.ТекущиеДанные;
    СтрокаТабличнойЧасти.Стоимость = СтрокаТабличнойЧасти.Количество * ПолучитьЦену(СтрокаТабличнойЧасти.Наименование)

КонецПроцедуры

&НаСервере
Функция ПолучитьЦену(Ссылка)
    Возврат Ссылка.Цена
КонецФункции
Показать
sSpy; oleg-x; killitch; +3 Ответить
Остальные ответы
Избранное Подписка Сортировка: Древо
2. Aspiring_specialist 1 10.02.19 16:02 Сейчас в теме
(1)
Наименование.Цена;
Посмотрите если в ТЧ столбец Цена (или он просто по другому назваеться), если да то должны написать вот так

СтрокаТабличнойЧасти.Стоимость = СтрокаТабличнойЧасти.Количество * СтрокаТабличнойЧасти.Цена;
3. Aspiring_specialist 1 10.02.19 16:07 Сейчас в теме
(1)
Стоимость"
НУ правильно у вас строки Цена нету. Сами же написали, что только табличной части три поля: "Наименование", "Количество" и "Стоимость" . Цены то нет, и он не знает откуда и как считать
4. antz 10.02.19 16:20 Сейчас в теме
На клиенте реквизиты объектов ссылочного типа (те, к которым идет обращение через точку) недоступны. Их надо получать на сервере.

&НаКлиенте
Процедура ПодборТоваровКоличествоПриИзменении(Элемент)
    
    СтрокаТабличнойЧасти = Элементы.ПодборТоваров.ТекущиеДанные;
    СтрокаТабличнойЧасти.Стоимость = СтрокаТабличнойЧасти.Количество * ПолучитьЦену(СтрокаТабличнойЧасти.Наименование)

КонецПроцедуры

&НаСервере
Функция ПолучитьЦену(Ссылка)
    Возврат Ссылка.Цена
КонецФункции
Показать
sSpy; oleg-x; killitch; +3 Ответить
5. sSpy 11.02.19 14:47 Сейчас в теме
(4)Большое Вам спасибо! Помогли разобраться! Теперь буду знать!
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Москва
зарплата от 160 000 руб. до 180 000 руб.
Полный день

Ведущий программист / Руководитель проектов 1С
Москва
зарплата от 190 000 руб. до 190 000 руб.
Полный день

Программист 1С ЗУП
Уфа
зарплата от 60 000 руб. до 90 000 руб.
Полный день

Программист 1С
Москва
зарплата от 140 000 руб. до 140 000 руб.
Полный день

Программист 1С
Санкт-Петербург
Полный день