1. Roman_Go 2 10.02.19 15:06 Сейчас в теме

имя печатной формы выводимое на экран

Подскажите. Делал печатные формы внешние и только сейчас заметил, что в панели окон там "печать документа", когда типовые печатаешь там имя документа, где во внешней печатной форме это задается? зуп 3.1 если что
Ответы
Избранное Подписка Сортировка: Древо
2. Aspiring_specialist 2 10.02.19 15:39 Сейчас в теме
(1)там где команда прописываеться на вывод макета. Вроде ТабДок. Показать("Приходный кассовый ордер"). Если не ошибаюсь. нужно посмотреть
3. Aspiring_specialist 2 10.02.19 15:46 Сейчас в теме
(2)
Если СтатусыДокумента = 0 Тогда
ФормированиеПКО().Показать("Приходный кассовый ордер");
Иначе
ФормированиеРКО().Показать("Расходный кассовый ордер");
КонецЕсли;

Вот где показать нужно прописывать
4. Roman_Go 2 10.02.19 17:51 Сейчас в теме
перефразирую, где во внешней печатной форме бсп, задать параметр, который потом пойдет в качестве параметра в ПОКАЗАТЬ
5. Aspiring_specialist 2 10.02.19 18:11 Сейчас в теме
(4)код есть? или прописать там где формируете сам макет ВПФ (табличный документ)
6. Roman_Go 2 10.02.19 18:29 Сейчас в теме
(5)
Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт

	//
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "МакетСрочный20161217") Тогда
		
		
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
		КоллекцияПечатныхФорм,
		"МакетСрочный20161217", НСтр("ru='Дополнительное соглашение срочное от 16.12.2016 (универсальное)'"),
		ПолучитьТабличныйДокументДопСоглашенияСрочный_СУ( МассивОбъектов, ОбъектыПечати, "МакетСрочный20161217"), ,		
		"МакетСрочный20161217");

		
	КонецЕсли;
	//
	
КонецПроцедуры
Показать



во внешней печатной форме нету "показать"
7. Aspiring_specialist 2 10.02.19 18:50 Сейчас в теме
(6)Подожди это Процедура печать, а где у тебя сам макет печатной формы формируеться? Где области выводишь и т.д.
8. Roman_Go 2 12.02.19 12:28 Сейчас в теме
(7) нигде, за меня это делает БСП. Поэтому вопрос, что и где задать в том месте, которое я показал, чтобы БСП встроенный в ЗУП 3.1 напечатал заголовок, который я хочу, а не "печать документа"

ну или в паре других служебных функций, которые есть во внешней обработке


#Область РегистрацияВПФ
//==========================================================­============================================================­
Функция ПолучитьТаблицуКоманд()
Команды = Новый ТаблицаЗначений;
Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
Возврат Команды;

КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
НоваяКоманда = ТаблицаКоманд.Добавить();
НоваяКоманда.Представление = Представление;
НоваяКоманда.Идентификатор = Идентификатор;
НоваяКоманда.Использование = Использование;
НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
НоваяКоманда.Модификатор = Модификатор;
КонецПроцедуры

Функция СведенияОВнешнейОбработке() Экспорт
ПараметрыРегистрации = Новый Структура;
МассивНазначений = Новый Массив;
//МассивНазначений.Добавить("Документ.ПриемНаРаботу"); //Указываем документ к которому делаем внешнюю печ. форму
//МассивНазначений.Добавить("Документ.ПриемНаРаботуСписком"); //Указываем документ к которому делаем внешнюю печ. форму
МассивНазначений.Добавить("Документ.ВедомостьНаВыплатуЗарплатыВБанк"); //Указываем документ к которому делаем внешнюю печ. форму
ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); //может быть - ПечатнаяФорма, ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов...
ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
ПараметрыРегистрации.Вставить("Наименование", "Заявка на оплату в банк (МеКаМи)"); //имя под которым обработка будет зарегестрирована в справочнике внешних обработок
ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);
ПараметрыРегистрации.Вставить("Версия", "1.0");
ПараметрыРегистрации.Вставить("Информация", "Заявка на оплату в банкх (МеКаМи)");
ТаблицаКоманд = ПолучитьТаблицуКоманд();

ДобавитьКоманду(ТаблицаКоманд, "Заявка на оплату в банк (МеКаМи)", "ЗаявкаНаОплатуВБанк", "ВызовСерверногоМетода", Истина, "ПечатьMXL");

ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

Возврат ПараметрыРегистрации;
КонецФункции
//==========================================================­============================================================­
#КонецОбласти
Показать



потом аналог той процедуры которую я выше показал ну и какое-нибудь "получитьТабличныйДокумент" которая возвращает, но не показыват ТабличныйДокумент
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Специалист техподдержки 1С
Иркутск
зарплата от 28 000 руб. до 34 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 48 000 руб. до 96 000 руб.
По совместительству

Программист 1С
Ставрополь
зарплата от 40 000 руб. до 60 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Преподаватель 1С
Самара
зарплата от 50 000 руб. до 100 000 руб.
По совместительству