Расширение: Темы для 1С 8.3

0. 649 10.02.19 00:27 Сейчас в теме
Расширение позволяет сменить цвет оформления для интерфейса Такси.

Перейти к публикации

Лучшие комментарии
14. margo2007 12 05.12.20 04:03 Сейчас в теме
Спасибо.
Пользователи работают в 2-х программах и цветовая визуализация очень помогает.
Остальные комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. cmd_vasec 34 13.02.19 17:26 Сейчас в теме
А фон окна изменить можно?
2. spec8s 649 13.02.19 21:59 Сейчас в теме
(1) Пока такой возможности нет и не анонсирована
adhocprog; +1 Ответить
3. Denis1404 9 10.10.19 13:16 Сейчас в теме
Добрый день! Подскажите пожалуйста, в статье по этой ссылке https://wonderland.v8.1c.ru/blog/podderzhka-korporativnogo-stilya/ написано что Стиль можно задавать в обработчике события УстановкаПараметровСеанса(), но когда там прописываю стиль, при запуске система ругается что свойство не может быть изменено после вызова УстановкаПараметровСеанса. Можете подсказать в итоге в каком месте нужно производить установку стиля если не в процедуре УстановкаПараметровСеанса()?
adhocprog; idhas; +2 Ответить
4. AlX0id 14.10.19 09:42 Сейчас в теме
(3)
Ток что пробовал на платформе 1513 - именно так и работает - в процедуре УстановкаПараметровСеанса() ставите главный стиль - и все.
5. spec8s 649 15.10.19 09:51 Сейчас в теме
(3)Все верно, процедура УстановкаПараметровСеанса может вызываться несколько раз, уже после старта системы.
Поэтому нужно вставить проверку в начало процедуры:

Если ТребуемыеПараметры <>  Неопределено Тогда
	Возврат;
КонецЕсли;


Процедура УстановкаПараметровСеанса(ТребуемыеПараметры)
	
	Если ТребуемыеПараметры <>  Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	ГлавныйСтиль = БиблиотекаСтилей[ИмяВашегоСтиля];		
		
КонецПроцедуры
Показать
yatec; CD_SVEN; adhocprog; Denis1404; +4 Ответить
8. 7OH 32 11.03.20 14:52 Сейчас в теме
(5) а разве красиво при получении каждого параметра устанавливать стиль ?
Параметр ведь могут установить и гораздо позже - после открытия - разве нет ?
9. spec8s 649 13.03.20 15:34 Сейчас в теме
(8) Ну так и вставлена проверка, которая позволяет выполнить установку стиля только 1 раз
Если ТребуемыеПараметры <> Неопределено Тогда
Возврат;
КонецЕсли;
10. 7OH 32 13.03.20 15:50 Сейчас в теме
(9) подзабыл, что в этой процедуре нет параметра этоПервыйЗапуск и его функция возложена на проверку параметров на Неопределено.
Каюсь )
6. kotov2000 5 15.10.19 21:15 Сейчас в теме
Еще бы хорошо сделать цветовую настройку по умолчанию для всех пользователей
7. rudsergo 26.12.19 10:32 Сейчас в теме
Спасибо!!! Проверили на зарплате 8.3.12 работает.
11. margo2007 12 04.12.20 10:43 Сейчас в теме
Расширение замечательное.
Поставила 8.3.15 УТ 11.4.11.104
Все сразу заработало без проблем. Приятная зеленая схема.

Вопрос: а можно сразу всем пользователям сменить схему?
12. spec8s 649 04.12.20 15:39 Сейчас в теме
(11)Подумаю над этим, добавлю в новом обновлении
13. spec8s 649 04.12.20 17:45 Сейчас в теме
(11)Вышла версия 1.0.0.3, в ней добавлено назначение темы всем пользователям.
14. margo2007 12 05.12.20 04:03 Сейчас в теме
Спасибо.
Пользователи работают в 2-х программах и цветовая визуализация очень помогает.
15. user825349 18.03.21 17:02 Сейчас в теме
16. spec8s 649 18.03.21 17:43 Сейчас в теме
17. user1355107 01.04.21 06:48 Сейчас в теме
на 1С Предприятие 8.3 данное расширение будет работать ?
18. imh0593 10.04.21 18:15 Сейчас в теме
а что там за двоичные данные, макет цветовые схемы? что за формат там, в какой программе создается?
19. spec8s 649 10.04.21 21:40 Сейчас в теме
(18) Я так понимаю речь про автоустановщик?
В макете файл расширения, который можно скачать отдельно на этой же страничке
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Программист 1С
Севастополь
зарплата от 150 000 руб. до 200 000 руб.
Полный день

Программист 1С
Москва
зарплата от 120 000 руб.
Полный день

Ведущий программист-консультант 1С (УХ)
Москва
зарплата от 250 000 руб. до 250 000 руб.
Полный день

Программист 1С (розница)
Москва
зарплата от 160 000 руб. до 160 000 руб.
Полный день