Расширение: Темы для 1С: Предприятия

0. spec8s 514 10.02.19 00:27 Сейчас в теме
Расширение позволяет сменить цвет оформления для интерфейса Такси.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. cmd_vasec 34 13.02.19 17:26 Сейчас в теме
А фон окна изменить можно?
2. spec8s 514 13.02.19 21:59 Сейчас в теме
(1) Пока такой возможности нет и не анонсирована
adhocprog; +1 Ответить
3. Denis1404 9 10.10.19 13:16 Сейчас в теме
Добрый день! Подскажите пожалуйста, в статье по этой ссылке https://wonderland.v8.1c.ru/blog/podderzhka-korporativnogo-stilya/ написано что Стиль можно задавать в обработчике события УстановкаПараметровСеанса(), но когда там прописываю стиль, при запуске система ругается что свойство не может быть изменено после вызова УстановкаПараметровСеанса. Можете подсказать в итоге в каком месте нужно производить установку стиля если не в процедуре УстановкаПараметровСеанса()?
adhocprog; idhas; +2 Ответить
4. AlX0id 14.10.19 09:42 Сейчас в теме
(3)
Ток что пробовал на платформе 1513 - именно так и работает - в процедуре УстановкаПараметровСеанса() ставите главный стиль - и все.
5. spec8s 514 15.10.19 09:51 Сейчас в теме
(3)Все верно, процедура УстановкаПараметровСеанса может вызываться несколько раз, уже после старта системы.
Поэтому нужно вставить проверку в начало процедуры:

Если ТребуемыеПараметры <>  Неопределено Тогда
	Возврат;
КонецЕсли;


Процедура УстановкаПараметровСеанса(ТребуемыеПараметры)
	
	Если ТребуемыеПараметры <>  Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	ГлавныйСтиль = БиблиотекаСтилей[ИмяВашегоСтиля];		
		
КонецПроцедуры
Показать
adhocprog; Denis1404; +2 Ответить
8. 7OH 32 11.03.20 14:52 Сейчас в теме
(5) а разве красиво при получении каждого параметра устанавливать стиль ?
Параметр ведь могут установить и гораздо позже - после открытия - разве нет ?
9. spec8s 514 13.03.20 15:34 Сейчас в теме
(8) Ну так и вставлена проверка, которая позволяет выполнить установку стиля только 1 раз
Если ТребуемыеПараметры <> Неопределено Тогда
Возврат;
КонецЕсли;
10. 7OH 32 13.03.20 15:50 Сейчас в теме
(9) подзабыл, что в этой процедуре нет параметра этоПервыйЗапуск и его функция возложена на проверку параметров на Неопределено.
Каюсь )
6. kotov2000 5 15.10.19 21:15 Сейчас в теме
Еще бы хорошо сделать цветовую настройку по умолчанию для всех пользователей
7. rudsergo 26.12.19 10:32 Сейчас в теме
Спасибо!!! Проверили на зарплате 8.3.12 работает.
Оставьте свое сообщение
Вопросы с вознаграждением