0. drmaxart 73 12.01.19 22:02 Сейчас в теме

Раздельный вывод частей даты на форму без программирования

Небольшой лайфхак для повышения удобства редактирования пользователем полей с типом "Дата".

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. acanta 57 12.01.19 22:07 Сейчас в теме
Супер. Давно такую искала. Спасибо.
Jimbo; drmaxart; +2 Ответить
2. drmaxart 73 12.01.19 22:14 Сейчас в теме
(1)Спасибо, приятно слышать!
3. ltfriend 309 13.01.19 08:19 Сейчас в теме
Это самый очевидный и простой способ, а не создавать лишние реквизиты. Применимо и к обычным формам.
Jimbo; drmaxart; +2 Ответить
7. drmaxart 73 13.01.19 13:17 Сейчас в теме
(3) согласен! По этой причине я и уточнил, что именно лично я считал так до осознания описанного варианта
4. motorsoft 2 13.01.19 11:46 Сейчас в теме
Отлично, взял на заметку
drmaxart; +1 Ответить
5. rozer 233 13.01.19 12:11 Сейчас в теме
6. MCV 13.01.19 13:16 Сейчас в теме
8. acanta 57 13.01.19 13:29 Сейчас в теме
Вопрос: как должен выглядеть обработчик, чтобы при регулировании минут минуты были кратны, например 10?
9. drmaxart 73 13.01.19 14:33 Сейчас в теме
(8)Нужно реализовать обработчик события Регулирования у поля минут, в нём параметр Направление позволяет определить, какая из кнопок регулирования была нажата. При нажатии на увеличение (вверх) параметр равен 1, при нажатии на уменьшение (вниз) - равен -1. То есть ставим СтандартнаяОбработка в ЛОЖЬ и пишем Дата = Дата + 600 * Направление
DrAku1a; gradi; rpgshnik; acanta; +4 Ответить
10. kolosof 13.01.19 15:44 Сейчас в теме
11. kembrik 2 14.01.19 10:45 Сейчас в теме
Способ кстати прекрасно работает и на обычных формах, именно там я его и подсмотрел у предшественника, отлично мигрировал в управляемые. От кнопок выбора даты и переметки времени совсем отказались в итоге, данный функционал используется при таксировке путевых листов, там операторы обрабатывали путевые с клавиатуры с дикой скоростью, лишние контролы и мышка только замедляли процесс. Мы еще цветом подсвечиваем и шрифтами выделяем, совсем глазасто получается
Прикрепленные файлы:
drmaxart; +1 Ответить
12. dock 35 14.01.19 22:39 Сейчас в теме
Как оказалось, проще всего вспомнить тот факт, что элемент формы отображает данные, указанные в свойстве "ПутьКДанным", но эта связь может иметь вид "Один ко многим" - одни и те же данные могут отображаться несколькими угодно элементами формы!

Если такие вещи приходят "сам случайно увидел его у коллеги ", то как же у нас всё плохо с обучением...
Или в 1С-ники приходят совсем не программисты...
З.Ы. автору благодарность за наставление юных подаванов на пусть истины ;)
13. drmaxart 73 14.01.19 22:44 Сейчас в теме
(12)Ну за чем так критично - этот факт все знают, просто лично я вот просто не задумывался о таком варианте применения, в голову не приходило. Бывает)
14. dock 35 14.01.19 23:04 Сейчас в теме
(13) :) вот в этом и есть отличие в образовании. Я открыл статью, думал реально "что-то"... Посмотрел свой код, вспомнил как писал: у меня просто даже мысли не было, что можно сделать как-то по другому :) Скорее были тесты на правильное поведение системы.
Лирика:
Когда ты ещё студент, очень многие принципы/методы/подходы просто закладываются чуть ли не на уровень подсознания.
Закладывается базис, который в дальнейшем вырабатывается в стиль - почерк. Одно дело, когда ты в 20 лет на курсе по базам данных выполняешь лабораторные работы по приведению БД к 6-й нормальной форме и к окончанию курса ты просто не можешь сделать базу менее чем в 3-й НФ (что и обещал преподаватель)... И совсем другое дело, когда ты в 30 лет узнаешь вообще о том, что БД оказывается-то реляционная...
С опытом только по коду начинаешь определять, из какой сферы пришёл человек в программисты 1С.
15. Danilov 15.01.19 09:19 Сейчас в теме
Отлично, взял на заметку
ValentinGushchin; drmaxart; +2 Ответить
16. suepifanov 15.01.19 14:56 Сейчас в теме
дополнительно к этому можно сделать список быстрого выбора времени как, например, сделано в УНФ.
Кнопка выпадающего списка = да, и ПриСозданииНаСервере заполнить список нужными интервалами.

// Процедура заполняет список выбора времени.
// Параметры:
//  ПолеВводаФормы  - элемент-владелец списка,
//  Интервал        - интервал, с которым необходимо заполнить список, по умолчанию час.
Процедура ЗаполнитьСписокВыбораВремени(ПолеВводаФормы, Интервал = 3600, Начало = '00010101080000', Окончание = '00010101200000') Экспорт
	
	СписокВремен = ПолеВводаФормы.СписокВыбора;
	СписокВремен.Очистить();
	
	ВремяСписка = НачалоЧаса(Начало);
	
	Пока НачалоЧаса(ВремяСписка) <= НачалоЧаса(Окончание) Цикл
		
		Если НЕ ЗначениеЗаполнено(ВремяСписка) Тогда
			ПредставлениеВремени = "00:00";
		Иначе
			ПредставлениеВремени = Формат(ВремяСписка,"ДФ=ЧЧ:мм");
		КонецЕсли;
		
		СписокВремен.Добавить(ВремяСписка, ПредставлениеВремени);
		
		ВремяСписка = ВремяСписка + Интервал;
		
	КонецЦикла;
	
КонецПроцедуры
Показать
Прикрепленные файлы:
drmaxart; +1 Ответить
17. androgin 15.01.19 20:59 Сейчас в теме
я конечно извиняюсь, но это не лайфхак, а тупость, при чем всем известная еще стотыщ лет назад
grachev1c; ZOMI; +2 2 Ответить
18. drmaxart 73 15.01.19 21:16 Сейчас в теме
(17)ну не для всех. Я смотрю, у Вас ко всем публикациям есть претензии. На Инфостарте много статей о вещах, которые кто-то знает, а кто-то - нет. Им поможет, для такого обмена информацией ресурс и создан
snood; ivnik; +2 Ответить
20. androgin 16.01.19 15:24 Сейчас в теме
(18) то есть по факту вам сказать нечего. поперлись копаться и искать к чему бы в ответ прицепиться?
Это вас характеризует явно не в положительном ключе))))
Уверен, что этот ресурс создан не для дошкольных публикаций и очевидных вещей, которые должен знать каждый программист. Тут гораздо более сложные и ПОЛЕЗНЫЕ материалы публикуются, а не два элемента одного реквизита с разным форматированием
19. ZOMI 417 16.01.19 14:53 Сейчас в теме
Автору пора уже готовить доклад для Infostart Event. Так лаконично разжевал такую сложную тему.
ivnik; androgin; +2 Ответить
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день

Программист 1С
Москва
Полный день

Консультант-аналитик 1С
Москва
Полный день

Консультант ERP-систем
Москва
Временный (на проект)