1. pentanom 21 11.01.19 18:16 Сейчас в теме

УТ 10.3 Изменить основную ставку НДС у всех пользователей.

В связи с изменением ставки НДС необходимо изменить "Основную ставку НДС" в настройках у всех пользователей. Может быть кто-нибудь уже сделал такую обработку ?
Найденные решения
4. antz 11.01.19 18:47 Сейчас в теме
9. pentanom 21 11.01.19 19:58 Сейчас в теме
Ну и для всех мой вариант:
Процедура КнопкаВыполнитьНажатие(Кнопка)
	
	Ном=0;
	Набор = РегистрыСведений.НастройкиПользователей.СоздатьНаборЗаписей();
	Набор.Отбор.Настройка.Установить(ПланыВидовХарактеристик.НастройкиПользователей.ОсновнаяСтавкаНДС);
	Набор.Прочитать();
	Для каждого ЗаписьНабора Из Набор Цикл
		Если ЗаписьНабора.Значение=Было Тогда
			ЗаписьНабора.Значение=Стало;
			Ном = Ном+1;
			Сообщить(""+ЗаписьНабора.Пользователь+" - "+ЗаписьНабора.Значение);
		КонецЕсли;
	КонецЦикла;
	Набор.Записать();
	Сообщить("Выполнено ! - " +Ном);
	
КонецПроцедуры
Показать
Остальные ответы
Избранное Подписка Сортировка: Древо
2. antz 11.01.19 18:30 Сейчас в теме
Их сделали, по-моему, несколько тысяч перед НГ) И все вывалили сюда.
Поиск не находит, что ли?
3. pentanom 21 11.01.19 18:40 Сейчас в теме
(2)
Поиск не находит, что ли?
Это удивительно, но не находит :(
4. antz 11.01.19 18:47 Сейчас в теме
5. pentanom 21 11.01.19 18:52 Сейчас в теме
(4)
И эта не годится?
Которая ? Вероятно, вы хотели написать ссылку, а забыли.
6. antz 11.01.19 18:57 Сейчас в теме
(5) ссылка спрятана в слове "эта" :)
7. pentanom 21 11.01.19 19:12 Сейчас в теме
(6)Спасибо ! Годится.
Но у меня совсем с головой что-то. Я сам написал похожую обработку еще в начале декабря. И забыл!!! А сейчас нашел.
8. antz 11.01.19 19:18 Сейчас в теме
(7) эти игры с ндс многим сделали что-то с головой)
9. pentanom 21 11.01.19 19:58 Сейчас в теме
Ну и для всех мой вариант:
Процедура КнопкаВыполнитьНажатие(Кнопка)
	
	Ном=0;
	Набор = РегистрыСведений.НастройкиПользователей.СоздатьНаборЗаписей();
	Набор.Отбор.Настройка.Установить(ПланыВидовХарактеристик.НастройкиПользователей.ОсновнаяСтавкаНДС);
	Набор.Прочитать();
	Для каждого ЗаписьНабора Из Набор Цикл
		Если ЗаписьНабора.Значение=Было Тогда
			ЗаписьНабора.Значение=Стало;
			Ном = Ном+1;
			Сообщить(""+ЗаписьНабора.Пользователь+" - "+ЗаписьНабора.Значение);
		КонецЕсли;
	КонецЦикла;
	Набор.Записать();
	Сообщить("Выполнено ! - " +Ном);
	
КонецПроцедуры
Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Москва
Полный день

Программист 1С
Видное
Полный день

Программист 1С
Москва
зарплата до 120 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата от 100 000 руб. до 170 000 руб.
Полный день