1. Stanislav1993 10.01.19 15:48 Сейчас в теме

Ошибки в отображении печати штрихкода в макете

Добрый день, друзья. У меня возникла проблемка при выводе макета на печать - не отображаются данные в макете. Модуль "РаботаСТорговымОборудованием" и "КомпонентыПечатиШтрихкодов" в разделе общие макеты - подключены. Все функции имеются.

//Код для кнопки
Процедура Печать(ТабДок, Ссылка) Экспорт
	ВнешняяКомпонента = РаботаСТорговымОборудованием.ПодключитьВнешнююКомпонентуПечатиШтрихкода();
	Если ВнешняяКомпонента = Неопределено Тогда
		Сообщить("Не удалось получить компоненту штрих код");
		Возврат;
	КонецЕсли;
	
	Макет = Справочники.Номенклатура.ПолучитьМакет("Печать");
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	Номенклатура.БарКод КАК БарКод,
		|	Номенклатура.Наименование КАК Наименование
		|ИЗ
		|	Справочник.Номенклатура КАК Номенклатура
		|ГДЕ
		|	Номенклатура.Ссылка В (&Ссылка)";
	
	Запрос.Параметры.Вставить("Ссылка", Ссылка);
	Выборка = Запрос.Выполнить().Выбрать();

	//ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
	Шапка = Макет.ПолучитьОбласть("Шапка");
	ТабДок.Очистить();
    
	ВставлятьРазделительСтраниц = Ложь;
	Пока Выборка.Следующий() Цикл
		Если ВставлятьРазделительСтраниц Тогда
			ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
		КонецЕсли;
   
		Шапка.Параметры.Заполнить(Выборка);
		Шапка.Рисунки.ШтрихКод.Картинка = РаботаСТорговымОборудованием.ПолучитьКартинкуШтрихкода(ВнешняяКомпонента,Выборка.БарКод, 49, 35); //  ОбщегоНазначения.СформироватьБарКодEAN13()
		Сообщить(ВнешняяКомпонента);
		Сообщить(Выборка.БарКод);
	    Сообщить(Выборка.Наименование);
		
		ТабДок.Вывести(Шапка, Выборка.Уровень());
   		ВставлятьРазделительСтраниц = Истина;
	КонецЦикла;
	//}}
КонецПроцедуры

Показать


Подскажите пожалуйста как исправить.
Ответы
Избранное Подписка Сортировка: Древо
2. login1020 16 10.01.19 16:02 Сейчас в теме
(1)
РаботаСТорговымОборудованием.ПолучитьКартинкуШтрихкода(ВнешняяКомпонента,Выборка.БарКод, 49, 35)

Посмотрите в Отладке что возвращает эта функция

или всё валится уже здесь?

(1)
ВнешняяКомпонента = РаботаСТорговымОборудованием.ПодключитьВнешнююКомпонентуПечатиШтрихкода(); Если ВнешняяКомпонента = Неопределено Тогда Сообщить("Не удалось получить компоненту штрих код"); Возврат; КонецЕсли;
3. Stanislav1993 10.01.19 16:10 Сейчас в теме
(2)Ничего, даже сообщений нет. Просто белый лист
4. Stanislav1993 10.01.19 16:12 Сейчас в теме
(2)РаботаСТорговымОборудованием.ПолучитьКартинкуШтрихкода(ВнешняяКомпонента,Выборка.БарКод, 49, 35) возвращает в отладчике - Неопределенно;
5. login1020 16 10.01.19 16:17 Сейчас в теме
(4) вот Вы и получили свой ответ, отладкой проходите в функцию
РаботаСТорговымОборудованием.ПолучитьКартинкуШтрихкода

и смотрите в какой момент все теряется.
ВнешняяКомпонента - чему равна?
6. Stanislav1993 10.01.19 16:17 Сейчас в теме
(5)ВнешняяКомпонента = РаботаСТорговымОборудованием.ПодключитьВнешнююКомпонентуПечатиШтрихкода();
7. login1020 16 10.01.19 16:20 Сейчас в теме
(6) В отладчике какое значение принимает переменная
ВнешняяКомпонента
8. Stanislav1993 10.01.19 16:23 Сейчас в теме
(7)AddIn.КартинкаШтрихКода.Barcode
9. login1020 16 10.01.19 16:28 Сейчас в теме
(8) Тогда отладчик, и идём в функцию
РаботаСТорговымОборудованием.ПолучитьКартинкуШтрихкода

заодно посмотрите с типами ничего не напутали, передавая параметры в функцию.
11. Stanislav1993 11.01.19 10:29 Сейчас в теме
(9)Решилась проблема. Сущий пустяк. А так все работает))
10. Stanislav1993 10.01.19 16:28 Сейчас в теме
Могу скинуть конфу, если хотите
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Москва
Полный день

Программист 1С
Видное
Полный день

Программист 1С
Москва
зарплата до 120 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата от 100 000 руб. до 170 000 руб.
Полный день