Жесткий контроль ставки НДС (любые конфигурации, обычные формы)

0. 104 29.12.18 09:10 Сейчас в теме
Подсистема для проверки корректности указания ставок НДС перед записью документов. Для любых конфигураций на обычных формах.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. ksnik 564 29.12.18 16:19 Сейчас в теме
Работает. Только у нас ставки не перечисления а предопределенные элементы справочника,
Функция ПроверитьСтавкуНДС(СтавкаНДС, ДатаДок, Отказ, ИмяТабЧасти = "", НомерСтроки = 0)
	
	Если ДатаДок < '20190101' И СтавкаНДС = Справочники.СтавкиНДС.НДС20  Тогда
		...
	КонецЕсли;
	
	Если ДатаДок >= '20190101' И СтавкаНДС = Справочники.СтавкиНДС.НДС20 Тогда
		...
	КонецЕсли;
	
КонецФункции
Показать

и есть уже функция проверяющая наличие реквизита поэтому переименовали
Функция ЕстьРеквизитДокументаНДС(ИмяРеквизита, МетаданныеДокумента)

Объединение конфигурации предлагает изменить свойства конфигурации, поэтому объединять надо осторожно - выборочно, а не принимать все изменения. И картинку мы не стали загружать.
2. ksnik 564 01.01.19 08:03 Сейчас в теме
Еще добавил в этот модуль функцию для задания основной ставки по умолчанию:
Функция ВыбратьСтавкуНДСПоДатеДокумента(СсылкаНаДокументДата)
	Если ТипЗнч(СсылкаНаДокументДата)=ТипЗнч(Дата(2019,01,01)) Тогда
		ДатаДок = СсылкаНаДокумент;
	Иначе
		ДатаДок = СсылкаНаДокумент.Дата;
	КонецЕсли;
	Если ДатаДок < '20190101' Тогда 
		СтавкаНДС = Справочники.СтавкиНДС.НДС18;
	Иначе	
		СтавкаНДС = Справочники.СтавкиНДС.НДС20;
	КонецЕсли;
	Возврат СтавкаНДС;
КонецФункции
Показать
3. DarkPinch222 104 01.01.19 08:23 Сейчас в теме
(2) Тестировалось на типовых конфигурациях (УТ 10.3, УПП 1.3), любые изменения приветствуются )
4. ksnik 564 06.01.19 18:30 Сейчас в теме
В моих фрагментах кода выше есть пара опечаток. Должно быть:
Если ДатаДок >= '20190101' И СтавкаНДС = Справочники.СтавкиНДС.НДС18 Тогда

и
    Если ТипЗнч(СсылкаНаДокументДата)=ТипЗнч(Дата(2019,01,01)) Тогда
        ДатаДок = СсылкаНаДокументДата;
    Иначе
        ДатаДок = СсылкаНаДокументДата.Дата;
    КонецЕсли;

Еще мы сделали из этого запрета исключения бухгалтерам на банковские документы.
5. wrangel87 31.01.19 05:55 Сейчас в теме
Здравствуйте! А можно ли сделать под платформу 8.3.10.2667 для УПП?
6. DarkPinch222 104 31.01.19 13:28 Сейчас в теме
(5) эта подсистема будет работать и на УПП 1.3
7. wrangel87 31.01.19 14:09 Сейчас в теме
При объединении требует обновить до платформы 8.3.12.1567, а я чет боюсь обновлять. как УПП будет работать на этой платформе незнаю.
8. DarkPinch222 104 31.01.19 14:20 Сейчас в теме
(7) тут наверное в свойствах самой конфигурации стоит режим совместимости 8.3.12, попробуйте сравнить/объединить с конфигурацией из файла, просто снять все галочки и меню действия - отметить по подсистемам файла - выбрать подсистему контроль НДС.
9. wrangel87 31.01.19 15:39 Сейчас в теме
во вложениие скрин сообщения которое появляется при попытке сравнить/объединить с конфигурацией из файла.
Прикрепленные файлы:
10. wrangel87 31.01.19 16:06 Сейчас в теме
Вроде дошло до меня. Я в Вашей конфе поменял режим совместимости на 8,3,10. Спасибо!
11. DarkPinch222 104 31.01.19 16:48 Сейчас в теме
Оставьте свое сообщение
Вакансии
Программист 1С
Нижний Новгород
зарплата от 170 000 руб.
Полный день

Программист 1С
Екатеринбург
зарплата от 120 000 руб. до 130 000 руб.
Полный день

Администратор 1C
Москва
зарплата до 110 000 руб.
Полный день

Программист 1С
Москва
зарплата до 150 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата до 130 000 руб.
Полный день