0. pentanom 21 24.12.18 02:16 Сейчас в теме

Переход на НДС 20% для 1С:7.7

Для 1С:Предприятия 8 переход на НДС 20% сделан, а для 7.7 я не нашел. Выкладываю.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. pentanom 21 24.12.18 11:16 Сейчас в теме
Если у кого-нибудь будут пожелания, исправлю и дополню.
2. user1125368 09.01.19 11:23 Сейчас в теме
Добрый день, напишите, пожалуйста, каким образом и что запускать из архива?
3. pentanom 21 10.01.19 20:16 Сейчас в теме
(2)
Добрый день, напишите, пожалуйста, каким образом и что запускать из архива?
Никакого архива нет. Нужно просто запустить обработку.
Но можно просто обновить релизы до 7.70.646 (ОСНО) и 7.70.288 (УСН). Там это встроено.
4. natoptic 11.01.19 08:15 Сейчас в теме
я до 646 обновила .2019 работает нормально , а в 2018 книга продаж и печатные формы по валютным счетам вместо 18 % считает 20% ндс.причем проводки и экранная форма остается правильной. в чем может быть проблема?
5. natoptic 11.01.19 08:17 Сейчас в теме
6. pentanom 21 11.01.19 13:14 Сейчас в теме
(5)Это на базу нужно посмотреть. Она у вас типовая или с дописками ?
8. natoptic 11.01.19 19:12 Сейчас в теме
Типовая, но есть несколько подключенных ert отчетов
9. pentanom 21 11.01.19 19:14 Сейчас в теме
(8)Ну и как посмотреть на базу ?
10. natoptic 11.01.19 23:24 Сейчас в теме
а какие варианты возможны?
11. pentanom 21 12.01.19 05:47 Сейчас в теме
(10)в зависимости от величины базы. Можно, например, выложить в облако.
12. user853631 14.01.19 10:09 Сейчас в теме
пришлите пожалуйста обработку, не хватает sm на dsl85{Собака}mail.ru
13. pentanom 21 14.01.19 15:33 Сейчас в теме
14. tn55 15.01.19 20:39 Сейчас в теме
Обновила базу до 646 релиза. Чуда не свершилось. В Номенклатуре как было 18% так и осталось, в константах тоже ничего не поменялось. Запустила обработку "Установка ставок налогов в справочнике Номенклатура", вручную изменила ставку НДС в Константах. Вроде все работает, но полной уверенности нет.. Только у меня "чудеса"? Поделитесь опытом.

Спасибо!
15. pentanom 21 15.01.19 21:00 Сейчас в теме
(14)В обновлении ИБ есть такой кусок:
	ИначеЕсли Номер = 770646 Тогда
		
		// Если в справочнике "Ставки НДС" нет, ставки 20%, то добавим ее
		Состояние("Обновление ставки НДС");
		
		СтавкаНДС20Существует = 0;
		СтавкаНДС20 = "";
		
		СтавкиНДС = СоздатьОбъект("Справочник.СтавкиНДС");
		СтавкиНДС.ВыбратьЭлементы();
		Пока СтавкиНДС.ПолучитьЭлемент() = 1 Цикл
		    Если СтавкиНДС.Ставка = 20 Тогда
		        СтавкаНДС20Существует = 1;
				СтавкаНДС20 = СтавкиНДС.ТекущийЭлемент();
				Прервать;
		    КонецЕсли;
		КонецЦикла;
		
		Если СтавкаНДС20Существует = 0 Тогда
			СтавкиНДС.Новый();
			СтавкиНДС.Ставка = 20;
			СтавкиНДС.Наименование = "20%";
			СтавкиНДС.Записать();
			СтавкаНДС20 = СтавкиНДС.ТекущийЭлемент();
			СтавкаНДС20Существует = 1;
		КонецЕсли;
		                                    
		// Если в справочнике "Варианты расчета налогов" нет
		// вариантов со ставками 20%, то добавим их.
		Состояние("Обновление справочника  ""Варианты расчета налогов""");
		НайденВариант20ВСумме = 0;
		НайденВариант20Сверху = 0;
		Вариант20ВСумме = "";
		Вариант20Сверху = "";
		
		ВариантыНалогов = СоздатьОбъект("Справочник.ВариантыРасчетаНалогов");
		ВариантыНалогов.ВыбратьЭлементы();
		Пока ВариантыНалогов.ПолучитьЭлемент() = 1 Цикл
		    Если ВариантыНалогов.СтавкаНДС.Ставка = 20 Тогда
				Если ВариантыНалогов.СтавкаНП.Ставка = 0 Тогда
				    Если ВариантыНалогов.СуммаВключаетНДС = 1 Тогда
				        НайденВариант20ВСумме = 1;
						Вариант20ВСумме = ВариантыНалогов.ТекущийЭлемент();
					Иначе
						НайденВариант20Сверху = 1;
						Вариант20Сверху = ВариантыНалогов.ТекущийЭлемент();
				    КонецЕсли;
				КонецЕсли;
		    КонецЕсли;
		КонецЦикла;
		
		Если НайденВариант20ВСумме = 0 Тогда // не найден вариант 20% в сумме
			ВариантыНалогов.Новый();
			ВариантыНалогов.СуммаВключаетНДС = 1;
			ВариантыНалогов.СуммаВключаетНП = 0;
			ВариантыНалогов.СтавкаНДС = СтавкиНДС.ТекущийЭлемент();
			ВариантыНалогов.СтавкаНП = глБезНалога("НП");
			ВариантыНалогов.Наименование = НаименованиеВариантаРасчетаНалогов(ВариантыНалогов);
			ВариантыНалогов.Записать();
			Вариант20ВСумме = ВариантыНалогов.ТекущийЭлемент();
		КонецЕсли;
		
		Если НайденВариант20Сверху = 0 Тогда // не найден вариант 20% сверху
			ВариантыНалогов.Новый();
			ВариантыНалогов.СуммаВключаетНДС = 0;
			ВариантыНалогов.СуммаВключаетНП = 0;
			ВариантыНалогов.СтавкаНДС = СтавкиНДС.ТекущийЭлемент();
			ВариантыНалогов.СтавкаНП = глБезНалога("НП");
			ВариантыНалогов.Наименование = НаименованиеВариантаРасчетаНалогов(ВариантыНалогов);
			ВариантыНалогов.Записать();
			Вариант20Сверху = ВариантыНалогов.ТекущийЭлемент();
		КонецЕсли;
		
		СтавкаНДС18Существует = 0;
		СтавкаНДС18 = "";
		
		СтавкиНДС.ВыбратьЭлементы();
		Пока СтавкиНДС.ПолучитьЭлемент() = 1 Цикл
			Если СтавкиНДС.Ставка = 18 Тогда
				СтавкаНДС18Существует = 1;
				СтавкаНДС18 = СтавкиНДС.ТекущийЭлемент();
				Прервать;
			КонецЕсли;
		КонецЦикла;
		
		Если (СтавкаНДС18Существует = 1) И (СтавкаНДС20Существует = 1) Тогда
			СпрНоменклатура = СоздатьОбъект("Справочник.Номенклатура");
			СпрНоменклатура.ВыбратьЭлементы();
			Пока СпрНоменклатура.ПолучитьЭлемент() = 1 Цикл
				Если СпрНоменклатура.СтавкаНДС.Получить('01.01.2019') = СтавкаНДС18 Тогда 
					СпрНоменклатура.СтавкаНДС.Установить('01.01.2019', СтавкаНДС20); 
				КонецЕсли;
			КонецЦикла;
			Если Константа.ОсновнаяСтавкаНДС = СтавкаНДС18 Тогда
				Константа.ОсновнаяСтавкаНДС = СтавкаНДС20;
			КонецЕсли;
			Если Константа.ОсновнойВариантРасчетаНалогов.Выбран() = 1 Тогда
				Если Константа.ОсновнойВариантРасчетаНалогов.СтавкаНДС = СтавкаНДС18 Тогда
					Если Константа.ОсновнойВариантРасчетаНалогов.СуммаВключаетНДС = 1 Тогда
						Константа.ОсновнойВариантРасчетаНалогов = Вариант20ВСумме;
					Иначе
						Константа.ОсновнойВариантРасчетаНалогов = Вариант20Сверху;
					КонецЕсли;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;
		
		Константа.СтавкаРефинансирования.Установить('17.09.2018', 7.5); 
		Константа.СтавкаРефинансирования.Установить('17.12.2018', 7.75); 
		
		
		ОбновитьТарифыСтраховыхВзносов();
		
		Константа.ПредельнаяВеличинаБазыСтраховыхВзносов.Установить('01.01.2019', 1150000); 
		Константа.ПредельнаяВеличинаБазыФСС.Установить('01.01.2019', 865000); 
		
		Таб.ВывестиСекцию(Строка(Номер));
		
	КонецЕсли;	
Показать

Видно, что на 01.01.2019 для всей номенклатуры, у которой на эту дату была ставка 18 %, должно установиться 20%. Вы на какую дату смотрите ставку НДС ?
16. tn55 16.01.19 07:26 Сейчас в теме
17. pentanom 21 16.01.19 11:36 Сейчас в теме
(16)Я бы еще просто посмотрел историю ставки НДС для какой-нибудь номенклатуры. И историю Константы "Предельная Величина Базы Страховых Взносов".
Если обработкой обновления ИБ они не изменились, то значит она не сработала. Я бы, на вашем месте, разобрался с этим.
Из того куска кода, который я выложил (15), можно сделать внешнюю обработку и запустить ее.
18. tn55 16.01.19 15:20 Сейчас в теме
Проверяла на номенклатуре с единственной ставкой 18 в истории. Константу не смотрела. Предельная величина базы Страховых взносов как могут влиять? С обратной сложнее, я не программист.
Спасибо
19. pentanom 21 16.01.19 16:31 Сейчас в теме
(18)
Предельная величина базы Страховых взносов как могут влиять?
Посто новое значение константы "Предельная Величина Базы Страховых Взносов" тоже должно было установиться на 01.01.19
А конфигурация типовая ? Или с доработками ? Кто делает обновление ?
20. tn55 16.01.19 19:55 Сейчас в теме
Предельная база 1150000 установилась. Конфигурация типовая без доработок. В справочнике ставок НДС обнаружила три записи со ставкой 18. Может в этом причина?
Спасибо
21. pentanom 21 16.01.19 20:23 Сейчас в теме
(20)
три записи со ставкой 18. Может в этом причина?
Может быть и в этом. Лишнее конечно нужно удалить. А потом попробуйте запустить прилагаемую обработку.
КОПИЮ БАЗЫ СДЕЛАТЬ ОБЯЗАТЕЛЬНО !!!

При обновлении должны были обновиться страховые взносы. Проверьте.
Прикрепленные файлы:
НДС_20.ert
22. tn55 17.01.19 00:00 Сейчас в теме
Причина именно в этом. Проверила все документы и справочники, "привязала" их все к одной записи ставки НДС. Лишние записи ставок удалила. Обновила базу до 646 релиза. Все обновилось. Все нормально. Огромное спасибо за помощь.
23. pentanom 21 17.01.19 07:44 Сейчас в теме
24. tn55 17.01.19 11:09 Сейчас в теме
Ещё раз огромное спасибо за поддержку!!! В таких ситуациях это очень важно, что ты не один со своей проблемой.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Консультант-аналитик 1С
Москва
зарплата от 100 000 руб. до 170 000 руб.
Полный день

Программист 1С
Москва
Полный день

Программист 1С
Видное
Полный день

Программист 1С
Москва
зарплата до 120 000 руб.
Полный день