1. user1105514 07.12.18 12:56 Сейчас в теме

Как записать данные в документ

Есть задача создать обработку по заполнению реквизита "Заказ покупателя" в табличной части документа "Отчет о розничных продажах". Данные о заказе брать из реквизита ЧекККМ той же табличной части. По кнопке "Заполнить" обработка будет подставлять "Заказы покупателей" и перепроводить документы ОРП. Заказы покупателей я подставил, а вот записать что-то не получается. Помоги пожалуйста.
Прикрепленные файлы:
Обработка по заполнению Заказов в ОРП.epf
Ответы
Избранное Подписка Сортировка: Древо
2. user834357 8 07.12.18 13:05 Сейчас в теме
Ну точно надо получать объект ОРП и в нем заполнять заказ клиента (если у вас уже добавлен такой реквизит в табличную часть), а так

Для Каждого Стр Из Объект.ОРПТовары1 Цикл
		     
		  Если Стр.Флажок = Истина Тогда
					
				 Стр.ЗаказКлиента = Стр.ЧекККМ.ИТ_ЗаказКлиента;
				 КонецЕсли;
	
				 
		КонецЦикла;
Показать


вы тупо перезаписываете ЗаказКлиента в строках своей обработки
3. user1105514 07.12.18 13:15 Сейчас в теме
При попытке получить объект пишет

Объект.ОРП.ПолучитьОбъект();
Ошибка при вызове метода контекста (ПолучитьОбъект)
по причине:
Элемент не выбран!
4. user614822 22 07.12.18 13:31 Сейчас в теме
Вы объект то получаете на сервере?
5. user1105514 07.12.18 13:32 Сейчас в теме
6. user623969_dusa 07.12.18 13:44 Сейчас в теме
(5) надо получать объект документа куда будете писать а Объект.ОРП - у него тип Строка
user1105514; +1 Ответить
7. user1105514 10.12.18 19:05 Сейчас в теме
Получил объект, "Заказ клиента" есть в "ЧекККМ", мне надо заказ клиента прикрутить и записать в ОРП, но что то не получается
Процедура ЗаполнитьЗаказКлиентаНаСервере()
	
	Для Каждого СтрокаТЗ из Объект.ОРПТовары1 цикл	 		
		
		 ОРПОбъект = СтрокаТЗ.ОРП.ПолучитьОбъект();
          	 ПараметрПоиска = Новый Структура;
		 ПараметрПоиска.Вставить("ИТ_ЧекККМ", "ИТ ЧекККМ");
		 НайтиСтроки = ОРПОбъект.Товары.НайтиСтроки(ПараметрПоиска);		 
		Для Каждого Стр Из НайтиСтроки Цикл
			Стр.массив.ЗаказКлиента = Стр.ЧекККМ.Записать();
		
		КонецЦикла;		
		КонецЦикла;
		ОРПОбъект.Записать();
					 		
КонецПроцедуры
Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Старший Программист 1С НОВОСИБИРСК
Новосибирск
зарплата до 130 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 75 000 руб.
Полный день



Руководитель проектов 1С
Санкт-Петербург
По совместительству