1. user916115 05.12.18 14:08 Сейчас в теме

Повтор строк

1с 8.2
Привет и всех с наступающим Новым Годом (осталось работать до НГ 3 недели и 2 дня ):)))))
Ребята, помогите пожалуйста вывести в печать пустые строки, если например в тч всего 7 строк, он должен вывести эти 7 строк плюс еще пустых например до 87...делаю так
//// Область2
    НомерПоПорядку = 0;
	Для каждого стр Из ТЧПланЗадание Цикл
		Область2 = Макет.ПолучитьОбласть("Область2");
		НомерПоПорядку = НомерПоПорядку + 1;
		Если НомерПоПорядку <= 87  Тогда
			Область2.Параметры.Номер =  НомерПоПорядку;
			ТекСтрока = ЭлементыФормы.ПланЗадание.ТекущаяСтрока;
			
			Если ТипЗнч(стр.ТипСИ) = Тип("СправочникСсылка.ЛРТИ") Тогда
				Область2.Параметры.Тип = Справочники.ЛРТИ.НайтиПоНаименованию(стр.ТипСИ).ТипСИ.Ссылка;
			ИначеЕсли ТипЗнч(стр.ТипСИ) = тип ("Строка") тогда
				Область2.Параметры.Тип = Стр.ТипСИ;
				
			КонецЕсли;
			//Область2.Параметры.Тип = Справочники.ЛРТИ.НайтиПоНаименованию(стр.ТипСИ).ТипСИ.Ссылка;
			Область2.Параметры.ЗН = стр.ЗаводскойНомер;
			Область2.Параметры.Цех = стр.Цех;
			Область2.Параметры.НЧ = стр.НЧ;
			Область2.Параметры.ДатаПоГрафику = Формат(стр.ДатаПоверкиПоГрафику,"ДФ=dd.MM.yyyy");
			Область2.Параметры.ДатаПоверки = формат(стр.ДатаПоверки,"ДФ=dd.MM.yyyy");
			Область2.Параметры.Заключение = стр.Заключение;
			ТабДок.Вывести(Область2);
		КонецЕсли;
	КонецЦикла;
	
	Если НомерПоПорядку < 87 Тогда 
		Пока НомерПоПорядку < 87 Цикл 
			Строка = Макет.ПолучитьОбласть("Область2");
			НомерПоПорядку = НомерПоПорядку + 1;
			Область2.Параметры.Номер             = НомерПоПорядку; 
			ТабДок.Вывести(Область2);
		КонецЦикла;
		 
	КонецЕсли;
Показать


а он выводит =>
Прикрепленные файлы:
Ответы
Избранное Подписка Сортировка: Древо
2. herfis 270 05.12.18 14:13 Сейчас в теме
    Если НомерПоПорядку < 87 Тогда 
        Пока НомерПоПорядку < 87 Цикл 
            Строка = Макет.ПолучитьОбласть("Область2");
            НомерПоПорядку = НомерПоПорядку + 1;
            Строка.Параметры.Номер             = НомерПоПорядку; 
            ТабДок.Вывести(Строка);
        КонецЦикла;        
    КонецЕсли;
Показать
3. user916115 05.12.18 14:15 Сейчас в теме
(2) у меня же тоже самое? или я в упор не вижу ошибку О_о
7. plevakin 05.12.18 14:19 Сейчас в теме
(3) Так Вы пишите
Строка = Макет.ПолучитьОбласть("Область2");


А выводите

ТабДок.Вывести(Область2);
4. herfis 270 05.12.18 14:15 Сейчас в теме
Ну или просто поменять переменную "Строка" на "Область2".
Суть в том, что ты сейчас ты получаешь новую область, а выводишь старую.
6. user916115 05.12.18 14:18 Сейчас в теме
(4)нууу ёёёмаё.... :( почему же я такая невнимательная :(
спасибо тебе большое, хороший человек! :)
5. herfis 270 05.12.18 14:16 Сейчас в теме
Если НомерПоПорядку < 87 Тогда
Пока НомерПоПорядку < 87 Цикл
Строка = Макет.ПолучитьОбласть("Область2");
НомерПоПорядку = НомерПоПорядку + 1;
Область2.Параметры.Номер = НомерПоПорядку;
ТабДок.Вывести(Область2);
КонецЦикла;

КонецЕсли;

Выделил ошибку
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Старший Программист 1С НОВОСИБИРСК
Новосибирск
зарплата до 130 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 75 000 руб.
Полный день



Руководитель проектов 1С
Санкт-Петербург
По совместительству