1. GreyWanderer 04.12.18 16:44 Сейчас в теме

1с 8.3 Как в табличной части сложить все пункты и вывести их в итоге

Есть табличная часть документа, "СтатьиЗатрат" как сложить все реквизиты в ней и вывести их в последнем реквизите этой табличной части
Прикрепленные файлы:
Найденные решения
3. insurgut 195 04.12.18 16:56 Сейчас в теме
Что значит как? К примеру при изменении ячейки:

ТекСтрока = ЭлементыФормы.СтатьиЗатрат.ТекущиеДанные;
Если ТекСтрока  <> Неопределено Тогда
ТекСтрока .ФактическаяСебестоимость = ТекСтрока.СырьеИМатериалы + ... + ТекСтрока.ОбщехозяйственныеРасходы;
КонецЕсли;


Тут скорее вопрос - в какой момент вы это хотите получить.
10. antz 04.12.18 17:29 Сейчас в теме
(9) Управляемые формы? Там свойство ЭлементыФормы называется Элементы.
Остальные ответы
Избранное Подписка Сортировка: Древо
2. user614822 25 04.12.18 16:55 Сейчас в теме
Что конкретно вы собираетесь складывать?
Если сложить Ежа с Носорогом что получится? Или километры с гвоздями сложить....
Ответите на этот вопрос - станет ясна абсурдность вашей темы...
4. GreyWanderer 04.12.18 16:57 Сейчас в теме
(2)Формат всех реквизитов числовой, ибо мы складываем затраты, т.е деньги которые мы потратили на изготовление продукции
5. insurgut 195 04.12.18 16:57 Сейчас в теме
(2) судя по всему все реквизиты ТЧ имеют тип Число
6. GreyWanderer 04.12.18 16:57 Сейчас в теме
7. GreyWanderer 04.12.18 17:02 Сейчас в теме
(5)Документ.ФактическаяСебестоимость.Форма.ФормаДокумента.Форма(4,8)}: Переменная не определена (ТекущиеДанныеСтатейЗатрат)
<<?>>ТекущиеДанныеСтатейЗатрат.ФактическаяСебестоимость = ТекущиеДанныеСтатейЗатрат.СырьеИМатериалы + ТекущиеДанныеСтатейЗатрат.Комплектующие +ТекущиеДанныеСтатейЗатрат.ВозвратныеОтходы+ТекущиеДанныеСтатейЗатрат.ТопливоИЭнергия + ТекущиеДанныеСтатейЗатрат.ЗароботнаяПлата+ТекущиеДанныеСтатейЗатрат.НачисленияНаЗп+ТекущиеДанныеСтатейЗатрат.СодержаниеОборудования + ТекущиеДанныеСтатейЗатрат.ОбщехозяйскиеРасходы+ТекущиеДанныеСтатейЗатрат.Общепроизводственныерасходы; (Проверка: Тонкий клиент)
{Документ.ФактическаяСебестоимость.Форма.ФормаДокумента.Форма(4,61)}: Переменная не определена (ТекущиеДанныеСтатейЗатрат)
ТекущиеДанныеСтатейЗатрат.ФактическаяСебестоимость = <<?>>ТекущиеДанныеСтатейЗатрат.СырьеИМатериалы + ТекущиеДанныеСтатейЗатрат.Комплектующие +ТекущиеДанныеСтатейЗатрат.ВозвратныеОтходы+ТекущиеДанныеСтатейЗатрат.ТопливоИЭнергия + ТекущиеДанныеСтатейЗатрат.ЗароботнаяПлата+ТекущиеДанныеСтатейЗатрат.НачисленияНаЗп+ТекущиеДанныеСтатейЗатрат.СодержаниеОборудования + ТекущиеДанныеСтатейЗатрат.ОбщехозяйскиеРасходы+ТекущиеДанныеСтатейЗатрат.Общепроизводственныерасходы; (Проверка: Тонкий клиент)
{Документ.ФактическаяСебестоимость.Форма.ФормаДокумента.Форма(4,105)}: Переменная не определена (ТекущиеДанныеСтатейЗатрат)
И т.д.
3. insurgut 195 04.12.18 16:56 Сейчас в теме
Что значит как? К примеру при изменении ячейки:

ТекСтрока = ЭлементыФормы.СтатьиЗатрат.ТекущиеДанные;
Если ТекСтрока  <> Неопределено Тогда
ТекСтрока .ФактическаяСебестоимость = ТекСтрока.СырьеИМатериалы + ... + ТекСтрока.ОбщехозяйственныеРасходы;
КонецЕсли;


Тут скорее вопрос - в какой момент вы это хотите получить.
8. GreyWanderer 04.12.18 17:06 Сейчас в теме
(3)Я хочу это получить при изменении табличной части "СтатьиЗатрат"

&НаКлиенте
Процедура СтатьиЗатратПриИзменении(Элемент)
ТекущиеДанныеСтатьиЗатрат.ФактическаяСебестоимость = ТекущиеДанныеСтатьиЗатрат.СырьеИМатериалы + ТекущиеДанныеСтатьиЗатрат.Комплектующие +ТекущиеДанныеСтатьиЗатрат.ВозвратныеОтходы+ТекущиеДанныеСтатьиЗатрат.ТопливоИЭнергия + ТекущиеДанныеСтатьиЗатрат.ЗароботнаяПлата+ТекущиеДанныеСтатьиЗатрат.НачисленияНаЗп+ТекущиеДанныеСтатьиЗатрат.СодержаниеОборудования + ТекущиеДанныеСтатьиЗатрат.ОбщехозяйскиеРасходы+ТекущиеДанныеСтатьиЗатрат.Общепроизводственныерасходы;
КонецПроцедуры
9. GreyWanderer 04.12.18 17:14 Сейчас в теме
(3){Документ.ФактическаяСебестоимость.Форма.ФормаДокумента.Форма(5,14)}: Переменная не определена (ЭлементыФормы)
ТекСтрока = <<?>>ЭлементыФормы.СтатьиЗатрат.ТекущиеДанные; (Проверка: Тонкий клиент)
10. antz 04.12.18 17:29 Сейчас в теме
(9) Управляемые формы? Там свойство ЭлементыФормы называется Элементы.
11. GreyWanderer 04.12.18 17:32 Сейчас в теме
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Волгоград
зарплата от 45 000 руб. до 90 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Консультант-аналитик 1С
Москва
зарплата от 70 000 руб. до 100 000 руб.
Полный день

Программист 1С
Москва
зарплата от 80 000 руб. до 120 000 руб.
Временный (на проект)

Ведущий программист 1С
Сочи
зарплата от 80 000 руб. до 100 000 руб.
Полный день