0. aco.art 3 31.10.18 12:02 Сейчас в теме

Загрузка и обработка номенклатуры из EXСEL (доп.реквизиты, номенклатура поставщика, заказ поставщику, регистрация цен)

Обработка для УТ 11.4.5, позволяющая загружать данные из EXСEL и CSV, позволяет создавать и выбирать Доп.Реквизиты номенклатуры, осуществляя поиск и сопоставление номенклатуры по Коду, Доп реквизиту (Артикул сравнения номенклатуры), Артикулу номенклатуры поставщика и наименованию номенклатуры поставщика. А также создавать на основе полученных данных Заказ поставщику и регистрировать цены поставщика.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. Konovalovss 01.12.18 10:54 Сейчас в теме
Обработка не работает. Дополнительные реквизиты не меняет
2. aco.art 3 01.12.18 14:26 Сейчас в теме
(1)
Здравствуйте, покажите свои настройки и файл который загружаете, если это возможно, разберемся. Важно чтобы корректно была выбрана строка и колонка по которой идет сопоставление номенклатуры.
3. 1977 2 22.12.18 20:01 Сейчас в теме
4. aco.art 3 23.12.18 09:11 Сейчас в теме
5. gvozditut 21.01.19 12:00 Сейчас в теме
не меняет реквизиты что не так делаю,файл ексель и настройки прикрепил
Прикрепленные файлы:
шурупы.xlsx
6. aco.art 3 21.01.19 16:19 Сейчас в теме
Вы проводите сопоставление номенклатуры по артикулу поставщика, в файле у вас только наименование.
Номенклатуру поставщика создавали? К созданной номенклатуре поставщика привяжется наша номенклатура.
Если не нужно создавать номенклатуру поставщика то можно привязывать соответствие по "Коду номенклатуры", для этого в фале должен быть "Код номенклатуры" из 1с и указана соответствующая колонка.

В файле 2 доп реквизита(Свойство), у вас же указан один "Длина резьбы (мм)". Добавьте второй реквизит и удалите ненужный в настройке.

В файле первая строка - описание, вторая с данными. В настройке файл данных укажите Строки Первая=2 Последняя=2.
7. 1977 2 12.04.19 16:50 Сейчас в теме
Прошу описать функцию 8. Регистрация цен поставщика с указанием до 2 типов цены поставщика.
9. aco.art 3 13.04.19 23:24 Сейчас в теме
(7)
Указали 2 вида цены постащика и номера колонок из загружаемой таблички, загрузили (создали или сопоставили по колонке из загружаемой таблички) номенклатуру поставщика, нажали записать цены и создался документ РегистрацияЦенНоменклатурыПоставщика
10. 1977 2 14.04.19 09:13 Сейчас в теме
(9) Скрин шот можно добавить таблицы?
11. aco.art 3 15.04.19 09:16 Сейчас в теме
(10)



Вот пример таблицы и настройки программы. Поиск в нашей номенклатуре по полному совпадению с наименованием поставщика, создание нашей номенклатуры и номенклатуры поставщика если не найдена. Созданную нашу поместить в каталог Несортированная, созданная поставщика в каталог с названием Вида номенклатуры (справочник номенлкатура поставщика).
Вид цены поставщика 1 отмечен стрелочкой. Везде прописаны номера колонок из файла.
Если нужен второй вид цены то выбрать вкладку 2 рядом со стелочкой и указать Вид цены поставщика и номер колонке из файла (в текущем примере это будет колонка 15, т.к. 16 уже использовали для вида цены поставщика "Закуп")
12. aco.art 3 15.04.19 11:14 Сейчас в теме
(11) Фото плохо приложилось, добавил фото с таблицами в фото публикации, полистайте их
8. aco.art 3 13.04.19 23:19 Сейчас в теме
(7)
 &НаСервере
Функция ЗаписатьДокументРегистрацияЦенПоставщикаНаСервере(ТаблицаЦенПоставщика)//ДокРегистрацияЦен)
	ДокРегистрацияЦен=Документы.РегистрацияЦенНоменклатурыПоставщика.СоздатьДокумент();
	ДокРегистрацияЦен.Дата=ТекущаяДата();
	ДокРегистрацияЦен.Партнер=Объект.Конкурент;
	ДокРегистрацияЦен.Комментарий="Документ созданный авоматической загрузкой.";
	ДокРегистрацияЦен.Ответственный=Пользователи.ТекущийПользователь();
	Для Каждого Стр Из ТаблицаЦенПоставщика Цикл
		
		НоваяСтрока=ДокРегистрацияЦен.Товары.Добавить();
		
		НоваяСтрока.ВидЦеныПоставщика=Стр.ВидЦены;	
		НоваяСтрока.Упаковка=Объект.Упаковка;
		НоваяСтрока.НоменклатураПоставщика=Стр.НайденнаяНоменклатурыПоставщика;
		Если НЕ Стр.НайденнаяНоменклатурыПоставщика.Номенклатура.Пустая() тогда
			НоваяСтрока.Номенклатура=Стр.НайденнаяНоменклатурыПоставщика.Номенклатура
		КонецЕсли;		
		
		НоваяСтрока.Цена=Стр.Цена;
	КонецЦикла;
	ДокРегистрацияЦен.Записать(РежимЗаписиДокумента.Проведение);
	
	Возврат ДокРегистрацияЦен.Ссылка;
КонецФункции
Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 135 000 руб. до 135 000 руб.
Полный день

Программист 1С
Норильск
зарплата от 50 000 руб. до 80 000 руб.
Полный день

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Ведущий программист 1С
Москва
зарплата от 120 000 руб. до 150 000 руб.
Полный день