1. user853074 11.10.18 16:33 Сейчас в теме

Запрос к 7.7 по счёту

Здравствуйте, такой вопрос через ком, подключился к 7 базе. Хочу сделать выгрузку даных по "411" счету, пишу такой код, ругаеться:

БухИтоги77 = v7.CreateObject("БухгалтерскиеИтоги");
ПланСчетов77 = v7.ПланыСчетов.Основной;
Счет77 = v7.СчетПоКоду("411", ПланСчетов77);
КолВоСубконто77 = Счет77.КоличествоСубконто();
Для кс=1 по Счет77.КоличествоСубконто() Цикл
БухИтоги77.ИспользоватьСубконто(Счет77.ВидСубконто(кс),"", 1);
КонецЦикла;
БухИтоги77.ВыполнитьЗапрос(НачПериода, КонПериода, Счет77,Неопределено,Неопределено,1,Неопределено, Неопределено);//
БухИтоги77.ВыбратьСчета();

Ругается на запрос, при том для все счетов"13+", всё работает нормально. В чём может быть проблема. Нужно получить данные именно по счёту "411"
Ответы
Избранное Подписка Сортировка: Древо
7. acanta 44 11.10.18 17:42 Сейчас в теме
В бух.итогах нет понятия выгрузить. Перебором.
БухИтоги77.ВыбратьСубконто(1);
Пока БухИтоги77.ПолучитьСубконто(1) = 1 Цикл
   БухИтоги77.ВыбратьСубконто(2);
   Пока БухИтоги77.ПолучитьСубконто(2) = 1 Цикл
      БухИтоги77.ВыбратьСубконто(3);
      Пока БухИтоги77.ПолучитьСубконто(3) = 1 Цикл
          БухИтоги77.ВыбратьСчета(1);
         Пока БухИтоги77.ПолучитьСчет(1) = 1 Цикл
               ТЗ.НоваяСтрока();
               ТЗ.Кво = БухИтоги77.СНД(3)-БухИтоги77.СНК(3);
               ТЗ.Сумма = БухИтоги77.СНД(1)-БухИтоги77.СНК(1);
               ТЗ.Субконто1 = БухИтоги77.Субконто(1);
               ТЗ.Субконто2 = БухИтоги77.Субконто(2);
               ТЗ.Субконто3 = БухИтоги77.Субконто(3);
          КонецЦикла;
     КонецЦикла;
   КонецЦикла;
КонецЦикла;
Показать
2. IvanovAV 64 11.10.18 16:49 Сейчас в теме
Счет заведен через конфигуратор или через 1С Предприятие? У него есть красная галочка на фоне буквы Т, в плане счетов?
3. IvanovAV 64 11.10.18 16:51 Сейчас в теме
БухИтоги77.ВыполнитьЗапрос(НачПериода, КонПериода, Счет77); Вот так попробуйте, в 7.7 нет понятия Неопределено
5. user853074 11.10.18 16:55 Сейчас в теме
(3)
Убрал Неопределенно, помогло, спасибо вам. Сейчас буду смотреть дальше)
6. user853074 11.10.18 16:59 Сейчас в теме
(3)

А как выгрузить всю информацию из запроса?

Пока БухИтоги77.ПолучитьСчет() = 1
Вот, как мне выгрузить всю информацию по счёту?
4. user853074 11.10.18 16:52 Сейчас в теме
Да есть красная галочка.
Может проблема в том что когда я выгружаю счет, и смотрю количество субконто, их =0?
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Нижний Новгород
зарплата от 120 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 80 000 руб. до 100 000 руб.
Полный день

Системный аналитик
Новосибирск
зарплата от 80 000 руб. до 100 000 руб.
Полный день

Программист 1С
Салехард
зарплата от 80 000 руб. до 200 000 руб.
Полный день