1. Vitaly1C8 11.10.18 14:16 Сейчас в теме

В строке Несколько пробелов заменить на один

Добрый день !
Где-то видел в примере что есть встроенная функция 1С позволяющая заменить несколько пробелов в строке на один.
Подскажите как эта функция называется ?!
Найденные решения
3. NatalkaBal 24 11.10.18 14:57 Сейчас в теме
Функция УдалитьЛишниеПробелы(ИсходнаяСтрока)
	
	Пока СтрНайти(ИсходнаяСтрока, "  ") > 0 Цикл
		ИсходнаяСтрока = СтрЗаменить(ИсходнаяСтрока, "  ", " ");
	КонецЦикла;
	
	Возврат ИсходнаяСтрока;
	
КонецФункции
Показать
Vitaly1C8; +1 Ответить
Остальные ответы
Избранное Подписка Сортировка: Древо
2. vadim1011985 58 11.10.18 14:23 Сейчас в теме
4. spacecraft 11.10.18 15:21 Сейчас в теме
(1)
Результат = СтрСоединить(СтрРазделить(ИсходнаяСтрока, " ", Ложь), " ");
Vitaly1C8; +1 Ответить
3. NatalkaBal 24 11.10.18 14:57 Сейчас в теме
Функция УдалитьЛишниеПробелы(ИсходнаяСтрока)
	
	Пока СтрНайти(ИсходнаяСтрока, "  ") > 0 Цикл
		ИсходнаяСтрока = СтрЗаменить(ИсходнаяСтрока, "  ", " ");
	КонецЦикла;
	
	Возврат ИсходнаяСтрока;
	
КонецФункции
Показать
Vitaly1C8; +1 Ответить
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Воронеж
Полный день

Программист 1С
Москва
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист 1С
Москва
зарплата от 160 000 руб. до 180 000 руб.
Полный день

Ведущий программист / Руководитель проектов 1С
Москва
зарплата от 190 000 руб. до 190 000 руб.
Полный день