IE 2018

1. Vitaly1C8 11.10.18 14:16 Сейчас в теме

В строке Несколько пробелов заменить на один

Добрый день !
Где-то видел в примере что есть встроенная функция 1С позволяющая заменить несколько пробелов в строке на один.
Подскажите как эта функция называется ?!
Найденные решения
3. NatalkaBal 15 11.10.18 14:57 Сейчас в теме
Функция УдалитьЛишниеПробелы(ИсходнаяСтрока)
	
	Пока СтрНайти(ИсходнаяСтрока, "  ") > 0 Цикл
		ИсходнаяСтрока = СтрЗаменить(ИсходнаяСтрока, "  ", " ");
	КонецЦикла;
	
	Возврат ИсходнаяСтрока;
	
КонецФункции
Показать
Vitaly1C8; +1 Ответить
Остальные ответы
Избранное Подписка Сортировка: Древо
2. vadim1011985 46 11.10.18 14:23 Сейчас в теме
4. spacecraft 11.10.18 15:21 Сейчас в теме
(1)
Результат = СтрСоединить(СтрРазделить(ИсходнаяСтрока, " ", Ложь), " ");
Vitaly1C8; +1 Ответить
3. NatalkaBal 15 11.10.18 14:57 Сейчас в теме
Функция УдалитьЛишниеПробелы(ИсходнаяСтрока)
	
	Пока СтрНайти(ИсходнаяСтрока, "  ") > 0 Цикл
		ИсходнаяСтрока = СтрЗаменить(ИсходнаяСтрока, "  ", " ");
	КонецЦикла;
	
	Возврат ИсходнаяСтрока;
	
КонецФункции
Показать
Vitaly1C8; +1 Ответить
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Новосибирск
зарплата от 80 000 руб. до 100 000 руб.
Полный день

Системный аналитик
Новосибирск
зарплата от 80 000 руб. до 100 000 руб.
Полный день

Программист 1С
Салехард
зарплата от 80 000 руб. до 200 000 руб.
Полный день

Программист 1С
Казань
Полный день

Программист 1С
Санкт-Петербург
зарплата от 130 000 руб. до 150 000 руб.
Полный день