1. waitklassik 14.09.18 17:53 Сейчас в теме

Ошибка при заполнении реквизита

Народ помогите не могу разобраться. Проблема такова есть документ с табличной частью. Как сделать чтобы выполнялось условие Если реквизит1 <> реквизиту2 тогда реквизит3 = реквизиту2 при попытке выполнить пишет что Поле объекта не обнаружено. ревизит3 находится в табличной части документа.
Ответы
Сортировка: Древо
2. ganjaman 14.09.18 18:57 Сейчас в теме
(1) а реквизит 1 и 2 где находятся ? какая-то совсем абстрактная задача
5. waitklassik 14.09.18 20:01 Сейчас в теме
(2) Реквизит 3 это табличная часть 1 и 2 не табличная=) выведена кнопка в которой прописано условие которое писал выше при нажатии кнопки выходит что поле объекта реквизита 3 не обнаружена все три реквизита (Строка)
6. ganjaman 16.09.18 00:55 Сейчас в теме
(5), ну тогда что то вроде этого, если я правильно понимаю задачу
Если Реквизит1 <> Реквизит2 Тогда
     ТабличнаяЧасть.ЗаполнитьЗначения(Реквизит2, "Реквизит3");
КонецЕсли;
7. asdfgcom 121 16.09.18 18:52 Сейчас в теме
(5) Если "Реквизит3" это колонка "ТЧ1" документа тогда обращаются к ней:

Если реквизит1 <> реквизиту2 тогда 
     Для Каждого Стр Из Объект.Тч1 Цикл
           Стр.Реквизит3 = реквизит2;
     КонецЦикла;
КонецЕсли;


То же самое, но более кратко в (6).
3. asdfgcom 121 14.09.18 19:24 Сейчас в теме
(1) Если это табличная часть документа, тогда по событию, например, изменение реквизита1, выполнит функцию проверки и расчета реквизита3. Аналогично, изменения реквизита2 выполнит такую же функцию.
А если Вы добавили в документ свою колонку Реквизит3 и хотите, чтобы старые документы открывались с уже заполненной колонкой реквизит 3, тогда есть смысл написать обработку по заполнению этой колонки во всех документах...
Маловато информации. Совсем не ясно...
4. Denis_CFO 8 14.09.18 19:38 Сейчас в теме
(1) нету там этого реквизита. Ваш КЭП.
А по-сути вопроса - код покажи хотя бы...
Ах, ну да, сегодня же пятницццо :)
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии


Программист 1С-проектов / Консультант 1С
Ульяновск
зарплата от 60 000 руб. до 120 000 руб.
Полный день

Удаленный консультант-разработчик 1С
Краснодар
зарплата от 60 000 руб. до 60 000 руб.
Полный день