1. ruffer 14.09.18 11:35 Сейчас в теме

ЗУП 2.5 Отпуска Организаций

Необходимо сделать перерасчет количества дней по всем отпускам сотрудников организаций. Запросом я получил необходимые для меня отпуска. У меня есть даты с и по при изменении который происходит расчет количества дней, при перевыборе той же даты. Можно ли как то обратиться к форме где происходит событие РаботникиОрганизацииДатаПоПриИзменении(Элемент)
или как то по другому можно сделать?
ДатаКонца=Дата('2018.08.11 01:00:00');
        ДатаНачала = Дата('2018.08.01 00:00:00');
		//ТЗ = Новый ТаблицаЗначений;
		//ТЗ.Колонки.Добавить("Ссылка");
		//ТЗ.Колонки.Добавить("Дата");
		//ТЗ.Очистить(); // привычка
		//           Для каждого ОбъектМД Из Метаданные.Документы Цикл
		//    Проведение = ОбъектМД.Проведение;
		//    Если Проведение=Метаданные.СвойстваОбъектов.Проведение.Разрешить Тогда
		//        Имя=ОбъектМД.Имя;
		//       //выборка документов
 
                Запрос = Новый Запрос();
	           Запрос.Текст = "ВЫБРАТЬ
	                          |	ОтпускаОрганизаций.Ссылка,
	                          |	ОтпускаОрганизаций.Дата
	                          |ИЗ
	                          |	Документ.ОтпускаОрганизаций КАК ОтпускаОрганизаций
	                          |ГДЕ
	                          |	ОтпускаОрганизаций.Дата МЕЖДУ &Дата1 И &Дата2
	                          |	И ОтпускаОрганизаций.Проведен = ИСТИНА
	                          |	И ОтпускаОрганизаций.ПометкаУдаления = ЛОЖЬ";
	//"ВЫБРАТЬ
	//            |" + Имя + ".Ссылка,
	//            |" + Имя + ".Дата
	//            |ИЗ                                                                      
	//            |    Документ." + Имя + " КАК " +Имя+
	//            " ГДЕ
	//            |    (" + Имя + ".Дата МЕЖДУ &ДатаНачала И &ДатаКонца) и (" + Имя + ".Проведен=Истина) и (" + Имя + ".ПометкаУдаления=Ложь)";    
	//
	            Запрос.УстановитьПараметр("Дата1", ДатаНачала);
	            Запрос.УстановитьПараметр("Дата2", ДатаКонца);
     
                Выборка=Запрос.Выполнить().Выбрать();
               // Готовим таблицу значений и сортируем дату по возростанию
 
			   Пока Выборка.Следующий() Цикл
				   
				    Объект = выборка.ссылка.ПолучитьОбъект();
				          
			//		Док = Документы.ОтпускаОрганизаций.СоздатьДокумент();
//Док.ПолучитьФорму("ФормаДокумента").Открыть();
//Док.РаботникиОрганизацииКоличествоДнейПриИзменении();
					
					Попытка
                    Объект.Записать(РежимЗаписиДокумента.Запись);
                   Сообщить("Запись "+Выборка.Ссылка);
 
                Исключение
                    Сообщить("Не получилось провести документ "+Выборка.Ссылка+" из-за "+ОписаниеОшибки());
                КонецПопытки;
					//НоваяСтрока = ТЗ.Добавить();
					//НоваяСтрока.Ссылка = Выборка.Ссылка;
					//НоваяСтрока.Дата = Выборка.Дата;
                КонецЦикла; 
			  //ТЗ.Сортировать("Дата Возр");
		//        
		//    КонецЕсли;            
		//КонецЦикла;
 //           Для Каждого элемент из ТЗ Цикл
 ////               Объект = элемент.ссылка.ПолучитьОбъект();
 ////   
 ////               Попытка
 ////                   Объект.Записать(РежимЗаписиДокумента.Запись);
 ////                  Сообщить("Запись "+Выборка.Ссылка);
 ////
 ////               Исключение
 ////                   Сообщить("Не получилось провести документ "+Выборка.Ссылка+" из-за "+ОписаниеОшибки());
 ////               КонецПопытки;
 //           КонецЦикла;

КонецПроцедуры
Показать
Вознаграждение за ответ
Показать полностью
Найденные решения
2. Aitbay 14.09.18 12:58 Сейчас в теме +0.39 $m
РаботникиОрганизацииДатаПоПриИзменении(Элемент) -
внутри этой функции есть же вызов экспортной процедуры из модуля не проще ее вызывать?
Остальные ответы
Избранное Подписка Сортировка: Древо
2. Aitbay 14.09.18 12:58 Сейчас в теме +0.39 $m
РаботникиОрганизацииДатаПоПриИзменении(Элемент) -
внутри этой функции есть же вызов экспортной процедуры из модуля не проще ее вызывать?
3. ruffer 14.09.18 16:39 Сейчас в теме
там есть она, но какие параметры я туда передавать должен?
4. ruffer 15.09.18 11:45 Сейчас в теме
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Нижний Новгород
зарплата до 120 000 руб.
Полный день

Бизнес-аналитик 1С ERP
Пермь
зарплата от 80 000 руб.
Полный день

Программист 1С УТ 11
Омск
зарплата от 60 000 руб.
Полный день

Бизнес-аналитик 1С УТ 11
Омск
зарплата от 60 000 руб.
Полный день

Программист 1С
Воронеж
Полный день