INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Круткина Оксана | Начальник бюро ОИТ | ПАО "Амурский судостроительный завод"

«Автоматизация закупочной и договорной деятельности предприятия в 1С: Бухгалтерия (223-ФЗ, 44-ФЗ)»

1. Закупочная деятельность. 1.1 Формирование годовой потребности центрами затрат. 1.2 Создание Плана закупок предприятия центрами финансовой ответственности (ЦФО) 1.3 Корректировка Плана закупок в течении года. 1.4 Проведение и контроль Закупочной процедуры на основе утвержденного Плана закупок. 1.5 Заключение договора по результату проведения закупочной процедуры. 2. Договорная деятельность 2.1 Электронное согласование и заключение договора. 2.1.1 Различия в процедуре согласования договора для конкурентного, не конкурентного и малого способов закупки. 2.2 Контроль лимитов БДР и БДДС. 2.3 Контроль исполнения договора.

1. user597078_steem34 10.08.18 13:03 Сейчас в теме

Странные картинки в строках дерева значений

Добрый день, есть дерево значений на управляемой форме, инициализируется оно вот так:

Запрос = Новый Запрос();
	Запрос.Текст = "ВЫБРАТЬ
	               |	Номенклатура.Ссылка КАК Товар,
	               |	Номенклатура.ЭтоГруппа КАК ЭтоГруппа
				   |ИЗ
	               |	Справочник.Номенклатура КАК Номенклатура
	               |
	               |УПОРЯДОЧИТЬ ПО
				   |	Товар ИЕРАРХИЯ
				   |АВТОУПОРЯДОЧИВАНИЕ"; 

	Результат = Запрос.Выполнить().Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);
	ЗначениеВРеквизитФормы(Результат,"Номенклатура");
Показать


В палитре свойстве "Отображение" указал "Иерархический список", чтобы дерево было красивее, после этого у меня во всех строках иконка группы (желтая папка), почему так, как сделать чтобы у элементов, которые не являются группами не было этой иконки?
Прикрепленные файлы:
Ответы
Сортировка: Древо
2. timeforlive 10 10.08.18 13:10 Сейчас в теме
Посмотреть другие поля свойств?
3. timeforlive 10 10.08.18 13:11 Сейчас в теме
А эти элементы разве не группы?
5. user597078_steem34 10.08.18 13:13 Сейчас в теме
(3) Нет, это обычные элементы справочника
4. timeforlive 10 10.08.18 13:12 Сейчас в теме
Поставь в значение "Дерево".

6. user597078_steem34 10.08.18 13:14 Сейчас в теме
(4)если поставить "Дерево", то значков совсем не будет, а мне нужно, чтобы только у групп они были...
7. timeforlive 10 10.08.18 13:14 Сейчас в теме
В типовом механизме где-то уже это есть? Посмотри как там это работает.
8. timeforlive 10 10.08.18 13:15 Сейчас в теме
У меня конфа на обычных формах, но я бы сделал именно так - сначала посмотреть как это работает в конфигурации.

Если такого нет, тогда программно, при выводе строки заменять иконку на нужную тебе.
9. user597078_steem34 10.08.18 13:16 Сейчас в теме
(8) я бы с радостью подменил картинку, но не знаю как это делается
10. user597078_steem34 10.08.18 13:16 Сейчас в теме
(8) это ут 11.3, если это важно
11. timeforlive 10 10.08.18 13:18 Сейчас в теме
То есть, для табличной части нужно указать событие "ПриПолученииДанных".

Вот пример, через точку останова посмотришь, какие там поля нужно брать, направление я тебе дал:

Процедура ТвояТабличнаяЧастьПриПолученииДанных(Элемент, ОформленияСтрок)
	
	Для каждого ОформлениеСтроки Из ОформленияСтрок Цикл		
		ДанныеСтроки = ОформлениеСтроки.ДанныеСтроки;		
		Если ДанныеСтроки <> Неопределено Тогда
			
			ОформлениеСтроки.Ячейки.Склад.УстановитьТекст(ДанныеСтроки.Ссылка.ЗаказПокупателя.СкладГруппа);					
			Если Не (ДанныеСтроки.ЭтоГруппа) Тогда
				ОформлениеСтроки.ЦветТекста  = новый Цвет (170, 170, 170);
			КонецЕсли; 			
		КонецЕсли;		
	КонецЦикла; 		
КонецПроцедуры
Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Бизнес-аналитик 1С
Санкт-Петербург
Полный день

Программист 1С
Москва
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Ведущий программист
Москва
зарплата от 130 000 руб. до 200 000 руб.
Полный день

Программист 1С
Одесса (Украина)
зарплата от 40 000 руб.
Полный день

Программист 1С
Санкт-Петербург
Полный день