0. pm74 130 01.06.18 15:24 Сейчас в теме

Рисуем стрелки в табличном документе

Рисуем стрелки средствами 1С .

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
2. WalterMort 305 02.06.18 14:04 Сейчас в теме
Способ рисования стрелки плохой. В том смысле, что кроме стрелки ничего не нарисуешь. Вот если бы была функция преобразований координат, а стрелка рисовалась как набор линий в базовых координатах (словно она исходит из 0,0 и смотрит ровно вверх, например), тогда можно было бы вместо рисования стрелки что угодно отобразить в любом месте, под любым углом и масштабом.
4wheel; Азверин; +2 Ответить
4. pm74 130 02.06.18 22:02 Сейчас в теме
(2)
Способ рисования стрелки плохой.

с удовольствием посмотрю на ваш вариант
зы. я и не утверждаю что мой способ идеальный
Вот если бы была функция преобразований координат

достаточно лишь знать положение начальной точки и угол поворота относительно оси ординат
ну например ломаная линия с углом наклона +-30 относительно оси абцисс
&НаКлиенте
Процедура ЛоманаяЛиния(Команда)
	Амплитуда= 30;
	ТочкаА = Новый Структура("Верх,Лево",30,30);
	Размер = 10;
	Для ё = 1 по 10 Цикл 
		Знак = ?(ё%2=0,-1,1);
		Угол = 90+Знак*Амплитуда;
		Гипотенуза(Размер,Угол,ТочкаА);
	КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура Гипотенуза(Знач Размер,Знач УголГрад,ТочкаА)
	Pi = 3.1415926535897932;
	УлолРад = УголГрад*Pi/180;
	Л=ТочкаА.Лево+sin(УлолРад)*Размер;
	В=ТочкаА.Верх-cos(УлолРад)*Размер;
	ТочкаБ =Новый Структура("Верх,Лево",В,Л);
	ЛинияАБ(ТабДок,ТочкаА,ТочкаБ);
	ТочкаА = ТочкаБ;
КонецПроцедуры
Показать
Прикрепленные файлы:
12. WalterMort 305 24.07.18 15:29 Сейчас в теме
(4)
с удовольствием посмотрю на ваш вариант


Вот и он:

https://infostart.ru/public/872775/
5. &rew 7 04.06.18 06:58 Сейчас в теме
Напомнило язык ЛОГО (он же - "черепашка"). На ЭВМ Электроника в школе "баловались".
SlavaKron; romanco; Sla; +3 Ответить
6. pm74 130 04.06.18 07:39 Сейчас в теме
(5)
черепашка
не видел,
имо смахивает на программирование для ЧПУ (без Z и управляющих кодов)
7. Поручик 4310 04.06.18 08:08 Сейчас в теме
Я тоже ЛОГО не видел. Помню только что-то бэйсик-подобное на русском языке.
9. Yashazz 2520 19.07.18 20:27 Сейчас в теме
А гляньте публикции Ильдаровича. Там было нечто с рисованием в таб.документе, с кривыми любого порядка.
10. pm74 130 19.07.18 20:36 Сейчас в теме
(9) киньте ссылку если можно.
вряд ли там есть стрелки , он такими пустяками не занимается
11. Yashazz 2520 19.07.18 22:03 Сейчас в теме
Там не стрелки. Он графы отрисовывал.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Екатеринбург
зарплата от 120 000 руб. до 120 000 руб.
Полный день

Бизнес-аналитик 1С
Москва
зарплата от 140 000 руб. до 200 000 руб.
Полный день

Руководитель проектов 1С
Санкт-Петербург
Полный день

Бизнес-архитектор 1С, ведущий консультант
Санкт-Петербург
Полный день