Переполнение стека встроенного языка на сервере

1. Sova123 19.05.18 00:20 Сейчас в теме
При проведении документа вышла такая ошибка "Переполнение стека встроенного языка на сервере".
Но в журнале регистрации никакой ошибки не видно. Как отследить где это ошибка. ПРи моделировании ситуации такого не получилось произвести.
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. KAV2 19.05.18 03:52 Сейчас в теме
Как отследить не подскажу, но замечу что одна из причин переполнения стека это рекурсивный вызов функций, то есть когда функция сама себя вызывает, поэтому советую посмотреть нет ли такого кода при проведении, если есть то скорее всего в этом причина.

Должно быть что-то в этом роде:

Процедура ИмяПроцедурыВызываемойРекурсивно()

...

 ИмяПроцедурыВызываемойРекурсивно();

...

КонецПроцедуры
Показать
3. SlavaKron 19.05.18 04:01 Сейчас в теме
Где-то в коде на сервере возникает бесконечная рекурсия.
Как отследить — запустить отладку на сервере и воспроизвести ошибку.
Например, имеем код внешней обработки:
&НаСервереБезКонтекста
Процедура Команда1НаСервере()
	Команда1НаСервере()
КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
	Команда1НаСервере();
КонецПроцедуры
Показать

После запуска команды, получаем такой текст ошибки, с указанием в каком месте происходит переполнение:
Прикрепленные файлы:
4. air_mike 25 16.07.19 20:55 Сейчас в теме
У меня была такая проблема. Как не странно проблема была даже не в коде, а в данных. Справочник ссылался сам на себя. И когда запускалась определенная процедура стала выходить такая ошибка. (На старых платформах просто вылетала программа без объяснений).
sergioevans; +1 Ответить
5. sergioevans 22.09.20 17:08 Сейчас в теме
(4) Спасибо!
Не представляете, как вы мне помогли!
Документооборот. Регистр "СвязиДокументов".
Вместо бесконечного шагания отладчиком (что ни к чему бы и не привело), просто вычислил лишнюю связь документов, из-за чего цикл возникал при запуске процесса (Договор связан с допсоглашением, которое связано тем же типом связи с этим же договором, который связан... и так до бесконечности).
6. air_mike 25 16.11.20 01:35 Сейчас в теме
(5)Не за что. Как не странно бывает кривой код, а бывают кривые данные.. Иногда они встречаются)))
Оставьте свое сообщение
Вопросы с вознаграждением