ЗУП 3.1 - загрузка данных из шапки документа в табличную часть

1. Вячеслав Остробрюхов (slava9119) 16.05.18 19:51 Сейчас в теме
Здравствуйте, помогите пожалуйста решить вопрос, конфигурация ЗУП КОРП 3.1, в документе Назначение планового начисления, нужно дату из реквизита Дата Окончания, при нажатии на кнопку выгрузить в табличную часть. Сделал это как внешнюю обработку через кнопку на форме :

&НаКлиенте
Процедура Заполнить(Команда)
	ЗаполнитьНаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьНаСервере()
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	НазначениеПлановогоНачисления.Ссылка КАК Ссылка,
	|	НазначениеПлановогоНачисления.ДатаОкончания КАК ДатаОкончания
	|ИЗ
	|	Документ.НазначениеПлановогоНачисления КАК НазначениеПлановогоНачисления
	|ГДЕ
	|	НазначениеПлановогоНачисления.Ссылка = &Ссылка";
	Запрос.УстановитьПараметр("ссылка", ВыборДок ) ;
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		
		ДатаОкон =(ВыборкаДетальныеЗаписи.ДатаОкончания) ;
		ОБ = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
		
		Для каждого стр из ОБ.сотрудники цикл
			Стр.ДатаОкончания = ДатаОкон;
			
		КонецЦикла ;
	КонецЦикла;
	
	ОБ.Записать(РежимЗаписиДокумента.Проведение);
	
КонецПроцедуры
Показать


Код работает, но мне нужно сделать как внешнюю обработку через "ЗаполнениеОбъекта", чтобы кнопка появилась на форме в самом документе. Тут возникли сложности, при нажатии на кнопку выдаёт ошибку :

{ВнешняяОбработка.ЗаполнениеТабличнойЧасти.Форма.Форма.Форма(37)}: Значение не является значением объектного типа (Записать)
ОБ.Записать(РежимЗаписиДокумента.Запись);

Спасибо
Ответы
2. Константин Хоров (user705522_constantin_h) 3 16.05.18 22:42 Сейчас в теме
(1) Перенеси
ОБ.Записать(РежимЗаписиДокумента.Проведение);

внутрь цикла.
3. maip1 (maip1) 17.05.18 00:57 Сейчас в теме
(1) "ОБ.Записать(РежимЗаписиДокумента.Проведение);" в цикл
Оставьте свое сообщение