INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Тягунов Иван | Управляющий партнер, основатель | Консалтинговая группа "Wiseadvice"

«UX/UI: почему 1С проигрывает веб-приложениям по интерфейсам, и как это изменить?»

В последние 5-7 лет решения на платформе 1С проигрывают позиции в разных нишах приложениям и сервисам, основанным на веб-технологиях. Основная причина тому - интерфейсы. Почему интерфейсы так важны пользователям и лицам, принимающим решение о выборе приложения? Почему "красиво" часто означает "эффективно"? Как успешно конкурировать с приложениями на веб-технологиях? Границы и технологии веб-разработки как внутри 1С, так и на стыке с 1С. Какие подходы и техники стоит перенять из веб-разработки? (Персонажи, сценарии, прототипы и др.). Когда в 1С нужно прототипирование интерфейсов, и как его осуществлять (инструменты)? Что такое дизайн-система, как ее разработать и поддерживать, к чему стремиться? Подходы и методы улучшения интерфейсов уже эксплуатируемых 1С-систем.

1. slava9119 16.05.18 19:51 Сейчас в теме

ЗУП 3.1 - загрузка данных из шапки документа в табличную часть

Здравствуйте, помогите пожалуйста решить вопрос, конфигурация ЗУП КОРП 3.1, в документе Назначение планового начисления, нужно дату из реквизита Дата Окончания, при нажатии на кнопку выгрузить в табличную часть. Сделал это как внешнюю обработку через кнопку на форме :

&НаКлиенте
Процедура Заполнить(Команда)
	ЗаполнитьНаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьНаСервере()
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	НазначениеПлановогоНачисления.Ссылка КАК Ссылка,
	|	НазначениеПлановогоНачисления.ДатаОкончания КАК ДатаОкончания
	|ИЗ
	|	Документ.НазначениеПлановогоНачисления КАК НазначениеПлановогоНачисления
	|ГДЕ
	|	НазначениеПлановогоНачисления.Ссылка = &Ссылка";
	Запрос.УстановитьПараметр("ссылка", ВыборДок ) ;
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		
		ДатаОкон =(ВыборкаДетальныеЗаписи.ДатаОкончания) ;
		ОБ = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
		
		Для каждого стр из ОБ.сотрудники цикл
			Стр.ДатаОкончания = ДатаОкон;
			
		КонецЦикла ;
	КонецЦикла;
	
	ОБ.Записать(РежимЗаписиДокумента.Проведение);
	
КонецПроцедуры
Показать


Код работает, но мне нужно сделать как внешнюю обработку через "ЗаполнениеОбъекта", чтобы кнопка появилась на форме в самом документе. Тут возникли сложности, при нажатии на кнопку выдаёт ошибку :

{ВнешняяОбработка.ЗаполнениеТабличнойЧасти.Форма.Форма.Форма(37)}: Значение не является значением объектного типа (Записать)
ОБ.Записать(РежимЗаписиДокумента.Запись);

Спасибо
Ответы
Сортировка: Древо
2. user705522_constantin_h 7 16.05.18 22:42 Сейчас в теме
(1) Перенеси
ОБ.Записать(РежимЗаписиДокумента.Проведение);

внутрь цикла.
3. maip1 17.05.18 00:57 Сейчас в теме
(1) "ОБ.Записать(РежимЗаписиДокумента.Проведение);" в цикл
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии


Программист 1С
Москва
зарплата от 100 000 руб. до 200 000 руб.
Полный день

Преподаватель 1С
Санкт-Петербург
Полный день

Удаленный ИТ-журналист
Санкт-Петербург
По совместительству

Удаленный бизнес-аналитик 1С
Санкт-Петербург
Временный (на проект)