ПредопределенноеЗначение на клиенте

1. reznic Резник (reznic) 92 16.04.18 15:59 Сейчас в теме
Столкнулся с проблемой при сравнении реквизиты с другим реквизитом для предопределенного элемента справочника на клиенте.

Собственно методом
ПредопределенноеЗначение("Справочник.НастройкиДоработок.ВидПроектаИсполнительныхПроизводств")

получаю сам предопределенный элемент, а вот получить реквизиты этого элемента ни как не получается
код не работает
ПредопределенноеЗначение("Справочник.НастройкиДоработок.ВидПроектаИсполнительныхПроизводств.ОбъектыНастроекДоработок")



Как решить данную задачу?
Ответы
5. Евгений Кузнецов (kuzev) 40 16.04.18 16:16 Сейчас в теме
(1) &НаСервереБезКонтекста
2. DenisCh Гейтс (DenisCh) 16.04.18 16:01 Сейчас в теме
Уходить на сервер, разумеется
3. reznic Резник (reznic) 92 16.04.18 16:07 Сейчас в теме
4. DenisCh Гейтс (DenisCh) 16.04.18 16:13 Сейчас в теме
(3) Ну почему... Можно вернуться на кошерные ОФ и не заморачиваться...
6. Сергей Шепелев (Skill) 16.04.18 16:25 Сейчас в теме
ПредопределенноеЗначение("Справочник.НастройкиДоработок.ВидПроектаИсполнительныхПроизводств").ОбъектыНастроекДоработок
7. reznic Резник (reznic) 92 16.04.18 16:39 Сейчас в теме
(6) так не работает, пробовал в самом начале
8. reznic Резник (reznic) 92 16.04.18 16:41 Сейчас в теме
тогда вопрос, почему не хочет работать так

вызов

Объект.ВидПроекта = ПолучитьПредопределенныеРеквизитыСправочников(".НастройкиДоработок.ВидПроектаИсполнительныхПроизводств.ОбъектыНастроекДоработок")

функция

&НаСервереБезКонтекста
Функция ПолучитьПредопределенныеРеквизитыСправочников(ДанныеДляВыбора)

Возврат Справочники[ДанныеДляВыбора];

КонецФункции
9. Сергей Шепелев (Skill) 16.04.18 16:46 Сейчас в теме
10. reznic Резник (reznic) 92 16.04.18 16:54 Сейчас в теме
(9) поле объекта необноруженно
11. Sashares 1 16.04.18 16:57 Сейчас в теме
12. reznic Резник (reznic) 92 16.04.18 16:57 Сейчас в теме
13. Sashares 1 16.04.18 16:58 Сейчас в теме
(12) Они хотят это развидеть =)
14. reznic Резник (reznic) 92 16.04.18 16:59 Сейчас в теме
15. reznic Резник (reznic) 92 16.04.18 16:59 Сейчас в теме
16. Sashares 1 16.04.18 17:03 Сейчас в теме
НужнаяСсылка = ПредопределенноеЗначение("Справочник.НастройкиДоработок.ВидПроектаИсполнительныхПроизводств");

Объект.ВидПроекта = ПолучитьРеквизитСправочника(НужнаяСсылка ,"ОбъектыНастроекДоработок");

функция

&НаСервереБезКонтекста
Функция ПолучитьРеквизитСправочника(НужнаяСсылка ,ИмяРеквизита)

Возврат ОбщегоНазначения.ЗначениеРеквизитаОбъекта(НужнаяСсылка ,ИмяРеквизита);

КонецФункции
17. Sergey Andreev (starik-2005) 1335 16.04.18 17:03 Сейчас в теме
ООП подразумевает, что есть объект. К полю объекта можно обратиться и через Объект.Поле, и через Объект["Поле"].

Обращаясь к Справочники[ИмяСправочника] - получаете менеджер объектов, а не сам объект.

Объект = ПолучитьПредопределенноеЗначение("Справчоник.Качество.Новый");
Свойство = Объект.Свойство;
Свойство = Объект["Свойство"]; // аналогично
user774630; +1 Ответить
18. Юрий Иночкин (user816930) 16.04.18 17:11 Сейчас в теме
Может такой вариант:

Объект = ПолучитьВидПроекта();


&НаСервере
Функция ПолучитьВидПроекта()
Возврат Справочники.НастройкиДоработок.ВидПроектаИсполнительныхПроизводств.Значение;
КонецФункции
Оставьте свое сообщение