INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Артёменко Максим | Директор, ведущий разработчик, архитектор 1С | ООО "Арт Порт"

«Практика создания модульных отраслевых конфигураций на БСП с общими библиотеками методов и метаданных на примере программного комплекса "Арт:Порт"»

Будет рассмотрена история и методы создания системы отраслевых конфигураций, одной из особенностей которых является изначальная нацеленность на возможное слияние и комплектование модулей для поставки Заказчику. Рассмотрим, в каких случаях модули системы являются частью типовых конфигураций, а в каких пишутся "с нуля" на БСП; как используется технология иерархии библиотек, описанная в БСП; с какими трудностями пришлось столкнуться, чтобы добиться обобщения правил разработки каждой команды для совместимости всех модулей комплекса.

1. reznic 93 16.04.18 15:59 Сейчас в теме

ПредопределенноеЗначение на клиенте

Столкнулся с проблемой при сравнении реквизиты с другим реквизитом для предопределенного элемента справочника на клиенте.

Собственно методом
ПредопределенноеЗначение("Справочник.НастройкиДоработок.ВидПроектаИсполнительныхПроизводств")

получаю сам предопределенный элемент, а вот получить реквизиты этого элемента ни как не получается
код не работает
ПредопределенноеЗначение("Справочник.НастройкиДоработок.ВидПроектаИсполнительныхПроизводств.ОбъектыНастроекДоработок")



Как решить данную задачу?
Ответы
Сортировка: Древо
5. kuzev 40 16.04.18 16:16 Сейчас в теме
(1) &НаСервереБезКонтекста
2. DenisCh 16.04.18 16:01 Сейчас в теме
Уходить на сервер, разумеется
3. reznic 93 16.04.18 16:07 Сейчас в теме
4. DenisCh 16.04.18 16:13 Сейчас в теме
(3) Ну почему... Можно вернуться на кошерные ОФ и не заморачиваться...
6. Skill 16.04.18 16:25 Сейчас в теме
ПредопределенноеЗначение("Справочник.НастройкиДоработок.ВидПроектаИсполнительныхПроизводств").ОбъектыНастроекДоработок
7. reznic 93 16.04.18 16:39 Сейчас в теме
(6) так не работает, пробовал в самом начале
8. reznic 93 16.04.18 16:41 Сейчас в теме
тогда вопрос, почему не хочет работать так

вызов

Объект.ВидПроекта = ПолучитьПредопределенныеРеквизитыСправочников(".НастройкиДоработок.ВидПроектаИсполнительныхПроизводств.ОбъектыНастроекДоработок")

функция

&НаСервереБезКонтекста
Функция ПолучитьПредопределенныеРеквизитыСправочников(ДанныеДляВыбора)

Возврат Справочники[ДанныеДляВыбора];

КонецФункции
9. Skill 16.04.18 16:46 Сейчас в теме
10. reznic 93 16.04.18 16:54 Сейчас в теме
(9) поле объекта необноруженно
11. Sashares 1 16.04.18 16:57 Сейчас в теме
12. reznic 93 16.04.18 16:57 Сейчас в теме
13. Sashares 1 16.04.18 16:58 Сейчас в теме
(12) Они хотят это развидеть =)
14. reznic 93 16.04.18 16:59 Сейчас в теме
15. reznic 93 16.04.18 16:59 Сейчас в теме
16. Sashares 1 16.04.18 17:03 Сейчас в теме
НужнаяСсылка = ПредопределенноеЗначение("Справочник.НастройкиДоработок.ВидПроектаИсполнительныхПроизводств");

Объект.ВидПроекта = ПолучитьРеквизитСправочника(НужнаяСсылка ,"ОбъектыНастроекДоработок");

функция

&НаСервереБезКонтекста
Функция ПолучитьРеквизитСправочника(НужнаяСсылка ,ИмяРеквизита)

Возврат ОбщегоНазначения.ЗначениеРеквизитаОбъекта(НужнаяСсылка ,ИмяРеквизита);

КонецФункции
17. starik-2005 1406 16.04.18 17:03 Сейчас в теме
ООП подразумевает, что есть объект. К полю объекта можно обратиться и через Объект.Поле, и через Объект["Поле"].

Обращаясь к Справочники[ИмяСправочника] - получаете менеджер объектов, а не сам объект.

Объект = ПолучитьПредопределенноеЗначение("Справчоник.Качество.Новый");
Свойство = Объект.Свойство;
Свойство = Объект["Свойство"]; // аналогично
user774630; +1 Ответить
18. user816930 16.04.18 17:11 Сейчас в теме
Может такой вариант:

Объект = ПолучитьВидПроекта();


&НаСервере
Функция ПолучитьВидПроекта()
Возврат Справочники.НастройкиДоработок.ВидПроектаИсполнительныхПроизводств.Значение;
КонецФункции
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Одесса (Украина)
зарплата от 40 000 руб.
Полный день

Программист 1С
Санкт-Петербург
Полный день

Аналитик 1С
Москва
зарплата от 80 000 руб. до 120 000 руб.
Полный день

1С Developer
Одесса (Украина)
зарплата от 60 000 руб. до 120 000 руб.
Полный день

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 70 000 руб. до 90 000 руб.
Полный день