Базелюк Петр | Технический директор | КТС

«Бизнес-аналитика с помощью Power BI»

- Почему Power BI? - Выгрузка данных из 1С:Предприятие это плохо? - События это наше все - О нормализации замолвим слово - Что такое хранилище данных. Смещение сложности в сторону бизнес-аналитики или в сторону 1С:Предприятия - Поговорим об первичных и вторичных ключах. Эффективно связываем одну таблицу хранилища данных со множеством объектов конфигурации 1С - Как максимально точно обновлять данные в хранилище. Забываем об операциях Insert, Delete, Update - учимся делать MERGE. - Оптимизация MERGE с помощью Common Table Expression - Все-таки, полный онлайн возможен?

ПредопределенноеЗначение на клиенте

1. reznic 93 16.04.18 15:59 Сейчас в теме
Столкнулся с проблемой при сравнении реквизиты с другим реквизитом для предопределенного элемента справочника на клиенте.

Собственно методом
ПредопределенноеЗначение("Справочник.НастройкиДоработок.ВидПроектаИсполнительныхПроизводств")

получаю сам предопределенный элемент, а вот получить реквизиты этого элемента ни как не получается
код не работает
ПредопределенноеЗначение("Справочник.НастройкиДоработок.ВидПроектаИсполнительныхПроизводств.ОбъектыНастроекДоработок")



Как решить данную задачу?
Ответы
Сортировка: Древо
5. kuzev 40 16.04.18 16:16 Сейчас в теме
(1) &НаСервереБезКонтекста
2. DenisCh 16.04.18 16:01 Сейчас в теме
Уходить на сервер, разумеется
3. reznic 93 16.04.18 16:07 Сейчас в теме
4. DenisCh 16.04.18 16:13 Сейчас в теме
(3) Ну почему... Можно вернуться на кошерные ОФ и не заморачиваться...
6. Skill 16.04.18 16:25 Сейчас в теме
ПредопределенноеЗначение("Справочник.НастройкиДоработок.ВидПроектаИсполнительныхПроизводств").ОбъектыНастроекДоработок
7. reznic 93 16.04.18 16:39 Сейчас в теме
(6) так не работает, пробовал в самом начале
8. reznic 93 16.04.18 16:41 Сейчас в теме
тогда вопрос, почему не хочет работать так

вызов

Объект.ВидПроекта = ПолучитьПредопределенныеРеквизитыСправочников(".НастройкиДоработок.ВидПроектаИсполнительныхПроизводств.ОбъектыНастроекДоработок")

функция

&НаСервереБезКонтекста
Функция ПолучитьПредопределенныеРеквизитыСправочников(ДанныеДляВыбора)

Возврат Справочники[ДанныеДляВыбора];

КонецФункции
9. Skill 16.04.18 16:46 Сейчас в теме
10. reznic 93 16.04.18 16:54 Сейчас в теме
(9) поле объекта необноруженно
11. Sashares 1 16.04.18 16:57 Сейчас в теме
12. reznic 93 16.04.18 16:57 Сейчас в теме
13. Sashares 1 16.04.18 16:58 Сейчас в теме
(12) Они хотят это развидеть =)
14. reznic 93 16.04.18 16:59 Сейчас в теме
15. reznic 93 16.04.18 16:59 Сейчас в теме
16. Sashares 1 16.04.18 17:03 Сейчас в теме
НужнаяСсылка = ПредопределенноеЗначение("Справочник.НастройкиДоработок.ВидПроектаИсполнительныхПроизводств");

Объект.ВидПроекта = ПолучитьРеквизитСправочника(НужнаяСсылка ,"ОбъектыНастроекДоработок");

функция

&НаСервереБезКонтекста
Функция ПолучитьРеквизитСправочника(НужнаяСсылка ,ИмяРеквизита)

Возврат ОбщегоНазначения.ЗначениеРеквизитаОбъекта(НужнаяСсылка ,ИмяРеквизита);

КонецФункции
17. starik-2005 1383 16.04.18 17:03 Сейчас в теме
ООП подразумевает, что есть объект. К полю объекта можно обратиться и через Объект.Поле, и через Объект["Поле"].

Обращаясь к Справочники[ИмяСправочника] - получаете менеджер объектов, а не сам объект.

Объект = ПолучитьПредопределенноеЗначение("Справчоник.Качество.Новый");
Свойство = Объект.Свойство;
Свойство = Объект["Свойство"]; // аналогично
user774630; +1 Ответить
18. user816930 16.04.18 17:11 Сейчас в теме
Может такой вариант:

Объект = ПолучитьВидПроекта();


&НаСервере
Функция ПолучитьВидПроекта()
Возврат Справочники.НастройкиДоработок.ВидПроектаИсполнительныхПроизводств.Значение;
КонецФункции
Оставьте свое сообщение
Все разделы

Вакансии

Консультант по внедрению 1С
Новосибирск
Полный день

Консультант-аналитик 1С
Санкт-Петербург
зарплата от 50 000 руб. до 65 000 руб.
Полный день

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 70 000 руб. до 90 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 70 000 руб. до 110 000 руб.
Полный день

Программист 1С
Новокузнецк
зарплата от 55 000 руб.
Полный день