0. blackhole321 1036 26.03.18 12:47 Сейчас в теме

Фоновые задания в http-сервисах OneScript

В статье описана библиотека, реализующая механизм фоновых заданий в http-сервисах OneScript, а также некоторые обновления платформы 1.0.19

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. starik-2005 1938 29.03.18 12:39 Сейчас в теме
А sleep в oneScript'е есть? А то без него управление многопоточными вычислениями мягко говоря ущербно...
2. blackhole321 1036 29.03.18 12:43 Сейчас в теме
(1)sleep есть, называется Приостановить. Честно говоря и без sleep ничего ущербного не вижу. Если не секрет -зачем создавать поток и стоить его?
3. blackhole321 1036 29.03.18 12:44 Сейчас в теме
4. starik-2005 1938 29.03.18 12:50 Сейчас в теме
(3) стопить не поток, а управляющую процедуру, чтобы не проверять мульон раз в секунду, завершился у меня расчет в потоке или нет. Т.е. так как-то:
  Пока ЕстьПотоки() Цикл
  Если ЕстьЗавершенныйПоток() Тогда
    Данные = ПолучитьСледующуюПорциюДанных();
    Если Данные = Неопределено Тогда
      Прервать;
    КонецЕсли;
    ДобавитьВСписокФЗ(
      ФоновыеЗадания.Выполнить("МодульФЗ.ОбработкаДанных", ПолучитьЗначениеВМссиве(Данные), ...)
      );
   КонецЕсли;
   Подождать 10мс;
  КонецЦикла;
  ДождатьсяЗавершенияВЗ();
Показать
sasha777666; +1 2 Ответить
5. blackhole321 1036 29.03.18 13:04 Сейчас в теме
(4) Понятно. Можно в самом потоке, при завершении инициировать новый поток, если остались данные для обработки.
6. starik-2005 1938 29.03.18 13:09 Сейчас в теме
(5)
если остались данные для обработки.
Тогда это не параллельность, а последовательное выполнение. Смысл теряется...
7. blackhole321 1036 29.03.18 13:14 Сейчас в теме
(6) Ну почему же, Вы можете сделать столько потоков, сколько элементов данных, подлежащих обработке (по крайней мере несколько, если у Вас некий пул), также, как Вы делаете в цикле, только в самих потоках.
8. starik-2005 1938 29.03.18 13:19 Сейчас в теме
(7) а микросекундный sleep есть?
9. blackhole321 1036 29.03.18 13:32 Сейчас в теме
(8)Думаю - нет, ведь и Linux и Windows не ОС реального времени, в Windows квант времени ~10-20 миллисекунд, поэтому даже если написать Sleep(1), то задержка будет > 1 мс.
10. blackhole321 1036 29.03.18 13:33 Сейчас в теме
(8) А если не секрет, зачем Вам такие малые задержки?
11. blackhole321 1036 29.03.18 13:55 Сейчас в теме
(8) Вот есть к примеру такая реализация микросекундного таймера https://www.codeproject.com/Articles/98346/Microsecond-and-Millisecond-NET-Timer , которую не сложно перенести, однако, как отмечает сам автор, если использовать в не real-time ОС, периодически интервалы будут неверными.
12. starik-2005 1938 29.03.18 14:23 Сейчас в теме
(11) периодические интервалы тут не особо критичны. Фактически если у Вас N заданиий, которые обрабатывают по M блоков, то массив из Х блоков они обработают за Х/M/N раз. При том если элемент данных обрабатывается за разное время, то некоторые блоки должны будут обработаться раньше, чем другие, и ДождатьяЗавершения будет ждать самый долгообрабатываемый блок. Для того, чтобы загрузить новые процессы данными, нужно их стартануть с новым массивом обрабатываемой информации. Если ждать секунду (как в 1С, когда народ юзает "ping localhost"), то за секунду можно некоторое количество элементов уже обработать. Поэтому хорошо бы ждать 1/10-ю секунды, например. И на сколько это в миллисекундах точно - второй вопрос, главное чтобы в это время процессор просто ждал...
13. blackhole321 1036 29.03.18 15:19 Сейчас в теме
(12)
Если ждать секунду (как в 1С, когда народ юзает "ping localhost"), то за секунду можно некоторое количество

Ну 1/10 секунды - это 100 миллисекунд, что вполне нормально и для Sleep, который уже есть. И это будет действительно приостановка выполнения. Вот описание метода, который реализует Sleep в OneScript https://msdn.microsoft.com/ru-ru/library/system.threading.thread.sleep(v=vs.110).aspx

Моя изначальная мысль была в том, что можно запускать потоки для обработки новых порций данных из самих потоков, примерно так:

Процедура МоеФЗ(ДанныеДляОбработки) Экспорт
	
	// Что-то делаем
	
	Отбор = Новый Структура;
	Отбор.Вставить("Состояние", СостояниеФоновогоЗадания.Активно);
	Отбор.Вставить("ИмяМетода", "МойМодуль.МоеФЗ");
	МассивЗаданий = ФоновыеЗадания.ПолучитьФоновыеЗадания(Отбор);
	
	МаксКоличествоПотоков = 5;
	КоличествоПотоков = МаксКоличествоПотоков - МассивЗаданий.Количество() + 1;
	
	Для Индекс = 1 По КоличествоПотоков Цикл
		
		ДанныеДляОбработки = ПолучитьСледующуюПорциюДанных();
		
		Если ДанныеДляОбработки = Неопределено Тогда
			Возврат;
		КонецЕсли;
		
		МасиивПараметров = Новый Массив;
		МассивПараметров.Добавить(ДанныеДляОбработки);
		ФоновыеЗадания.Выполнить("МойМодуль.МоеФЗ", МассивПараметров);
		
	КонецЦикла;
	
КонецПроцедуры
Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Екатеринбург
зарплата от 120 000 руб. до 120 000 руб.
Полный день

Бизнес-аналитик 1С
Москва
зарплата от 140 000 руб. до 200 000 руб.
Полный день

Руководитель проектов 1С
Санкт-Петербург
Полный день

Бизнес-архитектор 1С, ведущий консультант
Санкт-Петербург
Полный день