0. dendzu 26 23.03.18 21:56 Сейчас в теме

Расчет квартальной премии в ЗУП 3.0, ЗиКГУ 3.1

Одно из решений расчета квартальной премии в конфигурации Зарплата и кадры государственного учреждения, редакция 3.1. Сумма квартальной премии зависит от отработанных дней в квартале

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. katerina1996 22.05.18 03:53 Сейчас в теме
Добрый день) делаю все по инструкции, по после нажатия кнопки "Расчет квартальной премии" значения обнуляются
2. dendzu 26 22.05.18 06:57 Сейчас в теме
Здравствуйте! Скажите конфигурацию и платформу, релизы?. Потом еще попробуйте с начало:
- нажать на кнопку "Заполнить показатели" (смотрите рисунок 2) выбираем добавленные показатели, заполняем значениями например "1". Нажимаем "ОК";
- затем сохранить документ (кнопка "Записать");
- и нажать нашу добавленную команду "Расчет квартальной премии".
3. vat-74 166 25.05.18 14:59 Сейчас в теме
Взял за основу, немного переписал код, теперь рассчитывается без предварительные действий. ЗиКБУ
4. dendzu 26 28.05.18 08:01 Сейчас в теме
Предварительное действие делал больше для себя, для развития так сказать. Так что принципе это окошко с выбором всех сотрудников или выделенного и не нужно.
5. user658790_antonovdv 25.07.18 15:54 Сейчас в теме
Добрый день ,у меня обработка работает не корректно (1С:Предприятие 8.3 (8.3.12.1412)Зарплата и кадры государственного учреждения, редакция 3.1 (3.1.6.6))

норму всем ставит одинаковую , т.е. норма меняется если меняется период , но у всех сотрудников в табличной части одинаково и причем количество странное , ни к чему не подходит, а факт вроде правильно выдает.
Прикрепленные файлы:
6. dendzu 26 30.07.18 22:49 Сейчас в теме
(5)Здравствуйте! Сообщение увидел, но пока никак не могу посмотреть Вашу ошибку - на работе завал. Как освобожусь обязательно выясню в чем проблема.
7. mea1c 31.07.18 06:02 Сейчас в теме
(6) На релизе 3.1.7.87 не работает, выдает сообщение с текстом "1".
8. user658790_antonovdv 01.08.18 14:03 Сейчас в теме
у меня тоже выдает сообщение с "1" , но "отработано дней в квартале" собирает.
9. dendzu 26 01.08.18 14:12 Сейчас в теме
Здравствуйте! На этой неделе обязательно посмотрю. Сообщение с "1" - это мое тестовое сообщение (забыл за комментировать).
10. user658790_antonovdv 13.08.18 17:48 Сейчас в теме
(9)
посмотрите обработку очень нужна
11. dendzu 26 13.08.18 20:45 Сейчас в теме
(10) Вроде обещал, но на работе запара. Еще раз попытаюсь глянуть.
12. user658790_antonovdv 02.10.18 14:11 Сейчас в теме
(10) автор, есть смысл ждать или пора уже отчаяться?
17. mumik_nr 14.12.18 19:34 Сейчас в теме
(12)

(16) ребята залезти в мозги данной обработки и там где устанавливается параметры запроса у автора есть запрос который ищет порамет по наименованию "должностной оклад" а у нас наверное в большей массе это "оплата по окладу" и вуаля работает помечено между //ФРМ_н и //ФРМ_К
Процедура ЗаполнитьНачисленияПоказатели(Документ, МассивНомерСтроки)	
		
	ДокументОбъект = Документ.ПолучитьОбъект();		
	ДокументОбъектПоказатели =  ДокументОбъект.Показатели;
	ДокументОбъектНачисления = ДокументОбъект.Начисления;
		
	Запрос = ТекстЗапросаОтработаноДнейОборот();
	     
	Для Каждого СтрокаДокументОбъектПоказатели Из ДокументОбъектПоказатели Цикл
		Если СтрокаДокументОбъектПоказатели.Показатель = ПоказательНормаДнейВКвартале Тогда 
			
			НомерСтроки = 0;
			Для Каждого СтрокаДокументОбъектНачисления Из ДокументОбъектНачисления Цикл
				//Перебор по выбранным строкам
				Для Каждого СтрокаМассивНомерСтроки Из МассивНомерСтроки Цикл 
				
				  Если СтрокаДокументОбъектПоказатели.ИдентификаторСтрокиВидаРасчета = СтрокаДокументОбъектНачисления.ИдентификаторСтрокиВидаРасчета И 
						 СтрокаМассивНомерСтроки = НомерСтроки Тогда 
										
					   Запрос.УстановитьПараметр("ДатаНачала", НачалоДня(ДокументОбъект.ДатаНачалаБазовогоПериода));
					   Запрос.УстановитьПараметр("ДатаОкончания", КонецДня(ДокументОбъект.ДатаОкончанияБазовогоПериода));
					   Запрос.УстановитьПараметр("Сотрудник", СтрокаДокументОбъектНачисления.Сотрудник);
					   //фрм_н
					   //Запрос.УстановитьПараметр("Начисление",ПланыВидовРасчета.Начисления.НайтиПоНаименованию("Должностной оклад"));
				          Запрос.УстановитьПараметр("Начисление",ПланыВидовРасчета.Начисления.НайтиПоНаименованию("Оплата по окладу"));
						  //ФРМ_К
						  
				       ЗначениеДнейВКвартале = Запрос.Выполнить().Выгрузить();
					   Если ЗначениеДнейВКвартале.Количество() = 0 Тогда 												 
						 СтрокаДокументОбъектПоказатели.Значение = 0;
					   Иначе 
						 СтрокаДокументОбъектПоказатели.Значение = ЗначениеДнейВКвартале[0].РабочихДней;
						 					   КонецЕсли;			

				   КонецЕсли;	
				  
			     КонецЦикла;
			   НомерСтроки = НомерСтроки + 1;
			КонецЦикла
			
	    КонецЕсли;
	    Если СтрокаДокументОбъектПоказатели.Показатель = ПоказательОтработаноДнейВКвартале Тогда 
						НомерСтроки = 0;
			Для Каждого СтрокаДокументОбъектНачисления Из ДокументОбъектНачисления Цикл
				//Перебор по выбранным строкам
				Для Каждого СтрокаМассивНомерСтроки Из МассивНомерСтроки Цикл 

				   Если СтрокаДокументОбъектПоказатели.ИдентификаторСтрокиВидаРасчета = СтрокаДокументОбъектНачисления.ИдентификаторСтрокиВидаРасчета И
						 СтрокаМассивНомерСтроки = НомерСтроки Тогда
				 
					   Запрос.УстановитьПараметр("ДатаНачала", НачалоДня(ДокументОбъект.ДатаНачалаБазовогоПериода));
					   Запрос.УстановитьПараметр("ДатаОкончания", КонецДня(ДокументОбъект.ДатаОкончанияБазовогоПериода));
					   Запрос.УстановитьПараметр("Сотрудник", СтрокаДокументОбъектНачисления.Сотрудник);
					   //ФРМ_Н
					 //  Запрос.УстановитьПараметр("Начисление",ПланыВидовРасчета.Начисления.НайтиПоНаименованию("Должностной оклад"));
					 Запрос.УстановитьПараметр("Начисление",ПланыВидовРасчета.Начисления.НайтиПоНаименованию("Оплата по окладу"));
					   //ФРМ_К
					 
				       ЗначениеОтработаноДнейВКвартале = Запрос.Выполнить().Выгрузить();
					   Если ЗначениеОтработаноДнейВКвартале.Количество() = 0 Тогда 												 
						 СтрокаДокументОбъектПоказатели.Значение = 0;
					   Иначе 
						 СтрокаДокументОбъектПоказатели.Значение = ЗначениеОтработаноДнейВКвартале[0].ОтработаноДнейОборот; 		
					   КонецЕсли;			
		 
				   КонецЕсли;
				  КонецЦикла;

			 НомерСтроки = НомерСтроки + 1;
		 КонецЦикла
		КонецЕсли;  	 
	КонецЦикла;	
	
	ДокументОбъект.Записать();
		
КонецПроцедуры 
Показать
18. dendzu 26 14.12.18 19:41 Сейчас в теме
(17)
с который ищет порамет по наименованию "должностной оклад" а у нас наверное в большей массе это "оплата по окладу" и вуаля работает

(17)

Ого спасибо за предложенное решение. На досуге надо будет посмотреть.
19. mumik_nr 14.12.18 20:05 Сейчас в теме
(18) Вас спасибо за обработку))) плюсую
13. dendzu 26 02.10.18 15:28 Сейчас в теме
Здравствуйте! Смотрел обработку, но ошибок не нашел. Если бы на демо базе смоделировали проблему - так точно бы исправил.
14. user658790_antonovdv 03.10.18 10:22 Сейчас в теме
15. user1029657 09.11.18 10:18 Сейчас в теме
16. Авдеич 06.12.18 22:05 Сейчас в теме
На релизе 3.1.7.128 не работает, выдает сообщение с текстом "1".
20. hellbe 17.04.19 09:19 Сейчас в теме
Добрый день. Скачал вашу обработку но она оказывается не работает. Жаль потраченных СМ.
Выдает текст с ошибкой 1. И не заполняет норму и отработано.
Скажите есть рабочий вариант?
21. dendzu 26 17.04.19 09:33 Сейчас в теме
Здравствуйте! Посмотрите ответ выше от mumik_nr. Возможно поможет. У Вас ЗУП или ЗИКГУ?
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата до 120 000 руб.
Полный день

Работа от Инфостарт
Санкт-Петербург
Временный (на проект)

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Ведущий программист 1С
Сочи
зарплата от 82 500 руб. до 99 000 руб.
Полный день