Пропало расширение

1. Cat T (Beginner_107) 13.03.18 16:28 Сейчас в теме
Здравствуйте!
Я немного в шоке, но может, просто чего-то не понимаю, подскажите пожалуйста... Вчера создала расширение для конфы УТ 11.3. Сохранила конфу, запустила прогу - все работало... Сегодня расширения просто нет. Вот заходишь в конфигуратор, открываешь окошечко с расширениями, а там пусто. Что это? Почему? Можно ли его как-то вернуть и как не допустить больше, чтоб расширения пропадали?
Ответы
3. Максим Б (Xershi) 345 13.03.18 16:39 Сейчас в теме
(1) обычно такое на платформе 8.3.7 было со старыми БСП. В 11.3 скорее намеренно удалили. Ищите бэкап. Если нет бэкапа и расширение не сохраняли, то ответ нет.
2. НВ А (accounting_cons) 38 13.03.18 16:37 Сейчас в теме
Надо сохранять расширения файл. Тогда всегда будет откуда его восстановить.
4. Игорь Полосков (ipoloskov) 62 13.03.18 16:39 Сейчас в теме
У меня однажды тоже пропало в момент сравнения-объединения.
5. Kom-off (Kom-off) 13.03.18 16:40 Сейчас в теме
Может быть, Вы или кто-то, у кого есть права на это действие, удалил расширение в пользовательском режиме? При этом расширение полностью удаляется из информационной базы, в т.ч. и из конфигуратора.
6. Cat T (Beginner_107) 13.03.18 16:42 Сейчас в теме
Так удалить-то вроде некому... И объединения не делала... Единственное что, добавила в конфу еще новую роль и прошлась обработкой ОбновлениеИД, для метаданных... Может это повлияло? И то есть, расширения могут пропадать, этого следует ожидать? Только своевременная выгрузка поможет?
7. Игорь Полосков (ipoloskov) 62 13.03.18 16:44 Сейчас в теме
(6) я веду разработку расширения в тестовой копии, и переношу в рабочую через файл cfe. То есть свежая архивная копия в виде файла всегда имеется.

Вам можно развернуть бэкап, расширение там должно быть.
8. Cat T (Beginner_107) 13.03.18 16:50 Сейчас в теме
(7) спасибо, на будущее попробую опыт применить
9. Максим Б (Xershi) 345 13.03.18 16:53 Сейчас в теме
(6) я храню каждую версию расширения в файле, так что тоже проблем нет.
Оставьте свое сообщение