1. konyashkingn 3 13.02.18 19:42 Сейчас в теме

Новая строка в дереве значений

Добрый день.

Загрузил результат запрос в дерево значений. Теперь нужно в нужных строках добавить еще строки на уровень ниже. Как добавить разобрался:
Для каждого стр из Объект.Дерево.ПолучитьЭлементы() 
Для каждого Стр1 из Стр.ПолучитьЭлементы() Цикл
Стр2 = Объект.Дерево.ПолучитьЭлементы().Добавить();
КонецЦикла;
КонецЦикла;

А вот как указать ей родителя не могу понять. Стр2. Родитель конечно же не дает сделать. Помогите пожалуйста!
Ответы
Избранное Подписка Сортировка: Древо
7. Xershi 415 13.02.18 21:58 Сейчас в теме
(1) переведи на сервер и преобразуй элемент формы в дерево. Тогда будет работать как в 4. Иначе отладчик включай и справку читай.
2. serg_gres 137 13.02.18 21:01 Сейчас в теме
В той строке, подчинение к которой нужно иметь, в ней и вызывается метод "Добавить".
3. konyashkingn 3 13.02.18 21:07 Сейчас в теме
(2)
Для каждого Стр Из Объект.Дерево.ПолучитьЭлементы() Цикл
		Строка = Стр.Добавить();
	КонецЦикла

так?
4. t.v.s. 88 13.02.18 21:41 Сейчас в теме
(3)
Строка = Стр.Строки.Добавить();
5. konyashkingn 3 13.02.18 21:51 Сейчас в теме
(4) Выдает ошибку на отсутствие "Строки". Там даже в отладке в значении переменной Стр нет "Строки".
6. t.v.s. 88 13.02.18 21:57 Сейчас в теме
(5) Затупил, не обратил внимания что вы хотите на клиенте. Тогда так
Строка = Стр.ПолучитьЭлементы().Добавить();
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Старший Программист 1С НОВОСИБИРСК
Новосибирск
зарплата до 130 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 75 000 руб.
Полный день



Руководитель проектов 1С
Санкт-Петербург
По совместительству