0. MaxS 1721 02.11.17 19:03 Сейчас в теме

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена)

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

Перейти к публикации

AlexandrSmith; +1 Ответить
Вознаграждение за ответ
Показать полностью
Комментарии
Избранное Подписка Сортировка: Древо
193. GennadyOstanin 08.10.18 08:37 Сейчас в теме
При попытке выгрузить правила синхронизации обработка дает сообщение:
Поле объекта не обнаружено (КЛюч)

Место в процедуре ЗаполнитьТаблицуПКС:
...
Для Каждого ДанныеПКСТЧ ИЗ СтрокаТаблицы.СвойстваТабличныхЧастей Цикл
ИмяТЧ = ДанныеПКСТЧ.КЛюч;
...
194. user622896_mosshelp 22.10.18 18:54 Сейчас в теме
А что делать если в УПП 1.3 "Выгрузка правил синхронизации.epf" не открывается, так как она на управляемых видимо написана?
195. MaxS 1721 22.10.18 19:24 Сейчас в теме
(194) Нужно УПП запустить в режиме тонкого клиента, управляемых форм.
196. user622896_mosshelp 22.10.18 20:09 Сейчас в теме
(195)Спасибо! .. но
{ВнешняяОбработка.ВыгрузкаПравилСинхронизацииЧерезУниверсальныйФормат.Форма.Форма.Форма(88)}: Значение не является значением объектного типа (Получить)
КомпонентыОбмена.МенеджерОбмена = ВерсииФормата.Получить(Объект.НомерВерсииФормата);
Прикрепленные файлы:
197. MaxS 1721 23.10.18 17:08 Сейчас в теме
(196)
Так запускали?
В обработку "Выгрузка правил синхронизации.epf" внесены изменения как в статье указано?
198. user622896_mosshelp 23.10.18 19:24 Сейчас в теме
(197)
Выгр
нет, режим запуска менял, тип клиента в конфе не менял понятно.
199. MaxS 1721 24.10.18 10:47 Сейчас в теме
(198) А обработку какую использовали? УПП какой версии?
Проверял у себя, всё работает.
200. kassbar 95 16.11.18 23:25 Сейчас в теме
в последних БП 3.0 варианта с загрузкой своего менеджера обмена через настройку формы уже нет, хотя в реквизитах плана обмена есть путь к менеджеру обмена.
201. MaxS 1721 17.11.18 06:54 Сейчас в теме
(200) Код из расширения для восстановления использования внешней обработки с правилами для БП 3.0.66.х
Общий модуль ОбменДаннымиXDTOСервер

Процедура ED_ПолучитьВерсиюФорматаОбмена(ВерсииФормата, Знач УзелИнформационнойБазы) 
	
	Запрос = Новый Запрос(
	"ВЫБРАТЬ РАЗЛИЧНЫЕ
	|	СинхронизацияДанныхЧерезУниверсальныйФормат.ПутьКМенеджеруОбмена КАК ПутьКМенеджеруОбмена,
	|	СинхронизацияДанныхЧерезУниверсальныйФормат.ВерсияФорматаОбмена КАК ВерсияФорматаОбмена
	|ИЗ
	|	ПланОбмена.СинхронизацияДанныхЧерезУниверсальныйФормат КАК СинхронизацияДанныхЧерезУниверсальныйФормат
	|ГДЕ
	|	СинхронизацияДанныхЧерезУниверсальныйФормат.ПутьКМенеджеруОбмена <> """"
	|	И СинхронизацияДанныхЧерезУниверсальныйФормат.Ссылка = &Ссылка");
	
	Запрос.УстановитьПараметр("Ссылка", УзелИнформационнойБазы);
	Выборка = Запрос.Выполнить().Выбрать();
	
	Пока Выборка.Следующий() Цикл
		
		ИмяОбработки = Выборка.ПутьКМенеджеруОбмена;
		ФайлОбработки = Новый Файл(ИмяОбработки);
		Если НЕ ФайлОбработки.Существует() Тогда
			Продолжить;
		КонецЕсли;
		
		Если НЕ ОбщегоНазначенияКлиентСервер.РежимОтладки() Тогда 
			ДанныеОбработки = Новый ДвоичныеДанные(ИмяОбработки);
			АдресОбработки  = ПоместитьВоВременноеХранилище(ДанныеОбработки);
			
			Если ОбщегоНазначения.ЕстьЗащитаОтОпасныхДействий() Тогда
				ИмяОбработки = ВнешниеОбработки.Подключить(АдресОбработки, , ,
				ОбщегоНазначения.ОписаниеЗащитыБезПредупреждений());
			Иначе
				ИмяОбработки = ВнешниеОбработки.Подключить(АдресОбработки);
			КонецЕсли;
		КонецЕсли;
		
		МенеджерОбмена = ВнешниеОбработки.Создать(ИмяОбработки);
		
		ВерсииФормата.Вставить(Выборка.ВерсияФорматаОбмена, МенеджерОбмена);
		
	КонецЦикла;
	
КонецПроцедуры


&Вместо("ВерсииФорматаОбмена")
Функция ED_ВерсииФорматаОбмена(Знач УзелИнформационнойБазы)
	
	ВерсииФорматаОбмена = Новый Соответствие;
	ИмяПланаОбмена = "";
	
	Если ЗначениеЗаполнено(УзелИнформационнойБазы) Тогда
		ИмяПланаОбмена = ОбменДаннымиПовтИсп.ПолучитьИмяПланаОбмена(УзелИнформационнойБазы);
		ВерсииФорматаОбмена = ОбменДаннымиСервер.ЗначениеНастройкиПланаОбмена(ИмяПланаОбмена, "ВерсииФорматаОбмена");
		ED_ПолучитьВерсиюФорматаОбмена(ВерсииФорматаОбмена, УзелИнформационнойБазы);
	Иначе
		ОбменДаннымиПереопределяемый.ПриПолученииДоступныхВерсийФормата(ВерсииФорматаОбмена);
	КонецЕсли;
	
	Если ВерсииФорматаОбмена.Количество() = 0 Тогда
		Если ЗначениеЗаполнено(УзелИнформационнойБазы) Тогда
			ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
				НСтр("ru = 'Не заданы версии формата обмена.
				|Имя плана обмена: %1
				|Процедура: ПолучитьВерсииФорматаОбмена(<ВерсииФорматаОбмена>)'"),
				ИмяПланаОбмена);
		Иначе
			ВызватьИсключение НСтр("ru = 'Не заданы версии формата обмена.
				|Процедура: ОбменДаннымиПереопределяемый.ПриПолученииДоступныхВерсийФормата(<ВерсииФорматаОбмена>)'");
		КонецЕсли;
	КонецЕсли;
	
	Результат = Новый Соответствие;
	
	Для Каждого Версия Из ВерсииФорматаОбмена Цикл
		
		Результат.Вставить(СокрЛП(Версия.Ключ), Версия.Значение);
		
	КонецЦикла;
	
	Возврат Результат;
	
	
КонецФункции

Показать
ZeroSumGame; kassbar; +2 Ответить
202. kassbar 95 17.11.18 17:19 Сейчас в теме
(201) интересно, с какой целью была отключена эта возможность, должно же быть какое-то объяснение. Ну перевели БП на формат менеджера версии 2, и что ?
203. MaxS 1721 18.11.18 09:51 Сейчас в теме
(202) Это наверное можно понять, т.к. при работе на сервере пользователь забывает о правах доступа к обработке и обмен нарушается. Или после изменения обработки срабатывает защита от опасных действий и обмен завершается с ошибкой.
Могли бы сделать в узле ссылку на доп обработки, которые подключаются штатно в предприятии. Тогда сервер сам бы правильно разрулил права.

Непонятно зачем сделали и сами же запретили использовать обработки с правилами для обработки "Выгрузка загрузка EnterpriseData". Даже выбор файла с правилами работает и потом сообщают, что 'Внешняя обработка отладки, загружаемая из файла на диске, не поддерживается.'. Ну так если нельзя, можно было просто заблокировать поле выбора файла. Эту проблему тоже можно исправить расширением - заменить в модуле обработку Функция КомпонентыОбмена( на работающий вариант из прошлых версий.
204. kassbar 95 18.11.18 13:35 Сейчас в теме
(203)
Непонятно зачем сделали и сами же запретили использовать обработки с правилами для обработки "Выгрузка загрузка EnterpriseData".

о, там оказывается еще и свой менеджер выгрузки можно подключать в режиме разработчика, круто
207. dragen 22.11.18 17:11 Сейчас в теме
Спасибо за статью. Есть вопрос.

У меня 2 базы Бух 3.0 и 1 база УТ 11.4(две организации). Соответственно в УТ две синхронизации.
Версия формата: 1.3. Правила типовые с небольшими доработками.

Нужно сделать в УТ условие, в МенеджерОбменаЧерезУниверсальныйФормат, чтобы доработка работала только для обмена с Бух №1, а для Бух №2 не выполнялась.

Каким образом можно реализовать или куда смотреть?
208. MaxS 1721 23.11.18 07:03 Сейчас в теме
(207) В параметры конвертации передать значение, связанное с узлом и в правилах проверять параметр.
Например есть строковый реквизит на узле ВариантНастройки
Чтобы не ломать типовые механизмы можно например доп сведение попробовать добавить к узлу.
209. seva1405 33 28.11.18 20:11 Сейчас в теме
Жесть! Мне нужно просто убрать все банковские документы, для этого столько нужно сделать и получилось только с 5 раза. Спасибо разработчикам конечно, но правда не понятно зачем это делать, использование внешних обработок заблокировано, общий модуль даче через расширение дорабатывать просто ад - каждую процедуру.
В КД 2.0 - выгрузил правила отключил обработку выгрузки, загрузил обратно и все как надо работает.
210. MaxS 1721 29.11.18 07:50 Сейчас в теме
(209) Здесь всё так же.
В КД 2.0 - выгрузил правила
регистрации и запретил регистрацию ненужных объектов.
211. seva1405 33 29.11.18 12:17 Сейчас в теме
(210) можно по подробнее куда их загрузить? В КД 3 не могу найти куда загрузить правила регистрации.
212. MaxS 1721 29.11.18 18:06 Сейчас в теме
(211) Правила регистрации редактируются в КД 2. Правила обмена - в КД3.
213. seva1405 33 29.11.18 21:07 Сейчас в теме
214. seva1405 33 29.11.18 21:09 Сейчас в теме
Автор, подскажи пожалуйста, в бп 3.0.60 нет поля выбора модуля обмена, его убрали совсем или как то все же можно его подключить?
Прикрепленные файлы:
215. MaxS 1721 30.11.18 04:58 Сейчас в теме
(214) Есть подозрение, что убрали совсем, но т.к. сам реквизит ещё присутствует, то из предыдущих БП можно взять код для выбора файла для формы, из комментариев выше или скоро в статье будет - код для БП 3.0 для подключения обработки с правилами.

ps.
Давно в планах мысль поделиться расширениями для разных конфигураций для подобных целей и для КД3. Может кто аватарку нарисует? Для "Полезные инструменты. EnterpriseData (универсальный формат обмена)", а то их уже много одинаковых на разные публикации.
219. r2d24 20.12.18 12:29 Сейчас в теме
Делал как описано выше в статье.
Выгружал из базы Розница, редакция 2.2 (2.2.9.20). Загрузил в конвертацию данных 3.0.5.3, сделал как описано в статье.
В КД выгрузил модуль менеджера обмена, как описано в разделе "Проверка корректности загрузки правил".

У меня отличие в отсутствии одной процедуры "ПКО_ПКО_АТТ_ОтчетОРозничныхПродажах_ПриОтправкеДанных"

Решил проделать тоже самое, только с базой УТ. У меня там еще больше больше отличий. Не пойму что не так?
220. MaxS 1721 24.12.18 16:12 Сейчас в теме
(219) Как писал выше, расхождения возможны из-за того, что не загружены правила какой-нибудь версии формата.
Нужно смотреть в исходнике какой используется объект формата и есть ли он у Вас в КД3.
221. MaxS 1721 29.12.18 17:52 Сейчас в теме
Дополнил статью.
Искать текст "использование расширения с правилами обмена в универсальном формате".
Приведен пример кода для расширения чтобы подменить общий модуль с типовыми правилами на свой.
222. Angealtor 22 14.01.19 12:06 Сейчас в теме
Доброго всем дня! Подскажите, есть ли штатная возможность выгружать только проведенные документы и дополнить каждый документ доп.реквизитами "ПометкаУдаления" и "Проведен". Или же без AdditionalInfoВставить никак?
223. MaxS 1721 14.01.19 19:59 Сейчас в теме
(222) Добрый день!
Штатно и так выгружаются проведённые. За это отвечают правила регистрации. Вроде так было.
И если выгружается проведённый документ, то и так ясно, что он не помечен на удаление и проведён ;)
Чтобы дополнить этими реквизитами, без AdditionalInfo не обойтись.
Angealtor; +1 Ответить
224. Angealtor 22 15.01.19 12:56 Сейчас в теме
(223) Перед запуском обмена при начальной синхронизации выгружаются все документы. И потом в базе-приемнике становятся проведенными, включая те, которые в базе-отправителе были просто записанными. Поэтому пришлось доп. условие добавить. Попробую правила взять из более свежего релиза, может просто баг. Спасибо!
225. MaxS 1721 15.01.19 13:31 Сейчас в теме
(224) На всякий случай сообщу, что от первой синхронизации всеми объектами можно отказаться. Просто закрываете форму настройки на этом шаге. Настройка обмена уже создана. На всякий случай проверяете и отменяете все зарегистрированные объекты и запускаете обмен пустым сообщением. Потом продолжаете настройку другой базы если это не прямое соединение.
226. Angealtor 22 16.01.19 09:43 Сейчас в теме
Еще одну проблему нашел или не до конца разобрался.
УТ 11.4.6.174. Выгрузил конфиг, правила синхронизации. Загрузил в КД 3.0. Из КД 3.0 выгрузил во внешнюю обработку ("Сохранить модуль менеджера обмена"). Стандартные из общего модуля УТ тоже выгрузил во внешнюю. Сравниваю их, а они - не равны.
227. ZeroSumGame 12.02.19 09:30 Сейчас в теме
(226) За это отдельное "спасибо" разработчикам типовых, которые, видимо, пользуются своим отдельным инструментом, либо же дописанной КД3. Стандартные правила Бухгалтерии и Торговли типовой КД3 корректно не разбираются. Соль там в синтаксическом разборе текста модуля, который четко заточен на конкретные сочетания префиксов и постфиксов в именах функций и процедур. Все, что этим сочетаниям не соответствует - просто не загружается в КД3.
228. demetrius2003 11 23.03.19 11:57 Сейчас в теме
Грёбаная сыромятина! Вот даже просто следуя этому мануалу получаем на Этапе 2 "Поле объекта не обнаружено" и "Правила обработки данных загружены. Обработано: 165, создано новых 0" И вроде бы намерения благие, да только дорожка то непонятно куда!
229. MaxS 1721 23.03.19 16:08 Сейчас в теме
(228) Может быть что-то в конфигурации не исправлено, что в статье описано. Например при загрузке ПКО для отправки конфигурация пытается получить параметры этого ПКО для получения.
230. demetrius2003 11 23.03.19 16:11 Сейчас в теме
(229) Ваша правда! Без снятия с поддержки и доработки (или ещё как) ничего не получится! Уже прорвался далее до, собственно, редактирования.
233. simonov_2015 02.04.19 14:54 Сейчас в теме
БП 3.0.67 Перестал нормально работать обмен, с использованием внешних обработок в качестве менеджеров обмена. Выгрузка проходит, но при этом объекты выгружаются по типовым правилам. До этого релиза использовали внешние обработки очень давно, естественно каждый раз допиливали возможность указания пути к файлу внешней обработки и добавляли расширение с подменой функции ВерсииФорматаОбмена - как указано в статье, спасибо автору.
Разбираясь заметил интересную деталь, если запускать предприятие с ключом РежимОтладки то выгрузка проходит корректно. Оказалось, что неверно заполняется Значение в соответствии ВерсииФормата(см. картинку) в функции ПоддерживаемыеОбъектыФормата. В итоге в расширение пришлось добавить еще одну функцию
&Вместо("ПоддерживаемыеОбъектыФормата")
Функция РКМК_ПоддерживаемыеОбъектыФормата(ИмяПланаОбмена, Режим = "ОтправкаПолучение", УзелОбмена = Неопределено) Экспорт
	
	ТаблицаОбъекты = Новый ТаблицаЗначений;
	ИнициализироватьТаблицуПоддерживаемыхОбъектовФормата(ТаблицаОбъекты, Режим);
	
	//ВерсииФормата = ОбменДаннымиСервер.ЗначениеНастройкиПланаОбмена(ИмяПланаОбмена, "ВерсииФорматаОбмена"); оригинал
	ВерсииФормата = РКМК_ВерсииФорматаОбмена(УзелОбмена);  //из расширения
	
	Для Каждого Версия Из ВерсииФормата Цикл
		
		Если СтрНайти(Режим, "Отправка") Тогда
			КомпонентыОбмена = ИнициализироватьКомпонентыОбмена("Отправка");
			
			КомпонентыОбмена.ВерсияФорматаОбмена = Версия.Ключ;
			КомпонентыОбмена.МенеджерОбмена = Версия.Значение;
			
			КомпонентыОбмена.XMLСхема = ФорматОбмена(ИмяПланаОбмена, КомпонентыОбмена.ВерсияФорматаОбмена);
			
			ИнициализироватьТаблицыПравилОбмена(КомпонентыОбмена);
			
			ЗаполнитьПоддерживаемыеОбъектыФорматаПоКомпонентамОбмена(ТаблицаОбъекты, КомпонентыОбмена);
		КонецЕсли;
		
		Если СтрНайти(Режим, "Получение") Тогда
			КомпонентыОбмена = ИнициализироватьКомпонентыОбмена("Получение");
			
			КомпонентыОбмена.ВерсияФорматаОбмена = Версия.Ключ;
			КомпонентыОбмена.МенеджерОбмена = Версия.Значение;
			
			КомпонентыОбмена.XMLСхема = ФорматОбмена(ИмяПланаОбмена, КомпонентыОбмена.ВерсияФорматаОбмена);
			
			ИнициализироватьТаблицыПравилОбмена(КомпонентыОбмена);
			
			ЗаполнитьПоддерживаемыеОбъектыФорматаПоКомпонентамОбмена(ТаблицаОбъекты, КомпонентыОбмена);
		КонецЕсли;
		
	КонецЦикла;
	
	ЕстьАлгоритм = ОбменДаннымиСервер.ЕстьАлгоритмМенеджераПланаОбмена(
		"ПриОпределенииПоддерживаемыхОбъектовФормата", ИмяПланаОбмена);
	Если ЕстьАлгоритм Тогда
		ПланыОбмена[ИмяПланаОбмена].ПриОпределенииПоддерживаемыхОбъектовФормата(ТаблицаОбъекты, Режим, УзелОбмена);
	КонецЕсли;
	
	Возврат ТаблицаОбъекты;
	
КонецФункции
Показать

Понять почему неверно заполняется значение в соответствии ВерсииФормата не получилось ((
Прикрепленные файлы:
235. MaxS 1721 03.04.19 17:17 Сейчас в теме
(233) В последней БП 3.0.69 делал, вроде работает, но для постоянного использования рекомендуется расширение, а внешняя обработка только для отладки. Так даже в 1С отвечали.
234. simonov_2015 03.04.19 16:50 Сейчас в теме
Подскажите, по какому принципу встают на регистрацию объекты, если в настройке синхронизации в правилах отправки выбран способ "Отправлять только используемую в документах"?
Добавил в табличную часть документа новый реквизит (справочникСсылка) не могу зарегистрировать элементы этого справочника на обмен.
236. MaxS 1721 03.04.19 17:20 Сейчас в теме
(234) Теоретически должны автоматически регистрироваться элементы справочников из документа. Практически это не всегда работает как хотелось бы.
И в любом случае этот вид справочника должен быть в составе плана обмена и в подписках.
Ручная регистрация не должна работать, если не ошибаюсь.
237. artfa 41 20.05.19 17:05 Сейчас в теме
ни разу не пользовался поделием КД3.0, все что надо корректирую непосредственно в модуле
Franchiser; +1 Ответить
239. leobrn 191 13.06.19 08:36 Сейчас в теме
Подскажите, какой план действий для добавления своего документа в планы обмена через униф. формат?
243. Xershi 708 26.07.19 17:28 Сейчас в теме
(239) если он есть в 2 конфигурациях как не типовой, то пилить схему, затем пилить правила как для типовых. Инфы в нете достаточно для понимания.
240. Xershi 708 26.07.19 12:37 Сейчас в теме
Нужно что-то сделать с
Процедура ЗагрузитьПКО()
...
// Вариант идентификации - особая логика.
	Если ТекПКО.ИспользоватьДляПолучения Тогда //ED
		ТекПКО.ВариантИдентификации = Перечисления.ВариантыИдентификацииОбъектов[СтруктураАтрибутов.ВариантИдентификации];
	КонецЕсли;

Если допиливать правила, где указана галка отправить, то сохранить их не дает пока не заполнишь реквизит "ВариантИдентификации".
А он на форме ПКО виден, только если поставить галку получать или отправить и получать.
Далее нужно выбрать какой-то вариант вручную заполнял "Сначала по УИД, потом по полям поиска".
Проблема была в том что, если это условие не дописать, то вариант идентификации мог быть пустой и правила вообще не грузились...
241. MaxS 1721 26.07.19 13:16 Сейчас в теме
(240)
Нужно что-то сделать
Это вопрос или утверждение? )
Для чтения файлов с правилами нужна эта доработка. При сохранении правил в буфер обмена, не помню, вроде ошибки не возникает.
242. Xershi 708 26.07.19 13:44 Сейчас в теме
(241) я правила уже загрузил, так что это больше вопрос к обсуждению.
Для чего именно такой вариант допила делали?
244. MaxS 1721 26.07.19 18:05 Сейчас в теме
(242)
Для чего именно такой вариант допила делали?
На момент доработки этот вариант показался самым логичным. Вроде бы работает. Можно было конечно поставить везде попытку исключение, где возникает ошибка, но это самый некрасивый вариант.
245. Xershi 708 26.07.19 18:23 Сейчас в теме
(244) я к тому что после такой загрузки реквизит "ВариантИдентификации" не заполнен. А он обязательный при записи ПКО, что не дает отредактировать правило и нужно лишние действия делать.
ВариантИдентификации = ПредопределенноеЗначение("Перечисления.ВариантыИдентификацииОбъектов."  + СтруктураАтрибутов.ВариантИдентификации);
Если Не ЗначениеЗаполнено(ВариантИдентификации) Тогда
 ВариантИдентификации = ПредопределенноеЗначение("Перечисления.ВариантыИдентификацииОбъектов.ПоУникальномуИдентификатору");
КонецЕсли;
ТекПКО.ВариантИдентификации = ВариантИдентификации;

А вот с таким кодом этот реквизит будет всегда заполнен и проблем с редактированием элементов не возникнет.
Хотя возможно проблема возникла еще раньше, когда заполнялась структура "СтруктураАтрибутов"?
Посмотрел по коду, действительно проблема возникла еще раньше. Когда мы выгрузили файлы "PKO.xml" в частности, то там много где указан текст
ВариантИдентификации=""

Поэтому и ошибку выбивало. Надо смотреть почему так вышло...
Посмотрел...
В модуле "МенеджерОбменаЧерезУниверсальныйФормат" есть процедура "ЗаполнитьПравилаКонвертацииОбъектов" и там где НаправлениеОбмена = "Отправка" тихий ужас.
И у всех наверно процедур нет заполнения реквизита "ВариантИдентификации" в структуре "ПравилоКонвертации". Что по итогу и дает проблему.
Посмотрел в конфигураторе Значение заполнения = "ПоУникальномуИдентификатору".
Выходит, если вручную создавать ПКО, то этот реквизит будет заполнен, но похоже разработчики 1С все это генерировали программно и забыли про него.

Как итог предложенный код будет решением проблемы.
246. MaxS 1721 26.07.19 19:10 Сейчас в теме
(245) Посмотрел у себя, в модуле объекта справочника ПравилаКонвертацииОбъектов
увидел такую доработку:

Процедура ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты) //ED
	Если НЕ ЭтотОбъект.ИспользоватьДляПолучения И НЕ ПроверяемыеРеквизиты.Найти("ВариантИдентификации")=Неопределено Тогда
		ПроверяемыеРеквизиты.Удалить(ПроверяемыеРеквизиты.Найти("ВариантИдентификации"));
	КонецЕсли;
КонецПроцедуры

Видимо забыл отразить в статье. Будет поправлено.
247. Xershi 708 26.07.19 22:01 Сейчас в теме
(246) я больше склоняюсь к первому варианту, напишу в суппорт по этому вопросу.
Кстати было бы не плохо если бы было больше простых примеров возможностей доработки:
https://forum.infostart.ru/forum15/topic222615
248. MarryJane 23 31.07.19 08:24 Сейчас в теме
Может кто решал задачу перенос картинок номенклатуры через EnterpriseData или другой справочник(как пример) Поделитесь опытом
249. MaxS 1721 07.08.19 08:21 Сейчас в теме
(248) Давно уже как решил такой вопрос.
 // УТ 10.3  ПКО_Справочник_Файлы_Отправка_ПриОтправкеДанных
Если СтекВыгрузки.Количество() > 1 Тогда
	Возврат;
КонецЕсли;

Если ТипЗнч(ДанныеИБ.Объект)=Тип("СправочникСсылка.Номенклатура") Тогда
	ВладелецФайла = Новый Структура("Значение, ИмяПКО", ДанныеИБ.Объект, "Справочник_Номенклатура_Отправка");
КонецЕсли;
ДанныеXDTO.Вставить("ВладелецФайла", ВладелецФайла);

Если ДанныеИБ.ВидДанных=Перечисления.ВидыДополнительнойИнформацииОбъектов.Изображение Тогда
	ХранимыйФайл = Base64Строка(ДанныеИБ.Хранилище.Получить().ПолучитьДвоичныеДанные());
Иначе
	ХранимыйФайл = Base64Строка(ДанныеИБ.Хранилище.Получить());
КонецЕсли;
ДанныеXDTO.Вставить("ХранимыйФайл", ХранимыйФайл);

РасширениеИмениФайла = ОбщегоНазначенияКлиентСервер.ПолучитьРасширениеИмениФайла(ДанныеИБ.ИмяФайла);
Если ПустаяСтрока(РасширениеИмениФайла) Тогда
	Если ДанныеИБ.ВидДанных=Перечисления.ВидыДополнительнойИнформацииОбъектов.Изображение Тогда
		РасширениеИмениФайла = "jpg";
	Иначе
		РасширениеИмениФайла = "tmp";
	КонецЕсли;
КонецЕсли;
ДанныеXDTO.Вставить("Расширение", РасширениеИмениФайла);

Если ЗначениеЗаполнено(ДанныеИБ.ТекстФайла) Тогда
	Описание = ДанныеИБ.ТекстФайла.Получить();
	Если НЕ ПустаяСтрока(Описание) Тогда
		ДанныеXDTO.Вставить("Описание", Описание);
	КонецЕсли;
КонецЕсли;
Показать
250. SERGQ 38 08.10.19 14:40 Сейчас в теме
Статья крутая. Спасибо автору!
251. AlexandrSmith 46 11.10.19 09:58 Сейчас в теме
Сам несколько раз заморачивался с конвертированием данных, эта статья довольно информативна.
Alex1053669; MaxS; +2 Ответить
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Москва
зарплата от 120 000 руб. до 150 000 руб.
Полный день


Программист 1С
Санкт-Петербург
зарплата от 80 000 руб. до 120 000 руб.
Полный день

Архитектор 1С
Санкт-Петербург
зарплата от 150 000 руб.
Полный день

Программист 1С (Оперативный учет)
Санкт-Петербург
зарплата от 120 000 руб.
Полный день