1. _Pups_ 04.08.17 22:44 Сейчас в теме

Перенос шапки таблицы на каждую страницу в СКД

День дорбрый! Имеется БГУ 1.0. Типовой отчет Расчетная Ведомость. Нужно чтобы шапка таблицы была на каждой странице при переносе данных. В скд в настройках собрана таблица. Отчет резиновый, что не позволяет задать точное количество колонок. Была мысль передать в модуле отчета СКД в дерево или таблицу значений, ругается. Как можно реализовать?
Ответы
Избранное Подписка Сортировка: Древо
2. mickey.1cx 346 05.08.17 00:08 Сейчас в теме
Если известна высота шапки, то можно в процедуру ПриКомпоновкеРезультата модуля отчета добавить повторение строк при печати

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
	
// если высота шапки три строки
	ДокументРезультат.ПовторятьПриПечатиСтроки = ДокументРезультат.Область(1,, 3); 
	
КонецПроцедуры

Показать
3. _Pups_ 05.08.17 10:41 Сейчас в теме
(2)не известно, шапка формируется скд при выполнении запроса
4. mickey.1cx 346 05.08.17 11:43 Сейчас в теме
(3)
Если неизвестно, но шапка автоматически фиксируется при компоновке, то в этом случае можно использовать свойство ФиксацияСверху табличного документа.
Для этого придется отключить стандартный обработчик и выполнить компоновку кодом, например:

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
	
	СтандартнаяОбработка = Ложь;
	
	НастройкиКомпоновки = КомпоновщикНастроек.ПолучитьНастройки();
	
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, НастройкиКомпоновки, ДанныеРасшифровки);
	
	ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(МакетКомпоновки,, ДанныеРасшифровки);
	
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
	ПроцессорВывода.Вывести(ПроцессорКомпоновки);
	
	Если ДокументРезультат.ФиксацияСверху Тогда
		ДокументРезультат.ПовторятьПриПечатиСтроки = ДокументРезультат.Область(1,, ДокументРезультат.ФиксацияСверху);
	КонецЕсли;
	
КонецПроцедуры

Показать
5. Zlaya-Ferio 08.08.19 09:56 Сейчас в теме
Поднимем тему))))
Проблема с выводом заголовка. Строка из (2) работает, но только в файловом режиме. Как заставить работать в серверном?
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Чебоксары
зарплата от 50 000 руб. до 70 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 80 000 руб. до 120 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 110 000 руб. до 150 000 руб.
Полный день

Программист 1С
Воронеж
зарплата от 70 000 руб.
Полный день

Программист 1С
Москва
зарплата до 160 000 руб.
Полный день