1. kar911 30.12.16 09:13 Сейчас в теме

Нажатие в пусто поле

Как сделать так чтобы при нажатие в поле если оно пустое открывалась форма контрагента
Ответы
Избранное Подписка Сортировка: Древо
2. danjer74 30.12.16 09:27 Сейчас в теме
3. kar911 30.12.16 09:31 Сейчас в теме
(2)
Нового контрагента?

нет ссылка на которого храниться в реквизите
4. danjer74 30.12.16 09:35 Сейчас в теме
(3) Не совсем понятна задача. Можно подробнее? Просто если у реквизита тип справочник контрагенты или партнеры - тогда все норм.
5. kar911 30.12.16 09:40 Сейчас в теме
(4)
Можно подробнее? Просто если у реквизита тип справочник контрагенты или партнеры - тогда все норм.

есть реквизит партнер его тип справочники.контрогенты
есть реквизит ФИО руководителя его тип строка
в поле ФИОруководителя западает значение из таблички контрагента при изменение партнера
нужно чтобы открылась карточка контрагента при нажатие на поле ФИОруководителя если оно пусто для заполнения данных
6. danjer74 30.12.16 09:44 Сейчас в теме
(5)ФИО из контактной информации?
8. kar911 30.12.16 09:53 Сейчас в теме
(6)
из контактной инфо

нет
Прикрепленные файлы:
9. danjer74 30.12.16 10:00 Сейчас в теме
(8)При нажатии на реквизит в этой форме что должно произойти?
10. kar911 30.12.16 10:04 Сейчас в теме
(9)
нажатии на реквизит в этой форме что должно произойти

провериться заполнен ли реквизит если нет то открыть форму контрагента
7. mad375 30.12.16 09:47 Сейчас в теме
(1)Такое волшебство вроде как только через COM
11. kar911 30.12.16 10:08 Сейчас в теме
вот такое покачто придумал поставил свойство изменение текста
&НаКлиенте
Процедура ФизЛицоПокупателяИзменениеТекстаРедактирования(Элемент, Текст, СтандартнаяОбработка)
	если Флаг() тогда
		ФормаВыбора = ПолучитьФорму("Справочник.Контрагенты.ФормаОбъекта",Новый Структура("Ключ",Объект.Покупатель)); 
	    ФормаВыбора.Заголовок	= "Внесите недостающие данные";
	  	ФормаВыбора.ОткрытьМодально(); 
	КонецЕсли;

КонецПроцедуры

&НаСервере
Функция Флаг ()
	
	Возврат ?(ЗначениеЗаполнено(Объект.Покупатель.Партнер.ФИОРуководителяИП),Ложь,Истина);	
КонецФункции
Показать
12. PhoenixAOD 57 30.12.16 10:15 Сейчас в теме
(11)а что мешает сделать проверку при записи объекта? и если пустое значение делаем отказ, и открываем нужные справочник?
13. danjer74 30.12.16 10:23 Сейчас в теме
(11)Ну подход в общем и целом правильный. Только я бы через оповещения делал. От модальности надо отказываться - 1С об этом пишут.
14. kar911 30.12.16 10:32 Сейчас в теме
(13)
общем и целом правильный. Только я бы через оповещения делал. От модальности надо отказываться - 1С об этом пишут.

это как я просто с таким не сталкивался ещё
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Ведущий инженер - программист 1С
Москва
зарплата от 200 000 руб.
Полный день

Ведущий программист 1С
Нижний Новгород
зарплата от 100 000 руб.
Полный день

Программист 1С
Нижний Новгород
зарплата до 120 000 руб.
Полный день

Программист 1С
Волгоград
зарплата от 45 000 руб. до 90 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству