Тягунов Иван | Управляющий партнер, основатель | Консалтинговая группа "Wiseadvice"

«UX/UI: почему 1С проигрывает веб-приложениям по интерфейсам, и как это изменить?»

В последние 5-7 лет решения на платформе 1С проигрывают позиции в разных нишах приложениям и сервисам, основанным на веб-технологиях. Основная причина тому - интерфейсы. Почему интерфейсы так важны пользователям и лицам, принимающим решение о выборе приложения? Почему "красиво" часто означает "эффективно"? Как успешно конкурировать с приложениями на веб-технологиях? Границы и технологии веб-разработки как внутри 1С, так и на стыке с 1С. Какие подходы и техники стоит перенять из веб-разработки? (Персонажи, сценарии, прототипы и др.). Когда в 1С нужно прототипирование интерфейсов, и как его осуществлять (инструменты)? Что такое дизайн-система, как ее разработать и поддерживать, к чему стремиться? Подходы и методы улучшения интерфейсов уже эксплуатируемых 1С-систем.

Добавление(редактирование) информации в полях Торг-12

1. DeniskinMENZ 26.12.16 22:50 Сейчас в теме
Доброго времени суток!
Вопрос следующего характера, есть ВПФ Торг-12, в ней в частности надо добавить реквизит из справочника контрагента наименование, не полное, в поле грузополучатель, те помимо полного наименования, инн и тд, как это правильно сделать?

Просмотрел темы не одна не подошла.

ЗЫ 8.2 КА
Ответы
Сортировка: Древо
2. Caspersky 26.12.16 23:11 Сейчас в теме
Фактически изменить одну строчку кода в модуле ВПФ.
3. DeniskinMENZ 27.12.16 00:26 Сейчас в теме
(2)Какую именно? Если не затруднит.
4. Caspersky 27.12.16 01:01 Сейчас в теме
(3)что-то вроде,
ОбластьМакета.Параметры.ПредставлениеГрузополучателя = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузополучателе, "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,БИК,КоррСчет");

точнее нужен конкретно Ваш код...
5. DeniskinMENZ 27.12.16 17:50 Сейчас в теме
(4)пытался подставлять разные коды в итоге выводит без изменений
6. Alex_E 1821 27.12.16 18:16 Сейчас в теме
Порядок такой соблюдался:

1. Изменяем ВПФ
2. Сохраняем ВПФ
3. Подцепляем ВПФ
4. Проверяем ВПФ

ежели не так, то не стоит ждать изменения. А вообще тестировать ВПФ лучше через отладчик, или делать форму обработки и тестировать через неё)))))
7. DeniskinMENZ 27.12.16 18:30 Сейчас в теме
(6)да порядок такой. загвозка у меня в чем? в том что не могу найти как правильно называется поле чтобы правильно подставить, из данных контрагента поле наименование или комментарий, вообщем вот так верно или нет
ОбластьМакета.Параметры.ПредставлениеГрузополучателя = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузополучателе, "ПолноеНаименование,Наименование,Комментарий,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,БИК,КоррСчет");

этот код не показывает ни наименование ни комментарий, что именно не так написал?
8. Alex_E 1821 27.12.16 18:35 Сейчас в теме
ПИшите в лимчку - могу через амми админ посмотреть, времени жалко на гадать
9. DeniskinMENZ 28.12.16 00:09 Сейчас в теме
ОбластьМакета.Параметры.ПредставлениеГрузополучателя = ФормированиеПечатныхФормСервер.ОписаниеОрганизации(СведенияОГрузополучателе, "ПолноеНаименование,СокращенноеНаименование,НаименованиеСокращенное,Наименование,Комментарий,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,БИК,КоррСчет");


ни СокращенноеНаименование, ни НаименованиеСокращенное, ни Наименование, ни Комментарий не показывают нужную информацию, вернее вообще ничего не выводят, что не так написал?
10. Caspersky 28.12.16 16:32 Сейчас в теме
(9)
ФормированиеПечатныхФормСервер.ОписаниеОрганизации

Все не так.
Пытаетесь угадать?
Здесь пальцем в небо не прокатит...

1. Загляните в процедуру ОписаниеОрганизации()
посмотрите, разберитесь, как она работает, какие поля возвращает ....
все станет понятно.

или

2. Вам в (8) предложили помощь, воспользуйтесь...
11. DeniskinMENZ 28.12.16 21:49 Сейчас в теме
(10)
1. Загляните в процедуру ОписаниеОрганизации()
посмотрите, разберитесь, как она работает, какие поля возвращает ....
все станет понятно.


Функция ОписаниеОрганизации(СписокСведений, Знач Список = "", СПрефиксом = Истина) Экспорт

	Если ПустаяСтрока(Список) Тогда
		Список = "ПолноеНаименование,НаименованиеСокращенное,ИНН,Свидетельство,ЮридическийАдрес,Телефоны,НомерСчета,Банк,БИК,КоррСчет";
	КонецЕсли;

	Результат = "";

	СоответствиеПараметров = Новый Соответствие();
	СоответствиеПараметров.Вставить("ПолноеНаименование", 		" ");
	СоответствиеПараметров.Вставить("НаименованиеСокращенное", 	" ");
	СоответствиеПараметров.Вставить("ИНН",                		" ИНН ");
	СоответствиеПараметров.Вставить("КПП",                		" КПП ");
	СоответствиеПараметров.Вставить("Свидетельство",			" ");
	СоответствиеПараметров.Вставить("СвидетельствоДатаВыдачи",	" от ");
	СоответствиеПараметров.Вставить("ЮридическийАдрес",   		" ");
	СоответствиеПараметров.Вставить("ФактическийАдрес",   		" ");
	СоответствиеПараметров.Вставить("Телефоны",           		" тел.: ");
	СоответствиеПараметров.Вставить("НомерСчета",         		" р/с ");
	СоответствиеПараметров.Вставить("Банк",               		" в банке ");
	СоответствиеПараметров.Вставить("БИК",                		" БИК ");
	СоответствиеПараметров.Вставить("КоррСчет",           		" к/с ");
	СоответствиеПараметров.Вставить("КодПоОКПО",          		" Код по ОКПО ");


	Список          = Список + ?(Прав(Список, 1) = ",", "", ",");
	ЧислоПараметров = СтрЧислоВхождений(Список, ",");

	Для Счетчик = 1 по ЧислоПараметров Цикл

		ПозЗапятой = Найти(Список, ",");

		Если ПозЗапятой > 0  Тогда
			ИмяПараметра = Лев(Список, ПозЗапятой - 1);
			Список = Сред(Список, ПозЗапятой + 1, СтрДлина(Список));

			Попытка
				СтрокаДополнения = "";
				СписокСведений.Свойство(ИмяПараметра, СтрокаДополнения);

				Если ПустаяСтрока(СтрокаДополнения) Тогда
					Продолжить;
				КонецЕсли;

				Префикс = СоответствиеПараметров[ИмяПараметра];
				Если Не ПустаяСтрока(Результат)  Тогда
					Результат = Результат + ",";
				КонецЕсли; 

				Результат = Результат + ?(СПрефиксом = Истина, Префикс, "") + СтрокаДополнения;
			Исключение
				Сообщить("Не удалось определить значение параметра организации: " + ИмяПараметра, СтатусСообщения.Внимание);
			КонецПопытки;

		КонецЕсли;

	КонецЦикла;

	Возврат СокрЛП(Результат);

КонецФункции // ОписаниеОрганизации()
Показать


Хотябы НаименованиеСокращенное вродебы как должен показывать, не показывает и в ошибку не выпадает.
12. Caspersky 29.12.16 11:18 Сейчас в теме
(11)
Дам наводку...
1. А в структуре "СписокСведений" есть элемент с таким ключем...
2. см. процедуру формирования структуры "СписокСведений"
DeniskinMENZ; +1 Ответить
13. DeniskinMENZ 05.01.17 22:13 Сейчас в теме
(12)Спасибо, что пнул в нужное направление.
Вообщем под комментарием не посмотрел а там написано: СписокСведений формируется функцией СведенияОЮрФизЛице, провалился туда а там наименование в справочнике контрагента прописано как "Представление" вообщем вот так сделал и все норм

ОбластьМакета.Параметры.ПредставлениеГрузополучателя = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузополучателе, "ПолноеНаименование,ИНН,Представление,ФактическийАдрес,Телефоны,НомерСчета,Банк,БИК,КоррСчет");


Всем спасибо!

ЗЫ С Новым Годом! Рождеством!
Оставьте свое сообщение
Все разделы

Вакансии


Программист 1С
Москва
зарплата от 100 000 руб. до 200 000 руб.
Полный день

Преподаватель 1С
Санкт-Петербург
Полный день

Удаленный ИТ-журналист
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата от 80 000 руб. до 150 000 руб.
Полный день