Артёменко Максим | Директор, ведущий разработчик, архитектор 1С | ООО "Арт Порт"

«Практика создания модульных отраслевых конфигураций на БСП с общими библиотеками методов и метаданных на примере программного комплекса "Арт:Порт"»

Будет рассмотрена история и методы создания системы отраслевых конфигураций, одной из особенностей которых является изначальная нацеленность на возможное слияние и комплектование модулей для поставки Заказчику. Рассмотрим, в каких случаях модули системы являются частью типовых конфигураций, а в каких пишутся "с нуля" на БСП; как используется технология иерархии библиотек, описанная в БСП; с какими трудностями пришлось столкнуться, чтобы добиться обобщения правил разработки каждой команды для совместимости всех модулей комплекса.

Сохранить значения колонки (Обычные формы)

1. BigBoss 3 24.12.16 11:25 Сейчас в теме
Здравствуйте. Вопрос вот в чём: есть форма документа документа, в нём есть ТЧ. В ней же есть колонка "ИнвНомер" которая заполняется как я понял вот так:
Процедура ОСПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
	Если ЭлементыФормы.ОС.Колонки.ИнвентарныйНомер.Видимость Тогда
	ОформлениеСтроки.Ячейки.ИнвентарныйНомер.УстановитьТекст(ПолучитьОС_ИнвентарныйНомер(ДанныеСтроки.ОсновноеСредство));		
	КонецЕсли;	
КонецПроцедуры


Самих строк в ТЧ может быть несколько. И вот нужно сохранить значение этой колонки. Но она не сохраняет его.
Пробовал так : Добавил реквизит "ИнвентарныйНомерТУ" в тч, добавил на форму, прописал так:
Для Каждого Стр Из ОС Цикл 
		Стр.ИнвентарныйНомерТУ = ПолучитьОС_ИнвентарныйНомер(ДанныеСтроки.ОсновноеСредство);	  
		  КонецЦикла;


И если строк в тч много, то данная колонка заполняется одинаковыми значениями но запись происходит.
Пробовал так:
//Если ЭлементыФормы.ОС.Колонки.ИнвентарныйНомерТУ.Видимость Тогда
// ОформлениеСтроки.Ячейки.ИнвентарныйНомерТУ.УстановитьТекст(ПолучитьОС_ИнвентарныйНомер(ДанныеСтроки.ОсновноеСредство));
//КонецЕсли;

Если строк в тч много, то заполняется разными как положено, но данные НЕ СОХРАНЯЮТСЯ.
Как быть??? Обычные формы, 8.2
Найденные решения
2. YNik 24.12.16 11:36 Сейчас в теме
(1)
Для Каждого Стр Из ОС Цикл
Стр.ИнвентарныйНомерТУ = ПолучитьОС_ИнвентарныйНомер(ДанныеСтроки.ОсновноеСредство);
КонецЦикла;

Для Каждого Стр Из ОС Цикл 
        Стр.ИнвентарныйНомерТУ = ПолучитьОС_ИнвентарныйНомер(Стр.ОсновноеСредство);      
КонецЦикла;
Остальные ответы
Сортировка: Древо
2. YNik 24.12.16 11:36 Сейчас в теме
(1)
Для Каждого Стр Из ОС Цикл
Стр.ИнвентарныйНомерТУ = ПолучитьОС_ИнвентарныйНомер(ДанныеСтроки.ОсновноеСредство);
КонецЦикла;

Для Каждого Стр Из ОС Цикл 
        Стр.ИнвентарныйНомерТУ = ПолучитьОС_ИнвентарныйНомер(Стр.ОсновноеСредство);      
КонецЦикла;
3. BigBoss 3 24.12.16 12:33 Сейчас в теме
4. Fox-trot 54 24.12.16 14:07 Сейчас в теме
(3) рекомендую смотреть на свои труды через призму отладчика
Оставьте свое сообщение
Все разделы

Вакансии


Программист 1С
Москва
зарплата от 100 000 руб. до 200 000 руб.
Полный день

Преподаватель 1С
Санкт-Петербург
Полный день

Удаленный ИТ-журналист
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата от 80 000 руб. до 150 000 руб.
Полный день