1. BigBoss 3 24.12.16 11:25 Сейчас в теме

Сохранить значения колонки (Обычные формы)

Здравствуйте. Вопрос вот в чём: есть форма документа документа, в нём есть ТЧ. В ней же есть колонка "ИнвНомер" которая заполняется как я понял вот так:
Процедура ОСПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
	Если ЭлементыФормы.ОС.Колонки.ИнвентарныйНомер.Видимость Тогда
	ОформлениеСтроки.Ячейки.ИнвентарныйНомер.УстановитьТекст(ПолучитьОС_ИнвентарныйНомер(ДанныеСтроки.ОсновноеСредство));		
	КонецЕсли;	
КонецПроцедуры


Самих строк в ТЧ может быть несколько. И вот нужно сохранить значение этой колонки. Но она не сохраняет его.
Пробовал так : Добавил реквизит "ИнвентарныйНомерТУ" в тч, добавил на форму, прописал так:
Для Каждого Стр Из ОС Цикл 
		Стр.ИнвентарныйНомерТУ = ПолучитьОС_ИнвентарныйНомер(ДанныеСтроки.ОсновноеСредство);	  
		  КонецЦикла;


И если строк в тч много, то данная колонка заполняется одинаковыми значениями но запись происходит.
Пробовал так:
//Если ЭлементыФормы.ОС.Колонки.ИнвентарныйНомерТУ.Видимость Тогда
// ОформлениеСтроки.Ячейки.ИнвентарныйНомерТУ.УстановитьТекст(ПолучитьОС_ИнвентарныйНомер(ДанныеСтроки.ОсновноеСредство));
//КонецЕсли;

Если строк в тч много, то заполняется разными как положено, но данные НЕ СОХРАНЯЮТСЯ.
Как быть??? Обычные формы, 8.2
Найденные решения
2. YNik 24.12.16 11:36 Сейчас в теме
(1)
Для Каждого Стр Из ОС Цикл
Стр.ИнвентарныйНомерТУ = ПолучитьОС_ИнвентарныйНомер(ДанныеСтроки.ОсновноеСредство);
КонецЦикла;

Для Каждого Стр Из ОС Цикл 
        Стр.ИнвентарныйНомерТУ = ПолучитьОС_ИнвентарныйНомер(Стр.ОсновноеСредство);      
КонецЦикла;
Остальные ответы
Избранное Подписка Сортировка: Древо
2. YNik 24.12.16 11:36 Сейчас в теме
(1)
Для Каждого Стр Из ОС Цикл
Стр.ИнвентарныйНомерТУ = ПолучитьОС_ИнвентарныйНомер(ДанныеСтроки.ОсновноеСредство);
КонецЦикла;

Для Каждого Стр Из ОС Цикл 
        Стр.ИнвентарныйНомерТУ = ПолучитьОС_ИнвентарныйНомер(Стр.ОсновноеСредство);      
КонецЦикла;
3. BigBoss 3 24.12.16 12:33 Сейчас в теме
4. Fox-trot 109 24.12.16 14:07 Сейчас в теме
(3) рекомендую смотреть на свои труды через призму отладчика
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Чебоксары
зарплата от 50 000 руб. до 70 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 80 000 руб. до 120 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 110 000 руб. до 150 000 руб.
Полный день

Программист 1С
Москва
зарплата до 160 000 руб.
Полный день

Консультант 1С
Москва
зарплата от 100 000 руб. до 140 000 руб.
Временный (на проект)