Сохранить значения колонки (Обычные формы)

1. 2 24.12.16 11:25 Сейчас в теме
Здравствуйте. Вопрос вот в чём: есть форма документа документа, в нём есть ТЧ. В ней же есть колонка "ИнвНомер" которая заполняется как я понял вот так:
Процедура ОСПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
	Если ЭлементыФормы.ОС.Колонки.ИнвентарныйНомер.Видимость Тогда
	ОформлениеСтроки.Ячейки.ИнвентарныйНомер.УстановитьТекст(ПолучитьОС_ИнвентарныйНомер(ДанныеСтроки.ОсновноеСредство));		
	КонецЕсли;	
КонецПроцедуры


Самих строк в ТЧ может быть несколько. И вот нужно сохранить значение этой колонки. Но она не сохраняет его.
Пробовал так : Добавил реквизит "ИнвентарныйНомерТУ" в тч, добавил на форму, прописал так:
Для Каждого Стр Из ОС Цикл 
		Стр.ИнвентарныйНомерТУ = ПолучитьОС_ИнвентарныйНомер(ДанныеСтроки.ОсновноеСредство);	  
		  КонецЦикла;


И если строк в тч много, то данная колонка заполняется одинаковыми значениями но запись происходит.
Пробовал так:
//Если ЭлементыФормы.ОС.Колонки.ИнвентарныйНомерТУ.Видимость Тогда
// ОформлениеСтроки.Ячейки.ИнвентарныйНомерТУ.УстановитьТекст(ПолучитьОС_ИнвентарныйНомер(ДанныеСтроки.ОсновноеСредство));
//КонецЕсли;

Если строк в тч много, то заполняется разными как положено, но данные НЕ СОХРАНЯЮТСЯ.
Как быть??? Обычные формы, 8.2
Найденные решения
2. YNik 24.12.16 11:36 Сейчас в теме
(1)
Для Каждого Стр Из ОС Цикл
Стр.ИнвентарныйНомерТУ = ПолучитьОС_ИнвентарныйНомер(ДанныеСтроки.ОсновноеСредство);
КонецЦикла;

Для Каждого Стр Из ОС Цикл 
        Стр.ИнвентарныйНомерТУ = ПолучитьОС_ИнвентарныйНомер(Стр.ОсновноеСредство);      
КонецЦикла;
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. YNik 24.12.16 11:36 Сейчас в теме
(1)
Для Каждого Стр Из ОС Цикл
Стр.ИнвентарныйНомерТУ = ПолучитьОС_ИнвентарныйНомер(ДанныеСтроки.ОсновноеСредство);
КонецЦикла;

Для Каждого Стр Из ОС Цикл 
        Стр.ИнвентарныйНомерТУ = ПолучитьОС_ИнвентарныйНомер(Стр.ОсновноеСредство);      
КонецЦикла;
3. BigBoss 2 24.12.16 12:33 Сейчас в теме
4. Fox-trot 142 24.12.16 14:07 Сейчас в теме
(3) рекомендую смотреть на свои труды через призму отладчика
Оставьте свое сообщение
Вакансии
Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Автор новостей об 1С, налогах и бухучете на INFOSTART.RU
Санкт-Петербург
По совместительству

Программист 1С
Екатеринбург
зарплата от 50 000 руб.
По совместительству

Ведущий разработчик 1С (техлид внутреннего учета)
Новосибирск
зарплата от 230 000 руб.
Полный день

Программист 1С
Рязань
зарплата от 150 000 руб. до 250 000 руб.
Полный день