INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Кучма Дмитрий | Руководитель сектора программирования | Консорциум "Беркат"

«Автоматизация сети магазинов, централизация. Методика, приёмы, обучение персонала, решение проблем.»

- Причины необходимости автоматизации сети супермаркетов (ввиду децентрализации - большие затраты на персонал, снижение эффективности, отсутствие инструментов у руководителей служб и учредителей влиять на ситуацию в магазинах, плохой контроль распределения финансовых потоков и состояние фирмы в целом). - Выбор подходящего программного обеспечения, торгового оборудования, максимально эффективные и малозатратные сопряжения имеющегося оборудования и бизнес-процессов магазина с новой программой. - Определение сроков, команды внедрения, цели и задачи, средние и глобальные. - Подготовка к проекту, закуп оборудования (возможно, перетяжка сетей и замена оборудования), выбор оборудования с расчетом многолетней эксплуатации, достаточного запаса прочности. - Непосредственное внедрение, инвентаризация, ввод остатков, введение карточек товара, работа с операторами и обучение персонала. - Работа с бухгалтерской службой, настройка планов обмена, обучение персонала. - Работа с коммерческим отделом, установки цен, акции, ценники, закуп у поставщиков, категорийный менеджмент, взаимодействие с поставщиками, система лояльности покупателей. - Работа со службами магазина, по приемке товара, этикетированию, фасовкой, электронными весами, обучение кассиров и старшего кассира. -Сопровождение программы в течение первых месяцев, отладка взаимодействия служб, разбор проблем и задач. Заключение.

1. unlstu 16.12.16 17:40 Сейчас в теме

Не очищаются пользовательские настройки отчета

В модуле объекта отчета на СКД указан вариант настроек, который должен вызываться по умолчанию.
У одного пользователя вызывается другой вариант, причем независимого с какого компьютера заходить. Очистка хранилища настроек для данного пользователя и локального кэша ошибку не исправила.
Конфа самописная на основе БСП 2.2.2.48. Модули сохранения настроек не переписывались. В чем может быть причина?
Найденные решения
9. unlstu 22.12.16 12:32 Сейчас в теме
Решение оказалось таким: при первом открытии отчета по умолчанию в форме подставляется вариант, который указан в основной СКД первым. Жестко установил значение переменной КлючТекущегоВарианта ="ИмяНужногоВарианта" в процедуре ПриСозданииНаСервере формы отчета.
Остальные ответы
Сортировка: Древо
2. alxarz 29 16.12.16 17:47 Сейчас в теме
(1)
Очистка хранилища настроек для данного пользователя и локального кэша ошибку не исправила.
раз продолжает вызываться не тот вариант, возникает вопрос а что же тогда очистили?
4. unlstu 16.12.16 17:53 Сейчас в теме
(2) Код очистки такой:
Для каждого СтрНастройка Из НастройкиПользователей Цикл
		
	УдалитьНастройкиНаСервере(СтрНастройка.КлючОбъекта,СтрНастройка.КлючНастроек,СтрНастройка.Пользователь);
		
КонецЦикла;


Настройки пользователя получаем так:

Процедура ПолучитьНастройкиНаСервере()
	
	НастройкиПользователей.Очистить();
	
	Если Пользователь = "" и ИмяНастройки = "" Тогда
		Выборка = ХранилищеСистемныхНастроек.Выбрать();
	ИначеЕсли НЕ Пользователь = "" Тогда
		СтруктураОтбора = Новый Структура;
		СтруктураОтбора.Вставить("Пользователь",Пользователь);
		
		Если ЗначениеЗаполнено(КлючОбъекта) Тогда
			СтруктураОтбора.Вставить("КлючОбъекта",КлючОбъекта);
		КонецЕсли;
		
		Выборка = ХранилищеСистемныхНастроек.Выбрать(СтруктураОтбора);
	Иначе 
		СтруктураОтбора = Новый Структура;
		СтруктураОтбора.Вставить("КлючОбъекта",ИмяНастройки);
		Выборка = ХранилищеСистемныхНастроек.Выбрать(СтруктураОтбора);	
	КонецЕсли;
	
	Пока Выборка.Следующий() Цикл
		
		СтрокаТЧ = НастройкиПользователей.Добавить();
		ЗаполнитьЗначенияСвойств(СтрокаТЧ,Выборка);
		
	КонецЦикла;
КонецПроцедуры
Показать
3. herfis 257 16.12.16 17:52 Сейчас в теме
Подсистема "Варианты отчетов" (или как там ее) используется?
5. unlstu 16.12.16 17:54 Сейчас в теме
(3) Подсистема используется, но для этого отчета варианты отключены на уровне кода.
6. herfis 257 16.12.16 17:56 Сейчас в теме
(5) Это как это "на уровне кода"?
По дефолту альтернативное хранилище вариантов прописывается кажись в свойствах конфы и автоматически применяется ко всем отчетам.
7. unlstu 16.12.16 17:58 Сейчас в теме
(6) Хранилище вариантов системное. По отключению имеется в виду, что свой вариант не создать.
8. herfis 257 16.12.16 18:00 Сейчас в теме
(7) Странно. Подсистема "Варианты отчетов" подразумевает использование альтернативного хранилища вариантов. И если оно прописано в свойствах конфы, то системное использоваться не будет.
9. unlstu 22.12.16 12:32 Сейчас в теме
Решение оказалось таким: при первом открытии отчета по умолчанию в форме подставляется вариант, который указан в основной СКД первым. Жестко установил значение переменной КлючТекущегоВарианта ="ИмяНужногоВарианта" в процедуре ПриСозданииНаСервере формы отчета.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Одесса (Украина)
зарплата от 40 000 руб.
Полный день

Программист 1С
Санкт-Петербург
Полный день

Аналитик 1С
Москва
зарплата от 80 000 руб. до 120 000 руб.
Полный день

1С Developer
Одесса (Украина)
зарплата от 60 000 руб. до 120 000 руб.
Полный день

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 70 000 руб. до 90 000 руб.
Полный день