1. Salavat 12 16.04.16 16:11 Сейчас в теме

Имя Варианта Отчёта СКД -

Создал отчёт в СКД.
сам отчёт - не сложный/большой.
но вот с Вариантами настроек отчёта - я не вкурил:

по умолчанию создаётся один - Основной.
такое название ни о чём не говорит, по этому изменил в конфигураторе "Основной" (Имя Варианта и Представление) на - "Парам пам пам".

открываю в режиме предприятия - там всё-равно "Основной".

Как сделать-то название варианта, чтоб оно именно "Парам пам пам" было?

объясните пожалуйста.
Ответы
Избранное Подписка Сортировка: Древо
28. Поручик 4147 21.04.16 15:30 Сейчас в теме
(1) Ищите в гугле "Добавление нового варианта для встроенного отчета на СКД для конфигураций на БСП 2.1.X и позднее" или "Обновление предопределенных вариантов отчетов."
29. vovan_victory 59 22.04.16 08:14 Сейчас в теме
(28) Поручик, ну у него же внешний отчет. Там должно и так работать
illUMI; Salavat; +2 Ответить
2. Salavat 12 16.04.16 16:17 Сейчас в теме
если что - конфигурация УТ 11.2.119.
платформа - 8.3.7.2027
(но и - на предыдущих не мог изменить/сохранить/задать это имя варианта)
3. Salavat 12 16.04.16 16:49 Сейчас в теме
Попробовал добавить ещё один Вариант - нифига.
всё-равно при открытии отчёта (в режиме Предприятия) - только один "Основной".

я не пойму - так что нельзя чтоли без писания в модуле, варианты задать?
исходные/стандартные.
4. Salavat 12 16.04.16 17:04 Сейчас в теме
вобщем - ... (((
нашёл - http://1c-pro.ru/threads/vybor-varianta-otcheta-vo-vneshnem-otchete.35272/
Надо открыть отчет в пользовательском режиме. Сохранить два варианта отчета - Движения товаров и Остатки товаров (через меню Все действия - Сохранить вариант).
Понятно, что сейчас они будут одинаковыми.
Теперь понадобится обработка типа "Групповая обработка справочников и документов", которой, насколько я знаю, нет в УТ 11 :rolleyes: :)) Или "Универсальный подбор и обработка объектов" с диска ИТС. Но т.к. она для обычного приложения, то чтобы воспользоваться ей, надо запустить базу в обычном режиме. Либо поискать в инете...я видел такую обработку для управляемого приложения.
Вот, с помощью этой обработки в справочнике "Варианты отчетов" в вариантах, которые сохранили, надо поменять значение реквизита "КлючВарианта".
А именно установить там имя варианта как оно задано в конфигураторе в схеме компоновки данных.


вобщем я понял - капец просто.

может можно всёже сделать отчёт с двумя стандартными настройками?
чтоб просто - открыть отчёт и пользоваться этими вариантами.
без - каких либо мытарств.
5. vovan_victory 59 16.04.16 22:32 Сейчас в теме
(4) Salavat, посмотри что в модуль менеджера

Процедура НастроитьВариантыОтчета(Настройки, НастройкиОтчета) Экспорт
	МодульВариантыОтчетов = ОбщегоНазначения.ОбщийМодуль("ВариантыОтчетов");
	МодульВариантыОтчетов.УстановитьРежимВыводаВПанеляхОтчетов(Настройки, НастройкиОтчета, Ложь);
	
	НастройкиВарианта = МодульВариантыОтчетов.ОписаниеВарианта(Настройки, НастройкиОтчета, "Основной");
	НастройкиВарианта.Включен = Ложь;
	НастройкиВарианта.Описание = НСтр("ru = 'Поиск мест использования объектов приложения.'");
КонецПроцедуры


Именно результат этой процедуры потом появляется в вариантах отчетов
6. Salavat 12 17.04.16 05:03 Сейчас в теме
(5) vovan_victory, это у менеджера чего смотреть?
да и - что с увиденным делатьто?
конфигурация типовая - менять её не будем.
7. vovan_victory 59 17.04.16 10:14 Сейчас в теме
Salavat , я всего лишь ответил на вопрос: почему не появляются варианты отчетов и что/где можно посмотреть,а что с этим делать, решайте сами.

Р\С
Скажу больше. Перерегистрация вариантов отчетов происходит при смене релиза, т.е при обновлении. Можно попробовать поискать процедуру обновления вариантов и проанализировать на предмат нельзя ли впихнуть туда внешний отчет.. ну и запустить ее отдельно. Я так делал(запускал ее отдельно). А вообще,смотрите сервисные обработки, которые идут в БСП. Там, по моему есть готовая обработка
8. Salavat 12 17.04.16 14:51 Сейчас в теме
(7) vovan_victory,
смотрите сервисные обработки, которые идут в БСП. Там, по моему есть готовая обработка
так - куда смотретьто?
и - что там искать?

мне просто нужен был отчёт с двумя вариантами.
которые не нужно былоб колдовать, чтоб работали.
9. artfa 28 17.04.16 15:12 Сейчас в теме
переименуйте отчет - имя в самом верхнем окне внешнего отчета, и загрузите в базу,
или может помочь восстановление стандартных настроек и перевыбор варианта
10. Salavat 12 17.04.16 15:40 Сейчас в теме
(9) artfa, конфигурацию - менять не будем.
нужно - типовой оставить её.
12. artfa 28 17.04.16 16:33 Сейчас в теме
(10) Salavat, так вы пишите "создал отчет СКД", создать можно только новый или внешний отчет,
попробуйте "восстановление стандартных настроек и перевыбор варианта"
16. Salavat 12 17.04.16 17:50 Сейчас в теме
(12) artfa, да, похоже забыл упомянуть - отчёт внешний делаю.
17. artfa 28 17.04.16 18:06 Сейчас в теме
(16) Salavat, так переименуйте тут и загрузите в базу
18. Salavat 12 17.04.16 18:46 Сейчас в теме
(17) artfa, переименовал и имя и синоним.
а как оно/они влияют на вариант?
19. Salavat 12 17.04.16 18:46 Сейчас в теме
(17) artfa, да и - я говорил уже - базу надо оставить типовой!
20. artfa 28 17.04.16 21:20 Сейчас в теме
(19) Salavat, че то я совсем уже запутался, вы пишите что делаете внешний отчет, потом пишите что базу нужно оставить типовой,
вы определитесь где вы делаете отчет,
(18) Salavat, сохраняются настройки отчета в хранилище настроек и восстанавливаются при его открытии, поэтому чтобы их сбросить самый короткий путь это переименовать отчет
21. Salavat 12 18.04.16 05:00 Сейчас в теме
(20) artfa, повторяю:
1. Мне нужно в типовую конфу добавить внешний отчёт.
2. У этово внешнего отчёта - хотел сделать дтри варианта настроек отчёта.

п.1 - сделал.
п.2 - не выходит.
22. Salavat 12 18.04.16 05:04 Сейчас в теме
(20) artfa,
сохраняются настройки отчета в хранилище настроек и восстанавливаются при его открытии, поэтому чтобы их сбросить самый короткий путь это переименовать отчет
да - это я тоже видел - в справочнике ВариантыОтчетов.
но вот как мне сделать, чтоб те варианты, которые я создал в конфигураторе, были доступны в режиме предприятия?

что непонятного я спрашиваю?
и спрашивал изначально.
23. vovan_victory 59 21.04.16 11:25 Сейчас в теме
(22) Salavat, а я вот что то не увидел уточнения.... а отчет то сделан на каких формах? Форма то управляемая или нет?
Есть ощущение, что Вы пытаетесь добиться результат в простых формах. Если это так, то зря стараетесь. На простых формах вывести варианты отчета без кодинга не получится.

Для не управляемой формы я делал так:

Процедура _СменаВариантаНастройки (Элемент)
	Для каждого Настройка Из СхемаКомпоновкиДанных.ВариантыНастроек Цикл
		
		Если Элемент.Текст = Настройка.Представление тогда
			
			КомпоновщикНастроек.ЗагрузитьНастройки(Настройка.Настройки);
			
			КомпоновщикНастроек.Настройки.ДополнительныеСвойства.Вставить("ТекущийВариантОтчета",Настройка.Имя);
			
			УстановитьЗаголовокОТчета(Настройка.Представление);
			Прервать;
			
		КонецЕсли;
		
	КонецЦикла;
	
	Если ЗначениеЗаполнено(НачалоПериода) ИЛИ ЗначениеЗаполнено(КонецПериода) Тогда
		ТиповыеОтчеты.ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек, ЭтаФорма);
	КонецЕсли; 
	НастроитьКомпановщик();	
КонецПроцедуры

Процедура УстановитьВариантыНастроек()
	
	КП = ЭлементыФормы.ДействияФормы; 
	КП.Кнопки.Вставить(1,"_Разделитель", ТипКнопкиКоманднойПанели.Разделитель);
	НоваяКнопка = КП.Кнопки.Вставить(1,"_ВариантыОтчетов", ТипКнопкиКоманднойПанели.Подменю, "Варианты отчетов", ); 
	НовоеДействие = Новый Действие("_СменаВариантаНастройки"); ч = 1;
	
	Для каждого Настройка Из СхемаКомпоновкиДанных.ВариантыНастроек Цикл
		
		НоваяКнопка = КП.Кнопки._ВариантыОтчетов.Кнопки.Добавить("Вариант"+Строка(ч), ТипКнопкиКоманднойПанели.Действие, Настройка.Представление, НовоеДействие);
		ч = ч + 1;
		
	КонецЦикла;
	
	УстановитьЗаголовокОТчета(СхемаКомпоновкиДанных.ВариантыНастроек[0].Представление);
	КомпоновщикНастроек.Настройки.ДополнительныеСвойства.Вставить("ТекущийВариантОтчета",СхемаКомпоновкиДанных.ВариантыНастроек[0].Имя);
КонецПроцедуры
Показать
24. Salavat 12 21.04.16 14:45 Сейчас в теме
(23) vovan_victory, УТ 11.2.119 - она на УФ, да.
25. Salavat 12 21.04.16 14:47 Сейчас в теме
26. vovan_victory 59 21.04.16 14:52 Сейчас в теме
(25) Salavat, а подключаете как? Через дополнительные обработки или через расширения?
27. Salavat 12 21.04.16 15:07 Сейчас в теме
(26) vovan_victory, и через доп-обработки пробовал.
и просто файл-открыть.

без разницы.
13. vovan_victory 59 17.04.16 16:38 Сейчас в теме
(10) Salavat,
Прикрепленные файлы:
15. Salavat 12 17.04.16 17:35 Сейчас в теме
(13) vovan_victory, да - я и так пробовал изначально.
был всегда один только - Основной который.
пробовал (сразу) переименовать Основной - ничего не меняло абсолютно.
всегда один только - Основной называется.
11. vovan_victory 59 17.04.16 16:32 Сейчас в теме
Хотя, сейчас посмотрел свои отчеты все ок. Вы пробовали как рекомендовал artfa восстановить стандартные настройки?
14. Salavat 12 17.04.16 17:33 Сейчас в теме
(11) vovan_victory, (12) artfa, пробовал восстанавливать - никак вообще не меняет.
два варианта в конфигураторе делал (с переименовыванием их).
в Предприятии всегда один - Основной.
32. Yuri1988 09.07.18 10:37 Сейчас в теме
(14)
а в конфигураторе делал (с переименовыванием их).
в Предприятии всегда один - Ос

Если после изменения представления в СКД, наименование не поменялось. Достаточно запустить обновление базы. Для этого запускаем базу с параметром "/С ЗапуститьОбновлениеИнформационнойБазы"
Прикрепленные файлы:
30. dnrocco 29.11.17 03:50 Сейчас в теме
Толкну трупик...
тоже искал что делать с названием варианта отчета - оказалось достаточно изменить в СКД на закладке настройки представление (можно и имя) варианта.
Прикрепленные файлы:
AndrewKop; user684193_mavr; Tiff; +3 Ответить
31. user598655_ilia-bers 07.12.17 14:53 Сейчас в теме
Может кто то подскажет еще от чего зависит, будет ли в заголовке окна отчета выводиться только имя варианта или ИмяОтчета+ИмяВарианта, в нашей базе много внешних отчетов, и в основном выводится тольок имя варианта "Основной" (ну или другое имя), а в 2-х отчетах выводится Имяотчета+ИмяВарианта. Я их сравнивал везде лазил, но отличий в настройках так и не нашел.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Нижний Новгород
зарплата от 120 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 80 000 руб. до 100 000 руб.
Полный день

Системный аналитик
Новосибирск
зарплата от 80 000 руб. до 100 000 руб.
Полный день

Программист 1С
Салехард
зарплата от 80 000 руб. до 200 000 руб.
Полный день